Adium

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16630 closed defect (duplicate)

Yahoo IM won't connect and spikes CPU

Reported by: vapourick Owned by:
Milestone: Component: Service/Yahoo
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

Adium uses 140% CPU when attempting to connect to Yahoo (or possibly when attempting to connect to a service, but not succeeding.)

Steps to reproduce

Launch Adium 1.5.9 Within a few seconds, Adium uses all available CPU on the machine. Restarting Adium, the laptop, or the router does not help. Taking Adium offline (but still running) DOES restore normal CPU usage. Reconnecting to AIM does not cause a problem. Attempting to connect to Yahoo does cause the problem. The connection to Yahoo does not appear to succeed (after about 20 seconds it is still trying to connect), and CPU usage is at 140.9% Disconnecting from Yahoo restores normal CPU usage. Connecting to Google Chat does not cause a problem.

Expected results

Adium uses only a tiny amount of CPU

Actual results

Adium is using about 147% CPU on a 2.2 GHz Intel Core i7 Macbook Pro

Attachments (1)

adium.jpg (51.4 KB) - added by Eric Mitchell 6 years ago.

Download all attachments as: .zip

Change History (15)

Changed 6 years ago by Eric Mitchell

Attachment: adium.jpg added

comment:1 Changed 6 years ago by Josh Skidmore

I am having this problem as well. It's also referenced on ticket #16631.

comment:2 Changed 6 years ago by Robert

Keywords: yahoo cpu spike removed
Milestone: Adium 1.5.x
Resolution: duplicate
Severity: majornormal
Status: newclosed

Closed as duplicate of #16431.

comment:3 Changed 6 years ago by Eric Mitchell

This isn't right. This was closed because it's duplicate ticket (https://trac.adium.im/ticket/16431) CLOSED 4 weeks ago. The problem just started happening again several days ago.

a duplicate should only be closed if there's an open ticket for the same issue. Where is the open ticket this should reference so I can track progress?

comment:4 Changed 6 years ago by Thijs Alkemade

If you had actually read the linked ticket, you'd have noticed a fix has been committed and therefore is closed.

comment:5 in reply to:  3 Changed 6 years ago by Robert

The ticket is closed because the CPU spike is fixed in Adium source / in what will be Adium 1.5.10. We're confident the connection issue itself will be resolved by that as well.

comment:6 Changed 6 years ago by Josh Skidmore

vapourick - For now (until an official release happens), you can download the nightly version of 1.5.10 here: http://nightly.adium.im/?repo_branch=adium-adium-1.5.10 . This solved the issue for me.

comment:7 Changed 6 years ago by Robert

Thanks, Josh. We usually try to avoid pointing our users to nightly builds but it should be okay.

A 1.5.10 beta should be out shortly.

Last edited 6 years ago by Robert (previous) (diff)

comment:8 in reply to:  4 Changed 6 years ago by Eric Mitchell

Replying to sphynx:

If you had actually read the linked ticket, you'd have noticed a fix has been committed and therefore is closed.

sphynx, it might be helpful when closing to mention that's it's fixed instead of indicating a duplicate ticket that was closed 4 weeks ago or mention when the build will be released.

It's not unreasonable to expect it doesn't take 4 weeks to release a build and this might actually the same issue resurfacing as a new bug.

comment:9 in reply to:  7 Changed 6 years ago by Eric Mitchell

Replying to Robby:

Thanks, Josh. We usually try to avoid pointing our users to nightly builds but it should be okay.

A 1.5.10 beta should be out shortly.

great and thanks for the additional info. this is helpful

comment:10 in reply to:  6 Changed 6 years ago by Eric Mitchell

Replying to joshskidmore:

vapourick - For now (until an official release happens), you can download the nightly version of 1.5.10 here: http://nightly.adium.im/?repo_branch=adium-adium-1.5.10 . This solved the issue for me.

Thanks, this seems to be working for me so far. Thanks for the link.

comment:11 Changed 6 years ago by Josh Skidmore

Sorry guys ... just trying to help out!

comment:12 Changed 6 years ago by Robert

You're alright. :-)

comment:13 Changed 6 years ago by Mike Peck

I was having this problem (can't connect to Yahoo & cpu spike) on 1.5.10hgr5832, but switching to Adium_1.5.10b1r5848 solved the problem.

comment:14 in reply to:  13 Changed 6 years ago by Tupring

Replying to allnight:

I was having this problem (can't connect to Yahoo & cpu spike) on 1.5.10hgr5832, but switching to Adium_1.5.10b1r5848 solved the problem.

Still not working for me. I've tried 1.5.10b1r5848, 1.5.10b1r5855 and even 1.6hgr5852. I couldn't try 1.7hgr5854 as I'm using Snow Leopard… On a side note, the official Mac Yahoo Client connects and then immediately quits…

Note: See TracTickets for help on using tickets.