Adium

Opened 3 years ago

Closed 3 years ago

#16554 closed defect (fixed)

Some chat logs lose datestamps in 1.5.9 Transcript Viewer

Reported by: BiggusB Owned by:
Milestone: Adium 1.5.10 Component: Logging
Version: 1.5.9 Severity: regression
Keywords: Cc: wixardy
Patch Status:

Description

Summary

Starting only with 1.5.9, various historical chat logs have lost their datestamps as shown in the Chat Transcript Viewer.

Steps to reproduce

  1. Install 1.5.9
  2. Open Chat Transcript Viewer
  3. Note blanks in the "Date" field. (Optional: try sorting on date.)

Expected results

Each log entry would show a (correct) datestamp.

Actual results

There's a blank in the "Date" field in the viewer. Oddly, sorting on date doesn't put the blank logs at either the top or the bottom. In fact, the sorts don't seem to be chronological at all (although I'm not filing a separate ticket on that since I suspect it may be an artifact of this issue).

Regression

I noticed the problem under a pre-release version of 1.5.9 and again under release. It was not a problem with 1.5.8 and previous versions.

Notes

  1. This appears to be more of an issue with older AIM logs, although I identified some instances of older GTalk logs being affected as well. I can't say with authority, but it seems to be logs that are several years old. (I've been using Adium since 2006.)
  2. Rebuilding the index does not help. I tried this three times.
  3. Relaunching the app does not help.
  4. Reverting to 1.5.8 works fine. The logs show up normally there. An index rebuild is not necessary.

Change History (7)

comment:1 Changed 3 years ago by Robby

  • Cc wixardy added
  • Milestone changed from Adium bugs to Adium 1.5.10

comment:2 follow-up: Changed 3 years ago by mathuaerknedam

  • Status changed from new to pending

Does this only happen with messages that were logged while using 1.5.9 (beta or final)? Are the timestamps still missing if you switch back to 1.5.8? (You can download 1.5.8 here.)

comment:3 in reply to: ↑ 2 Changed 3 years ago by Robby

Both is mentioned in the description (unless I'm mistaken):

Replying to mathuaerknedam:

Does this only happen with messages that were logged while using 1.5.9 (beta or final)?

  1. This appears to be more of an issue with older AIM logs, although I identified some instances of older GTalk logs being affected as well. I can't say with authority, but it seems to be logs that are several years old. (I've been using Adium since 2006.)

Are the timestamps still missing if you switch back to 1.5.8? (You can download 1.5.8 here.)

  1. Reverting to 1.5.8 works fine. The logs show up normally there. An index rebuild is not necessary.

comment:4 Changed 3 years ago by mathuaerknedam

You're right! Sorry for the noise. :)

comment:5 Changed 3 years ago by mathuaerknedam

  • Status changed from pending to new

comment:7 Changed 3 years ago by sphynx

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in aed198ae15cb.

Note: See TracTickets for help on using tickets.