Adium

Opened 14 years ago

Closed 9 years ago

Last modified 9 years ago

#1654 closed enhancement (fixed)

Difficult to delete/forget known fingerprints.

Reported by: Cortland Klein <me@pixelcort.com> Owned by:
Milestone: Adium 1.5 Component: Adium Core
Version: 1.0svn Severity: minor
Keywords: OTR Off-The-Record Encryption preferences prefs fingerprint list Cc:
Patch Status: Accepted

Description

Currently, the only way to delete/forget a known fingerprint is to select it, click Show Fingerprint, and click Forget Fingerprint. Instead, a button next to Show Fingerprint labeled "Forget Fingerprint" or "Delete Fingerprint" should be provided.

Attachments (3)

OTRButtonPatch.diff (18.7 KB) - added by aleksei 10 years ago.
OTRFingerprintDetailsWindow.nib.zip (5.8 KB) - added by aleksei 10 years ago.
Removed the button from here…
OTRPrefs.nib.zip (9.0 KB) - added by aleksei 10 years ago.
Added the button here

Download all attachments as: .zip

Change History (20)

comment:1 Changed 14 years ago by boredzo

  • Keywords OTR Off-The-Record Encryption preferences prefs fingerprint list added
  • priority changed from lowest to normal

please don't set priority.

comment:2 Changed 14 years ago by anonymous

I agree. I'm having difficulty with one of my contacts. Everytime I IM I get this encrypted chat deal which neither of intended. How can I fix this?

comment:3 Changed 14 years ago by evands

  • field_haspatch set to 0

anonymous, your comment is irrelevant to this ticket :)

comment:4 Changed 13 years ago by tick

  • Milestone set to Adium X 1.1

Moving to 1.1 for now

comment:6 Changed 13 years ago by tick

  • Milestone changed from Adium X 1.1 to Adium X 1.2

comment:7 Changed 13 years ago by tick

  • Milestone changed from Adium X 1.2 to Sometime after 1.0

comment:8 Changed 12 years ago by djmori

comment:8 Changed 11 years ago by Robby

  • Component changed from Adium UI to OTR
  • Patch Status set to None
  • pending set to 0

comment:9 Changed 11 years ago by Robby

  • Type changed from defect to enhancement

This would be an improvement. As it stands it is not a bug.

comment:10 Changed 11 years ago by zacw

  • Component changed from OTR to Adium Core

Removing 'OTR' component.

Changed 10 years ago by aleksei

Changed 10 years ago by aleksei

Removed the button from here...

Changed 10 years ago by aleksei

Added the button here

comment:11 Changed 10 years ago by aleksei

Added three files relevant to closing this issue. The OTRPrefs.nib is located in several localization folders, but as now its versions are essentially the same, so the same file can be just copied around.

comment:12 Changed 10 years ago by Robby

  • Milestone changed from Good idea for "later" to Adium 1.4
  • Patch Status set to Needs Dev Review

Thanks! :)

comment:13 Changed 10 years ago by zacw

  • Milestone changed from Adium 1.4 to Adium 1.5

Pushing back for review later.

comment:14 Changed 9 years ago by Robby

  • Owner nobody deleted

comment:15 Changed 9 years ago by Aleksei Gorny

  • Resolution set to fixed
  • Status changed from new to closed

(In 1190bca3e731) Move the 'Forget Fingerprint' button to be under the fingerprints list.

With help from wixardy. Fixes #1654

comment:16 Changed 9 years ago by wixardy

  • Patch Status changed from Needs Dev Review to Accepted

comment:17 Changed 9 years ago by Robert Vehse

(In 48c5b6b69d35) Credit "aleksei" in Copyright.txt. Refs #1654.

Note: See TracTickets for help on using tickets.