Adium

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16502 closed defect (fixed)

User icons in "Stockholm" blank after upgrading to OS X 10.9

Reported by: tonyc Owned by:
Milestone: Adium 1.5.9 Component: Adium Core
Version: 1.5.8 Severity: normal
Keywords: 10.9 Mavericks Cc:
Patch Status:

Description

Summary

After upgrading to OSX 10.9 (Mavericks), user profile icons show up blank in chat windows.

Steps to reproduce

  1. Upgrade to 10.9
  2. Launch Adium

Expected results

I expect to see profile pictures in chats: myself, as well as my contacts.

Actual results

The user profile image is a blank (grey) box.

Notes

I am using the "Stockholm" message theme. If I switch to other themes, pictures of my contacts show up, but my own profile picture is blank as well.

Profile pictures correctly show up when I mouse-hover over the contacts in the contact list.

Attachments (1)

uy112736kl6dsau.jpg (26.4 KB) - added by tonyc 3 years ago.

Download all attachments as: .zip

Change History (16)

Changed 3 years ago by tonyc

comment:1 Changed 3 years ago by Robby

We have a possible fix we need to test for regressions: https://hg.adium.im/xtras/mathuaerknedam/rev/ed15d8592d8c.

The issue indeed seems to be limited to Stockholm so I would suggest using a different message style for the moment.

Last edited 3 years ago by mathuaerknedam (previous) (diff)

comment:2 Changed 3 years ago by Robby

  • Milestone set to Adium 1.5.9

comment:3 Changed 3 years ago by tonyc

I applied this patch to my local copy, and it appears to fix the problem.

comment:4 Changed 3 years ago by Robby

Thanks for letting us know, Tony. :-) Please alert us should you find any issues which could be attributed to the change.

comment:5 Changed 3 years ago by Robby

  • Summary changed from GTalk avatars in chat windows blank after upgrading to OSX 10.9 to User icons in "Stockholm" blank after upgrading to OS X 10.9

comment:6 Changed 3 years ago by mathuaerknedam

  • Summary changed from User icons in "Stockholm" blank after upgrading to OS X 10.9 to GTalk avatars in chat windows blank after upgrading to OSX 10.9

The problem appears in The WebKit with Safari 6.1 and Safari 7. I've checked the change with those and WebKit (Safari) 6.0.5 and it doesn't appear to cause any problems. This was a quick check without any real chatting, so more testing would be wise.

Last edited 3 years ago by mathuaerknedam (previous) (diff)

comment:7 Changed 3 years ago by Robby

  • Summary changed from GTalk avatars in chat windows blank after upgrading to OSX 10.9 to User icons in "Stockholm" blank after upgrading to OS X 10.9

comment:8 Changed 3 years ago by mathuaerknedam

Sorry, I'm not sure how I reverted your nice summary change.

comment:9 Changed 3 years ago by sphynx

  • Resolution set to fixed
  • Status changed from new to closed

I've tested the change and it works for me. I transplanted it to 44b2eacffae5.

comment:10 Changed 3 years ago by sphynx

Ticket #16505 has been marked as a duplicate of this ticket.

comment:11 Changed 3 years ago by Robby

  • Keywords 10.9 Mavericks added

comment:12 Changed 3 years ago by Robby

This fix is included in the beta of 1.5.9 we just released. Anyone wanting to test it, can find it on the beta page.

comment:13 Changed 3 years ago by tonyc

Looks good in the beta!

comment:14 Changed 3 years ago by adamprocter

All good in beta 2

comment:15 Changed 3 years ago by lorin

Just tried the beta, it resolves this issue for me.

Note: See TracTickets for help on using tickets.