Adium

Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#16431 closed defect (fixed)

Adium goes into using > 100% cpu when the server closes a connection

Reported by: acli Owned by:
Milestone: Adium 1.5.10 Component: Adium Core
Version: 1.5.7 Severity: major
Keywords: Cc:
Patch Status:

Description

Summary

When Adium displays a password dialog and is not quickly dismissed, Adium eventually uses > 100% cpu and system temperature shoots above 73°C despite the cpu fan spinning at 6200rpm.

Steps to reproduce

Scenario 1:

  1. Leave Adium idle
  2. Google account disconnectes and Adium shows password dialog
  3. Several hours later system temperature reaches 73°C. At least three cores out of 4 register a temperature >72°C. top(1) shows Adium using >120% cpu.
  4. Enter the password (several times to dismiss all dialogs) and system temperature drops below 60°C within 1 minute

Scenario 2 (reproduced):

  1. Quit and retart Adium
  2. Launch top(1)
  3. Wait for Adium to ask for a password
  4. Switch to top(1) but do not enter your password
  5. Adium cpu usage shoots from < 10% to > 148% within a minute
  6. Enter passwords (often multiple times for the same account) and cpu usage drops back to the normal range

Expected results

The presence of a password dialog should not cause Adium to use anywhere near 100% cpu, let alone >120% cpu.

Actual results

System temperature shot up to a dangerous level and cpu usage was >120%. The system was virtually completely idle.

Regression

This is Adium 1.5.7

Attachments (1)

Échantillon de Adium.txt (144.2 KB) - added by acli 4 years ago.
Activity monitor sample (cpu usage between 120% and 144%)

Download all attachments as: .zip

Change History (30)

comment:1 Changed 4 years ago by Robby

  • Status changed from new to pending

Please follow the instructions to get a sample and attach it to this ticket.

There may also be useful logging in Console.app.

Last edited 4 years ago by Robby (previous) (diff)

Changed 4 years ago by acli

Activity monitor sample (cpu usage between 120% and 144%)

comment:2 Changed 4 years ago by acli

  • Status changed from pending to new

Attachment (Échantillon de Adium.txt) added by ticket reporter.

comment:3 Changed 3 years ago by rmueller

I think I have the same problem. I am connecting to a XMPP server which is pretty unreliable at the moment. So the connection to the server gets lost very often and Adium asks me to re-enter my account password. I usually hide Adium by pressing cmd+h, so I only see a rotating square in the dock. The CPU usage heavily increases then.
Perhaps the error is reproducible by configuring Adium to not save the account password and by "destroying" the connection to the XMPP server somehow.

comment:4 Changed 3 years ago by Robby

  • Severity changed from normal to major

comment:5 Changed 3 years ago by sphynx

Ticket #16477 has been marked as a duplicate of this ticket.

comment:6 Changed 3 years ago by sphynx

As I posted on #16477, this is probably related to the change in #16356.

I've managed to run into this problem myself, and I agree that it's very annoying (the entire system slows down).

comment:7 Changed 3 years ago by mgarciaisaia

Adium's CPU usage drops from ~120% to ~80% while sampling.

This doesn't seem to happen with a MSN account, so may be it's XMPP specific.

comment:8 Changed 3 years ago by mgarciaisaia

comment:9 Changed 3 years ago by Robby

  • Milestone set to Adium 1.5.10

Might this be related to #16365?

comment:10 Changed 3 years ago by sphynx

Robby: That issue has only been shown on 10.7, I've had this issue myself, on 10.9.

comment:11 Changed 3 years ago by Robby

Oh yes, that fact escaped me even though the commit message mentions it and some reports do. Good to know, thanks!

comment:12 Changed 3 years ago by Thijs Alkemade <me@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In f8d2f42c499b) Backed out ef796c40efb0: the code can cause busy loops on disconnect, especially with XMPP servers (in particular when prompted to enter a password).

Reverting this change until we have found the exact cause.

Refs #16356, fixes #16431

comment:13 follow-up: Changed 3 years ago by sphynx

Ticket #16609 has been marked as a duplicate of this ticket.

comment:14 in reply to: ↑ 13 ; follow-up: Changed 3 years ago by kallekilponen

Replying to sphynx:

Ticket #16609 has been marked as a duplicate of this ticket.

Since I posted ticket #16609 I thought I might point out that I've found out that for me the culprit is an YIM account. As soon as it looses the connection and/or tries to connect, the processor usage jumps. So it seems to be the same issue, even though no dialogue is presented.

comment:15 in reply to: ↑ 14 Changed 3 years ago by sphynx

  • Summary changed from Adium goes into using > 100% cpu when a password dialog is not dismissed quickly to Adium goes into using > 100% cpu when the server closes a connection

Replying to kallekilponen:

Replying to sphynx:

Ticket #16609 has been marked as a duplicate of this ticket.

Since I posted ticket #16609 I thought I might point out that I've found out that for me the culprit is an YIM account. As soon as it looses the connection and/or tries to connect, the processor usage jumps. So it seems to be the same issue, even though no dialogue is presented.

Yeah, lets give this one a more accurate title.

comment:16 Changed 3 years ago by sphynx

Ticket #16608 has been marked as a duplicate of this ticket.

comment:17 Changed 3 years ago by diathesis

I just had this issue with YIM (Yahoo) as well on 1.5.9; Adium was 145%-195% CPU usage, quitting and re-opening didn't help, but cancelling YIM login brought it back down immediately.

Looks like Adium 1.5.10 will fix this for me.

comment:18 Changed 3 years ago by sphynx

Ticket #16628 has been marked as a duplicate of this ticket.

comment:19 Changed 3 years ago by sphynx

Ticket #16632 has been marked as a duplicate of this ticket.

comment:20 Changed 3 years ago by Robby

Ticket #16631 has been marked as a duplicate of this ticket.

comment:21 Changed 3 years ago by Robby

Ticket #16630 has been marked as a duplicate of this ticket.

comment:22 Changed 3 years ago by Robby

Ticket #16633 has been marked as a duplicate of this ticket.

comment:23 Changed 3 years ago by Robby

A 1.5.10 beta fixing the issue should be out shortly.

comment:24 Changed 3 years ago by Robby

comment:25 Changed 3 years ago by Robby

Ticket #16644 has been marked as a duplicate of this ticket.

comment:26 Changed 3 years ago by JamesH

I've downloaded and installed the beta, and it's now unable to connect to Yahoo at all. Looking at the Preferences / Account page, my Yahoo account just keeps bouncing between "Reconnecting in xxx minutes" and "Connecting". Says "Error" Error reading from login.yahoo.com: Undefined error: 0".

I also tried renaming both of the preferences files (as in Troubleshooting Tips), and that had no effect. My Yahoo account behavior (as above) did not change.

comment:27 Changed 3 years ago by Robby

Ticket #16678 has been marked as a duplicate of this ticket.

comment:28 Changed 3 years ago by veggiespam

This issue also occurs in the 1.6hgr5811 branch. I'm going to side-grade over to 1.5.10b1. Thanks for fixing.

comment:29 Changed 2 years ago by Robby

Ticket #16677 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.