Adium

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#16430 closed crash (fixed)

Trying to send a file crashes Adium on OS X 10.9

Reported by: grouver Owned by:
Milestone: Adium 1.5.9 Component: Adium Core
Version: 1.5.7 Severity: major
Keywords: 10.9 Mavericks Cc:
Patch Status:

Description (last modified by Robby)

Summary

Steps to reproduce

  1. Drag a file to a message window
  2. The file gets added to the message body (I tried this with a png file)
  3. Press return in order to send the file. That would cause Adium to crash because it's trying to use a pointer which does not exist

Expected results

A file send progress window opens or maybe you reuse the chat window.

Actual results

Adium crashes because it's trying to use a pointer which does not exist.

Regression

  • OS X 10.9 (beta 2)
  • Adium 1.5.7

Notes

Attachments (2)

#16430 crash log from grouver.txt (68.8 KB) - added by Robby 3 years ago.
adium_crash.txt (41.9 KB) - added by gerlich 3 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 4 years ago by Robby

  • Keywords 10.9 Mavericks added

comment:2 Changed 3 years ago by aefinity

Exactly the same problem here, on Jabber as well. Mac OS X 10.9 (13A558) (DP8)

comment:3 Changed 3 years ago by vlbrown

I'm getting the same thing with files sent from Lion to Mountain Lion (10.7 to 10.8)

Changed 3 years ago by Robby

comment:4 Changed 3 years ago by Robby

  • Description modified (diff)
  • Milestone set to Adium 1.5.9

(I've attached the crash log to make the ticket more easier to read.)

According to HockeyApp, this is one of our most common crashes. While sending files might also crash on versions of OS X as pointed out by vibrown, this ticket deals with a file sending crash which, according to our data, is either far more prevalent on Mavericks or even limited to Mavericks.

comment:5 Changed 3 years ago by Robby

Ticket #16425 has been marked as a duplicate of this ticket.

comment:6 Changed 3 years ago by wixardy

See also #p15755 and #16352.

comment:7 Changed 3 years ago by Robby

Hi folks, please try this pre-release build of Adium 1.5.9 and let us know whether it fixes the issue for you. vibrown, it would be interesting to know whether it maybe also helps with your crashes on 10.7 and 10.8 after all.

Last edited 3 years ago by Robby (previous) (diff)

Changed 3 years ago by gerlich

comment:8 Changed 3 years ago by gerlich

I've just tried the pre-release 1.5.9 build and now adium won't start at all.
Here's the crash log: https://trac.adium.im/attachment/ticket/16430/adium_crash.txt

comment:9 Changed 3 years ago by Robby

Oh, sorry about that. This build should be better, the last one was missing a file.

Last edited 3 years ago by Robby (previous) (diff)

comment:10 Changed 3 years ago by aefinity

File transfer worked for me with that nightly build! :)

comment:11 Changed 3 years ago by gerlich

OK, works now.
Now I have a problem with my SIPE plugin. It won't connect, but I guess it's a problem with the plugin and not with adium.

comment:12 Changed 3 years ago by Robby

Thanks for reporting back, affinity and gerlich. It would good to hear back from the original reporter, grouver.


gerlich, that is very likely. I would suggest contacting its author first.

comment:13 Changed 3 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed

Mm, on second thought the probability of grouver's crash being different seems minimal enough to consider it fixed for now.

grouver, please comment should you find otherwise using the build linked above.

comment:14 Changed 3 years ago by Robby

This fix is included in the beta of 1.5.9 we just released. Anyone wanting to test it, can find it on the beta page.

comment:15 Changed 3 years ago by catsdas

Problem exists in 1.6hgr5833 would be nice to have it fixed soon. I use 1.6 for the Tor proxy setting, so 1.5.9 would not work for me.

Thanks

Note: See TracTickets for help on using tickets.