Adium

Opened 4 years ago

Last modified 3 years ago

#16418 new defect

Can't connect to twitter (1.5.7b3)

Reported by: sjdw80 Owned by:
Milestone: Adium 1.5.11 Component: Service/Twitter
Version: 1.5.8 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

I get an error when twitter tries to connect.

Steps to reproduce

  1. Add twitter account
  2. Authorize twitter account

Expected results

Twitter feed should show up

Actual results

Error: Unable to retrieve user list [fail]

Regression

I upgraded to 1.5.7b3 because twitter couldn't connect in the latest stable release (I think due to updated twitter API). Got this error, which is different from the previous.

Notes

Log as requested:
https://gist.github.com/sjdw80/e7150129774f7ccf80bf

Attachments (1)

Debug log from 1.5.7b3r5603.txt (11.2 KB) - added by Robby 4 years ago.
User name replaced by "<user>"

Download all attachments as: .zip

Change History (12)

comment:1 Changed 4 years ago by Thijs Alkemade <me@…>

(In 41c3ce5d4fd0) Log the error when retrieving the Twitter user list fails to download. Refs #16418

comment:2 Changed 4 years ago by Robby

  • Version changed from 1.5.6 to 1.5.7b3

The version number "1.5.7b3" was missing, sorry.

comment:3 Changed 4 years ago by sphynx

The actual error was never logged, I've added a new debug statement that should tell us what's going on.

If you could grab http://nightly.adium.im/adium-adium-1.5.7/Adium_1.5.7b3r5603.dmg and check the debug log again, that would be great!

comment:4 Changed 4 years ago by Robby

  • Milestone changed from Adium 1.5.7 to Adium 1.5.8

1.5.7 has been released so I'm pushing all the issues which haven't been fixed yet.

Changed 4 years ago by Robby

User name replaced by "<user>"

comment:5 Changed 4 years ago by Robby

I've added a debug log we received via feedback email.

comment:6 Changed 4 years ago by Robby

Ticket #16474 has been marked as a duplicate of this ticket.

comment:7 follow-up: Changed 3 years ago by sphynx

  • Resolution set to fixed
  • Status changed from new to closed

I hope this is mitigated with 975b4f6e5729. If it still happens with 1.5.8, let us know!

comment:8 in reply to: ↑ 7 Changed 3 years ago by rolfmeijer

I experience this in Adium 1.5.8, OS X 10.8.5

comment:9 Changed 3 years ago by Robby

  • Milestone changed from Adium 1.5.8 to Adium 1.5.9
  • Resolution fixed deleted
  • Status changed from closed to new
  • Version changed from 1.5.7b3 to 1.5.8

Also reported for 1.5.8 on Cocoaforge and by @antelope13 on Twitter.

Last edited 3 years ago by Robby (previous) (diff)

comment:10 Changed 3 years ago by Robby

  • Milestone changed from Adium 1.5.9 to Adium 1.5.10

Adium 1.5.9 is out.

comment:11 Changed 3 years ago by Robby

  • Milestone changed from Adium 1.5.10 to Adium 1.5.11

Adium 1.5.10 was released last week.

Note: See TracTickets for help on using tickets.