Adium

Opened 4 years ago

Closed 3 years ago

Last modified 21 months ago

#16352 closed crash (fixed)

Crash under guardmalloc when sending image in XMPP chat

Reported by: vaniffy Owned by:
Milestone: Adium 1.5.9 Component: Adium Core
Version: 1.5.6 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

Under guardmalloc, Adium will crash when attempting to send an image in a XMPP chat.

Steps to reproduce

  1. Launch Adium with guardmalloc:
    $ export DYLD_INSERT_LIBRARIES=/usr/lib/libgmalloc.dylib
    $ /Applications/Adium.app/Contents/MacOS/Adium
    
  2. Start an XMPP chat with another user or with yourself.
  1. Drag an image file into the text input field in the chat window.
  1. Send.

Expected results

Image gets sent.

Actual results

Crash.

Regression

Occurs with:
OS X 10.8.3
Adium 1.5.6, 1.7hgr5405

Notes

Occurs with a clean OS/Adium install. Changes to the OS could cause this to start occurring with the regular malloc.

Attachments (1)

crash.log (57.4 KB) - added by vaniffy 4 years ago.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by vaniffy

comment:1 Changed 3 years ago by fain

This looks to be caused by an issue in libpurple: https://developer.pidgin.im/ticket/15755

A workaround, if they decide not to fix it on their end, would be to make sure the string pointers are not equal before calling purple_xfer_set_local_filename.

comment:2 Changed 3 years ago by Thijs Alkemade <me@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 5ef5fe5b5c05) libpurple @ c8e809dffa1d and updated a number of other dependencies. This includes the patch on https://developer.pidgin.im/ticket/15755.

Fixes #16352

comment:3 Changed 3 years ago by sphynx

fain: I don't know whether the Pidgin guys will pick it up, but we've applied the patch to Adium.

We usually credit third-party patches with the submitter's real name or a nickname. How would you like to be mentioned?

comment:4 Changed 3 years ago by Robby

  • Milestone set to Adium 1.5.9

comment:5 Changed 3 years ago by Robby

Hi vaniffy (and others), please try this pre-release build of Adium 1.5.9 and let us know whether it fixes the issue for you. vibrown, it would be interesting to know whether it maybe also helps with your crashes on 10.7 and 10.8 after all.

comment:6 Changed 3 years ago by Robby

Oops, that last build was missing a file. Please try this one.

comment:7 Changed 3 years ago by fain

Awesome, fixes the crash for me. Thanks!

Oh, "fain" is fine.

comment:8 Changed 3 years ago by Robby

Thank you! This fix is immensely important. :-)

Alright.

comment:9 Changed 3 years ago by Robby

This fix is included in the beta of 1.5.9 we just released. Anyone wanting to test it, can find it on the beta page.

comment:10 Changed 21 months ago by sphynx

Ticket #16901 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.