Adium

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16343 closed defect (fixed)

Cannot connect to Facebook Chat

Reported by: onlineaddy Owned by:
Milestone: Component: Adium Core
Version: Severity: regression
Keywords: Facebook Cc:
Patch Status:

Description

Summary

I can't get Adium to connect to Facebook Chat. I would go through the process of allowing access, seeing "Adium is authorized for Facebook Chat", then seeing "Not Authorized", and ending with "Requesting authorization...". Repeat.

Mac OS X 10.8.2 Adium 1.5.4

I didn't have this issue with another machine on Lion.

Steps to reproduce

Detail the exact steps taken to produce the bug. Use the following format, each line with " 1." before it:

  1. Preferences > Accounts > Add an account for Facebook > Allow Access
  2. Enter username and password for FB account in Facebook Account Setup page. Check "Keep me logged in". Click "Log In" button.
  3. Witness message "Adium is authorized for Facebook Chat." Click "OK" button.
  4. Facebook Account Setup page appears again, asking me to log in again.
  5. The Accounts Preference window shows the Facebook account with "Error: Not Authorized" underneath it.

Expected results

Connect to Facebook Chat.

Actual results

Facebook Chat connection not established. Being asked to log in again after initial brief authorization.

Regression

Adium 1.5.2 (I think) on OS X 10.7 (Lion) did not have this issue. Facebook Chat worked when I had this configuration on my previous Macbook.

Notes

See attached debug log.

Attachments (1)

adium_debug.txt (15.8 KB) - added by Douglas 7 years ago.
debug log

Download all attachments as: .zip

Change History (28)

Changed 7 years ago by Douglas

Attachment: adium_debug.txt added

debug log

comment:1 Changed 7 years ago by Thijs Alkemade

Ticket #16360 has been marked as a duplicate of this ticket.

comment:2 Changed 7 years ago by Thijs Alkemade

Ticket #16369 has been marked as a duplicate of this ticket.

comment:3 Changed 7 years ago by Thijs Alkemade

Ticket #16368 has been marked as a duplicate of this ticket.

comment:4 Changed 7 years ago by galactic surfeur

Same problem since I changed my Facebook's password.

Try to delete Adium's Application via Facebook settings : nothing. Try to delete my Facebook Account into Adium : nothing.

Facebook Chat connection not established. Being asked to log in again after initial brief authorization.

Adium version : 1.5.6 Mac OS : 10.8.3

comment:5 Changed 7 years ago by Aaron

Issue started just today. Spontaneously. As everything was working fine earlier in the day. Removed and added accounts and still same result. Authorizes then asks for login info again again.

OSx 10.8.3 Adium 1.5.6

Thanks!

comment:6 Changed 7 years ago by Joris

Hello,

Confirmed for:

OSX 10.6.8 Adium 1.5.6

Thanks,

comment:7 Changed 7 years ago by Steven

Having this problem across two MacBooks. One 2011 Air and a 2012 Pro w/ retina. Both running 10.8.3 and Adium 1.5.6.

comment:8 in reply to:  description Changed 7 years ago by Zoltan Shapiro

Having this too. 10.8.3 on a 17" Late '09 MBP, and 10.8.3 on a latest-gen Mini. Adium 1.5.6 on both.

comment:9 Changed 7 years ago by hbinfinity

Hi, My facebook contacts weren't showing up on Adium. So I logged out of my facebook chat on adium and logged back in to see if that would make a difference. It kept asking me over and over again for my login info for facebook chat even though I kept giving it the right info. Then it finally took and I still don't see my facebook contacts in Adium. Then, the little circle in the status menu for facebook turned grey. I made sure that I Was still logged into facebook chat on my actual facebook page because I know that makes a difference and yes I was. All my other accounts are fine. I don't know if this matters, but I have a macbook pro, under a year old. Thanks.

comment:10 Changed 7 years ago by neutralino1

Same issue here.

comment:11 Changed 7 years ago by attheshow

Same issue here. Adium 1.5.6. Macbook Pro, 10.8.2.

comment:12 Changed 7 years ago by edgar george

same issue adium 1.5.6 mountain lion 10.8.2 macbook pro

comment:13 Changed 7 years ago by edgar george

i need chat facebook chat please fix this problem thanks

comment:14 Changed 7 years ago by tomkatsu

I have the same issue and reverted my version to 1.5.4 and this did not fix the issue. I do have two step authentication enabled on Facebook. OS X version is 10.8.3 on a macbook air.

comment:15 Changed 7 years ago by waylandsmith

This started happening to me a few days ago. Has anyone found a workaround?

comment:16 Changed 7 years ago by Douglas

Yes, I did find a workaround. Instead of adding a Facebook account to Adium, add an XMPP (aka Jabber) account. Your ID would be <facebook_username>@chat.facebook.com. Good luck, all.

comment:17 Changed 7 years ago by Tom

I, too, cannot add a Facebook account to Adium due to having to re-authorize with the same credentials over and over to no avail. The XMPP "workaround" has been listed several times over the years, but the problem just persists in another way. The XMPP account doesn't even show up in the buddy lists and, if it does, it only populates 1 - 4 contacts at a time.

Last edited 7 years ago by Tom (previous) (diff)

comment:18 Changed 7 years ago by Douglas

I am okay with the limitations of the XMPP workaround. I typically do not initiate a chat with my FB friends, so the buddy list issue does no harm to me. YMMV.

But, of course, it is best if Adium team fixes the FB account issue.

comment:19 Changed 7 years ago by Tom

I can now log in to Facebook without being prompted repeatedly for my password, but the buddy list still does not populate.

comment:20 in reply to:  19 Changed 7 years ago by galactic surfeur

Replying to lawkid2013:

I can now log in to Facebook without being prompted repeatedly for my password, but the buddy list still does not populate.

Same for me. Login OK but no buddy list.

comment:21 Changed 7 years ago by Tom

Everything is back to normal as of yesterday.

comment:22 Changed 7 years ago by attheshow

It's working again for me as well. I guess we have to assume that Facebook fixed the issue somehow?

comment:23 Changed 7 years ago by Robert

Thanks for reporting back. :)

They'd promised they would by yesterday.

Last edited 7 years ago by Robert (previous) (diff)

comment:24 Changed 7 years ago by galactic surfeur

+1 for me. Works like a charm...

Just weird.

comment:25 Changed 7 years ago by Robert

Resolution: fixed
Status: newclosed

No, that's just Facebook messing up and fixing the mess. :)

Let's consider this fixed for now then, shall we.

comment:26 Changed 7 years ago by James Rothschild

I have this back... Started about 3 days ago across all Macs with Adium 1.5.6 and OSX 10.8.x.latest :-( Any solution please?

comment:27 Changed 7 years ago by Adam F

Hi, I just wanted to report that I've started having this issue since updating to 1.5.6. I'm using OS X 10.7.5 and I do not have two-step authentication enabled on my Facebook account. I'm prompted to sign in to Facebook every time I start Adium and usually after I've been signed in for several hours.

Note: See TracTickets for help on using tickets.