Adium

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#16305 closed defect (fixed)

Chat windows dropped to right side of tab bar turn invisible

Reported by: ColinDabritz Owned by: wixardy
Milestone: Adium 1.5.10 Component: Adium UI
Version: 1.5.4 Severity: normal
Keywords: PSMtabbarcontrol Cc:
Patch Status:

Description

Summary

When chat tabs are dragged into the empty area of a chat tab bar or former location of a chat tab bar, the window for that specific chat turns invisible.

Steps to reproduce

Single chat window version (simplest case):

  1. Open a single chat window with a contact, ensure it is large enough to have empty space to the right of the tab on the tab bar at the bottom of the window.
  2. Note the current location of the empty space on the screen (it will be targeted later)
  3. Begin dragging the chat by the tab to a new location. The screen will transparently 'ghost' to show where the window will end up.
  4. While dragging, move the tab over to the location noted before, where the empty space in the tab bar used to be. The ghosted window will change from a full window to only a tab. (Note, you may need to be far enough to the right to be clear of the correct tab insertion point).
  5. Once you are in the noted location and the ghosted window has turned into a simple tab, release the tab.

Result: The tab vanishes, and is now invisible.

Multiple chat window version (additional case):

  1. Open two separate chat windows. (they may be overlapping, but it may be easier to target if not)
  2. Ensure one chat is large enough to have empty space to the right of the tab bar at the bottom of the window. This will be the 'Target' chat window.
  3. The other chat window will be the 'source' chat window. Begin dragging the source chat by it's tab. Once the window is being dragged, it will turn transparent to indicate the drag location.
  4. Drag this window to the target chat, placing it in the empty space to the right of the other chat tab at the bottom of the window. (Note: If you are too close to the exiting tab it will insert as normal. This is indicated by the grey blocking area that shows up before the insert. You must be to the right of this area to cause the issue).
  5. Drop the tab in empty area.

Result: The tab vanishes, and is now invisible.

Expected results

Simple scenario:
The ghosted window should NOT change to a tab when dragged to it's own former tab bar location.
Tabs dropped in this location should NOT turn invisible.
Tabs dropped in this location should be moved to the new location (as they do for anywhere else on the screen).

Additional scenario:
Tabs dropped in this location should NOT turn invisible.
(Suggested) Tabs dropped in this location should be added to the tab bar inserted in the right most position.

Actual results

The tab turned invisible. It still takes screen space, and can be highlighted by clicking on it. It can be seen if you hover over the Adium group in mission control.

Regression

Adium: 1.5.4
OSX: 10.8.2
Reproduces consistently.

Notes

If this description isn't clear enough I can provide more detail, investigation, or debugging.

Change History (7)

comment:1 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.5

Looks like updating our tab framework might fix this: https://github.com/dorianj/PSMTabBarControl/pull/31. (Thanks to Paul Wilde for the hint!)

comment:2 Changed 4 years ago by Robby

  • Component changed from Adium Core to Adium UI
  • Keywords PSMtabbarcontrol added; Tab Invisible Drag removed
  • Milestone changed from Adium 1.5.5 to Adium 1.6

comment:3 Changed 4 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 7658a4afc14d) Updated PSMTabBarControl to github.com/wixardy/PSMTabBarControl/commit/12ee3ecf023d44c6737d52ab6502bc0e8fff0957 fixes #16305 and #15518 and #15414 and #16286.

comment:4 Changed 3 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

Reopening for attribution

comment:5 Changed 3 years ago by Robby

  • Owner set to wixardy

comment:6 Changed 3 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 3 years ago by Robby

  • Milestone changed from Adium 1.6 to Adium 1.5.10
Note: See TracTickets for help on using tickets.