Adium

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#16281 closed crash (fixed)

Dragging chat window/tab freezes target

Reported by: allbery_b Owned by: wixardy
Milestone: Adium 1.5.10 Component: Adium Core
Version: 1.5.4 Severity: major
Keywords: PSMTabBarControl Cc:
Patch Status:

Description (last modified by Robby)

Summary

Dragging a conversation window into an existing tabbed conversation window causes the original window to vanish and the target window to become nonresponsive

Steps to reproduce

  1. Given a window containing tabs and a window with a single tab: drag the tab from the second window to the tab bar of the first.
  2. As expected, the tab bar of the target window will shift to make room for the new tab. Release the dragged tab to drop it.
  3. The source window will disappear; the tab does not appear in the target window, and the target window stops responding to events.

Expected results

The tab should appear in the target window

Actual results

As in (3) above: the target window freezes, although the source window disappears. It looks like the target window gets stuck trying to add the newly dropped tab. The main UI is still responsive, and if I exit and restart (no force quit needed) I will be left with the original windows and can repeat the same sequence of actions with the same result. Also, the window list (both from the Window menu and from the dock icon) still shows the separate window.

Regression

OS X 10.7 (Lion), Adium 1.5.4 (11/7/12; 5efcd11df694)

Notes

Originally I reproduced this over a VNC connection. I just tried it directly; it actually managed to redraw the tab bar in this case, but the target window is now unresponsive as before and the window list still shows the original window even though the tab bar indicates it has been accepted into the target.

Attachments (2)

crash 1.5.4.txt (54.1 KB) - added by Robby 4 years ago.
crash 1.6hg.txt (56.7 KB) - added by Robby 4 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 4 years ago by Robby

  • Description modified (diff)
  • Severity changed from normal to major
  • Summary changed from dragging chat window/tab freezes target to Dragging chat window/tab freezes target
  • Type changed from defect to crash

I can reproduce this with both 1.5.4 and 1.6hg. I'm attaching crash logs.

Here's Console logging:

24.01.13 17:18:18,166 Adium[30009]: !*** WARNING: -[NSImage compositeToPoint:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.
24.01.13 17:18:18,166 Adium[30009]: !*** WARNING: -[NSImage compositeToPoint:fromRect:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.
24.01.13 17:18:25,184 Adium[30009]: Exception was raised: Uncaught system exception: signal 11
24.01.13 17:18:26,944 WindowServer[76]: CGXDeferSurfaces : Invalid source window 111165
24.01.13 17:18:26,945 WindowServer[76]: CGXDeferSurfaces : Invalid source window 111065
24.01.13 17:18:26,945 WindowServer[76]: CGXDeferSurfaces : Invalid source window 111065
24.01.13 17:18:26,945 WindowServer[76]: CGXFilterEventToConnection : Invalid connection
24.01.13 17:18:26,945 WindowServer[76]: CGXFilterEventToConnection : Invalid connection
24.01.13 17:18:26,946 WindowServer[76]: CGXDeferSurfaces : Invalid source window 111065
24.01.13 17:18:26,958 com.apple.launchd.peruser.501[150]: ([0x0-0x642f429].com.adiumX.adiumX[30009]) Job appears to have crashed: Segmentation fault: 11
24.01.13 17:18:27,249 ReportCrash[30063]: Saved crash report for Adium[30009] version 1.6hg (1.6hg) to /Users/robertvehse/Library/Logs/DiagnosticReports/Adium_2013-01-24-171827_Robert-Vehses-MacBook-Pro.crash

Changed 4 years ago by Robby

Changed 4 years ago by Robby

comment:2 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.5

comment:3 Changed 4 years ago by Robby

  • Milestone changed from Adium 1.5.5 to Adium 1.6
  • Resolution set to fixed
  • Status changed from new to closed

It appears this is fixed with a newer 1.6hg including the updated tab framework (http://hg.adium.im/adium/rev/cc6d598f5692).

comment:4 Changed 4 years ago by Robby

allbery_b, if you like you can try a development build of 1.6. They are pretty stable, you will find some visual regressions caused by the updated tab code. They are being collected in this ticket: #16286.

comment:5 Changed 4 years ago by Robby

  • Keywords PSMTabBarControl added; conversation tab dragging removed

comment:6 Changed 3 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

Reopening for attribution

comment:7 Changed 3 years ago by Robby

  • Owner set to wixardy

comment:8 Changed 3 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 3 years ago by Robby

  • Milestone changed from Adium 1.6 to Adium 1.5.10
Note: See TracTickets for help on using tickets.