Adium

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16280 closed crash (fixed)

Crash following certificate dialogue for newly-added XMPP account

Reported by: Robby Owned by:
Milestone: Adium 1.5.5 Component: Service/XMPP (Jabber)
Version: 1.5.5 Severity: regression
Keywords: Cc:
Patch Status:

Description

Summary

Adium 1.6hg crashes when clicking either of the "Continue" and "Cancel" buttons in the certificate dialogue for a newly-created XMPP account.

I'm attaching crash logs for both cases. They seem identical except that the first time I clicked "Cancel", it was different (I think).

Regression

Adium 1.5.4 is fine. For me this happens every time with this account, I haven't tried others.

Change History (10)

comment:1 Changed 4 years ago by Robby

  • Milestone set to Adium 1.6
  • Severity changed from normal to regression
  • Version changed from 1.5.4 to 1.6hg

comment:2 Changed 4 years ago by nyeates

I am seeing this too, though only once I try to bring over settings from another computer.

I am trying to port settings from one computer to another
I have 1.6hgr5303
i have the same version on the other computer
I over write ~/Library/.../Adium 2.0 and the .plist with the ones from my old computer
On the new computer, adium starts fine, but then when it gives me a popup about certificate not recognized, and i click accept, it crashes the entire adium

Please also see duplicate of this here https://trac.adium.im/ticket/16315

comment:3 Changed 4 years ago by nyeates

The weird thing here, is that I have one computer, with 1.6hgr5303 that it DOES work on. My other computer, with the same version, crashes - even if I setup the acct from scratch.

There must be *some* workaround.

comment:4 Changed 4 years ago by Thijs Alkemade <me@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In c71cfe104f07) Fix an overrelease of this SecTrustRef object, causing a crash when closing an untrusted certificate window.

Fixes #16280

comment:5 Changed 4 years ago by sphynx

  • Milestone changed from Adium 1.6 to Adium 1.5.5
  • Version changed from 1.6hg to 1.5.5

comment:6 Changed 4 years ago by nyeates

Just as an FYI...

The crashing stopped for me and I changed nothing in Adium.

Possible workaround:
I think maybe adding my organizations root certificate to mac OSX's 'Keychain Access' app, then restarting the computer, may have rid of it. This is a way you can get around having to click 'Accept' every time you get a certificate that your app or mac doesnt know about.

comment:7 Changed 4 years ago by Robby

Yes, Adium wouldn't complain about the certificate once it's in Keychain Access.

Thijs' change does indeed fix the crash.

Note: See TracTickets for help on using tickets.