Adium

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#16203 closed crash (fixed)

OTR does not work/crashes Adium

Reported by: Skyrazer Owned by:
Milestone: Adium 1.5.5 Component: Adium Core
Version: 1.5.4b4 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

OTR encryption does not work (and crashes Adium).

Steps to reproduce

Version 1: Trying to start encryption from my side:

  1. During a conversation try to start encryption using the icon/menu.

Version 2: A contact is trying to start encryption

Expected results

Encrypted conversation should start.

Actual results

Version 1: Nothing seems to happen.
Version 2: Adium hangs or crashes.

Regression

Using Mac OS X 10.6.8 on a MacBook 1,1 (32bit).

Notes

I attach a crash log for version 2 and debug logs for versions 1 and 2.

system.log is showing these messages quite often. Not sure if they are related to this issue:

Oct 22 20:01:20 BlackBeauty [0x0-0x184184].com.adiumX.adiumX[5510]: ** (process:5510): CRITICAL **: purple_signal_emit_vargs: assertion `instance_data != NULL' failed
Oct 22 20:01:20 BlackBeauty [0x0-0x184184].com.adiumX.adiumX[5510]: (process:5510): GLib-CRITICAL **: g_hash_table_lookup: assertion `hash_table != NULL' failed


Attachments (3)

version1_debug.log (2.1 KB) - added by Skyrazer 5 years ago.
version2_debug.log (2.6 KB) - added by Skyrazer 5 years ago.
version2.crashlog (43.0 KB) - added by Skyrazer 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by Skyrazer

Changed 5 years ago by Skyrazer

Changed 5 years ago by Skyrazer

comment:1 Changed 5 years ago by Skyrazer

Also found this in system.log:

Oct 22 20:00:51 BlackBeauty [0x0-0x181181].com.adiumX.adiumX[5495]: Ohhhh jeeee: ... this is a bug (sexp.c:431:_gcry_sexp_find_token)

Seems this is related to the crash log:

...openspecies.rtool.libgcrypt      0x022c57b7 _gcry_sexp_find_token + 230
Last edited 5 years ago by Skyrazer (previous) (diff)

comment:2 Changed 4 years ago by defa

I can confirm this bug for 1.5.4

comment:3 Changed 4 years ago by Skyrazer

In my case it seems to be a 32bit problem. The errors do not occur on a 64bit system. Would be nice if it could be fixed for the next release.

comment:4 Changed 4 years ago by galiyosha

I can confirm this for 1.5.4 on 10.7.5 when Adium is running in 32-bit mode. OTR doesn't work at all, for example trying to generate a new private key freezes Adium. No issues in 64-bit mode.

comment:5 Changed 4 years ago by Thijs Alkemade <me@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 604a4e1e865a) Rebuilt libgcrypt with a patch fixing SIZEOF_UNSIGNED_LONG for 32-bits Macs. Also updated libgpgerror to 1.11.

Fixes #16203

comment:6 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.5

Folks, please test 1.5.6b2.

Note: See TracTickets for help on using tickets.