Adium

Opened 4 years ago

Closed 4 years ago

#16119 closed crash (fixed)

Crash on animateSelection

Reported by: sphynx Owned by: sphynx
Milestone: Adium 1.5.7 Component: Adium Core
Version: 1.5.3 Severity: major
Keywords: Cc:
Patch Status:

Description

http://pastebin.com/rgAvDTqK

Possibly related to proxy objects.

Attachments (4)

Adium_2012-08-14-022752_iMac.crash (60.9 KB) - added by sphynx 4 years ago.
Adium_2013-01-03-175638_Shivas-rMBP.crash (59.5 KB) - added by Shivatron 4 years ago.
Adium_2013-01-04-143649_milvich.crash (61.2 KB) - added by milvich 4 years ago.
jesse-2013-03-22.crash (58.7 KB) - added by jesse@… 4 years ago.

Download all attachments as: .zip

Change History (45)

Changed 4 years ago by sphynx

comment:1 Changed 4 years ago by sphynx

  • Owner set to sphynx
  • Status changed from new to assigned

comment:2 Changed 4 years ago by Robby

  • Type changed from defect to crash

Also reported by @rabryst with identical backtrace.

Changed 4 years ago by Shivatron

comment:3 Changed 4 years ago by Shivatron

I see the same thing in 1.5.4 on a nearly daily basis. (New crash report attached.) Let me know if I can assist in debugging...

Last edited 4 years ago by Shivatron (previous) (diff)

Changed 4 years ago by milvich

comment:4 Changed 4 years ago by milvich

I just started to see this crash today. The stack trace appears to be the same as Shivatron (my crash report is attached). Adium 1.5.4, and OS X 10.8.2.

The only change today is that I changed the sorting order of the contacts from "by Status" to "Alphabetically". I changed it back to "by Status" and haven't had a crash yet, but it is too soon to tell if that was the trigger.

comment:5 Changed 4 years ago by Robby

Ticket #16271 has been marked as a duplicate of this ticket.

comment:6 Changed 4 years ago by jesse@…

I filed #16271, please let me know if I can assist in debugging this. I will try changing the order of my contacts like comment:4 and see if that helps.

comment:7 Changed 4 years ago by Shivatron

I also changed the order of my contacts as described in comment:4, and it hasn't crashed yet. However, I'm not sure that's causal, as it has only been 24 hours. I'll report back after more time has passed.

comment:8 Changed 4 years ago by jesse@…

I changed my contact sort from alphabetical by last name, to just alphabetical and it crashed again only a few minutes later. Trying sort by status now.

comment:9 Changed 4 years ago by milvich

My crashes stopped when I switch contact sorting back to by status. Tried to replicate this again by switching contact sorting to by alphabetically and it hasn't crashed yet...

comment:10 Changed 4 years ago by milvich

Adium crashed with the same stack trace while I was away at lunch. Sorting my contacts alphabetically defiantly is a condition for this crash.

comment:11 Changed 4 years ago by jesse@…

Adium hasn't crashed since changing my sort by Status either. Which really sucks because my list is huge and I have to search for people all the time.

comment:12 Changed 4 years ago by jesse@…

Confirming that I did not crash once when sorting by Status, but going back to sorting Alphabetically I crashed within 24 hours.

comment:13 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.5

comment:14 Changed 4 years ago by jesse@…

Well, my Adium is continually crashing on sort by status. I guess that is not the workaround (for me at least).

comment:15 follow-up: Changed 4 years ago by mathuaerknedam

Under Preferences -> Advanced -> Contact List -> Appearance, try deselecting "animate changes". If that doesn't help try deselecting other things under Appearances. I have no idea if this should work, but if animating the contact list is the problem, maybe this will help.

comment:16 in reply to: ↑ 15 ; follow-up: Changed 4 years ago by milvich

I unchecked "Animate changes" and change the sort back to alphabetically and haven't had a crash yet.

comment:17 in reply to: ↑ 16 Changed 4 years ago by jesse@…

Replying to milvich:

I unchecked "Animate changes" and change the sort back to alphabetically and haven't had a crash yet.

I did the same, however mine crashed today :(

comment:18 Changed 4 years ago by Detmud

I will try to reproduce this Bug.

comment:19 Changed 4 years ago by milvich

I haven't had a crash for a few days, so this morning I re-enabled "Animate changes" and a few hours later I got the same crash. So the trigger (for me at least) appears to be sorting contacts alphabetically and enabling "Animate changes" for the contact list.

comment:20 Changed 4 years ago by edr1084

  • Severity changed from normal to major

I've been hearing multiple reports of this one lately as well. Traces are the same.

comment:21 Changed 4 years ago by milvich

Unchecking "Animate changes" doesn't completely fix the problem for me. It just greatly reduces the probability of the crash. Just crashed today, and it has been about a week since the last crash.

comment:22 Changed 4 years ago by Robby

  • Milestone changed from Adium 1.5.5 to Adium 1.5.7

comment:23 Changed 4 years ago by scottastrophic

I've had this crash quite frequently since upgrading to Mountain Lion from Lion. Unchecking Animate Changes seems to have reduced this quite a bit. Still sorting by status.

comment:24 Changed 4 years ago by jesse@…

I am still hitting this multiple times a day. Are crash reports helpful for debugging?

Changed 4 years ago by jesse@…

comment:25 follow-up: Changed 4 years ago by Robby

From what I've told it seems to be all about reproducibility. And those that have looked into the issue haven't been able to reproduce it so far.

comment:26 in reply to: ↑ 25 Changed 4 years ago by jesse@…

Replying to Robby:

From what I've told it seems to be all about reproducibility. And those that have looked into the issue haven't been able to reproduce it so far.

I've crashed 3 or 4 times already today. If there is any additional logging or debugging I can run in a custom build, I would be happy to. This is making Adium almost impossible to use for me.

comment:27 follow-up: Changed 4 years ago by milvich

I think this might be getting triggered when a contact is changing their status at the same time as another contact joins or leaves. But it is hard to say. Don't know if it matters, but I am only connected to an internal Jabber server. Sorry, I don't know which one, but I can probably find out.

comment:28 in reply to: ↑ 27 Changed 4 years ago by jesse@…

Replying to milvich:

I think this might be getting triggered when a contact is changing their status at the same time as another contact joins or leaves. But it is hard to say. Don't know if it matters, but I am only connected to an internal Jabber server. Sorry, I don't know which one, but I can probably find out.

That seems plausible for me as well, although just conjecture. I'm also only on an internal Jabber server with probably 100+ contacts online at a time.

comment:29 Changed 4 years ago by wixardy

Ticket #16405 has been marked as a duplicate of this ticket.

comment:30 Changed 4 years ago by Frank Dowsett <wixardy@…>

(In 4044634d3b95) Remove the reselection of contacts in the contact list on reloadData; it doesn't work anymore and probably causes #16119.

Refs #16119

comment:31 follow-ups: Changed 4 years ago by Robby

Anyone who has been troubled by this crash, please give the current 1.5.7 beta a shot and let us know if there is any noticeable improvement.

comment:32 in reply to: ↑ 31 Changed 4 years ago by jesse@…

Replying to Robby:

Anyone who has been troubled by this crash, please give the current 1.5.7 beta a shot and let us know if there is any noticeable improvement.

This did not help for me:

Adium quit unexpectedly.
Click Reopen to open the application again. Click Report to see more detailed information and send a report to Apple.

Crash report - http://pastebin.com/raw.php?i=j9ZiTiLf

EDIT: Crash report has version, removed screenshot.

Last edited 4 years ago by jesse@… (previous) (diff)

comment:33 Changed 4 years ago by jesse@…

Additionally, Adium has crashed for me about 10 times today since upgrading to 1.5.7 beta, so I would say nothing has changed.

comment:34 Changed 4 years ago by jazzyjeff

Same thing here, on my 4th crash today with latest beta (mountain lion 10.8.4)

comment:35 Changed 4 years ago by scottastrophic

Also did not fix the problem for me, osx 10.8.4 and adium 1.5.7b1

comment:36 in reply to: ↑ 31 Changed 4 years ago by sphynx

Replying to Robby:

Anyone who has been troubled by this crash, please give the current 1.5.7 beta a shot and let us know if there is any noticeable improvement.

wixardy's commit happend after 1.5.7b1 was built. Please stay tuned for a 1.5.7b2 where this (potential) fix will be in. :)

comment:37 Changed 4 years ago by Robby

Oops, sorry about the false alarm.

comment:38 follow-up: Changed 4 years ago by sphynx

1.5.7b2 is available now from beta.adium.im! If you've been experiencing this problem, please try it and tell us if it still happens.

comment:39 in reply to: ↑ 38 Changed 4 years ago by jesse@…

Replying to sphynx:

1.5.7b2 is available now from beta.adium.im! If you've been experiencing this problem, please try it and tell us if it still happens.

Almost afraid to say... but I've not crashed since upgrading yesterday. I usually would've crashed at least a few times by now. Keeping my fingers crossed!

comment:40 Changed 4 years ago by scottastrophic

Likewise, no crashes since upgrading. Thank you, wixardy!

comment:41 Changed 4 years ago by Robby

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.