Adium

Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#16102 closed defect (fixed)

Change default tab switching shortcut

Reported by: Robby Owned by: evands
Milestone: Adium 1.5.8 Component: Adium Core
Version: 1.5.2 Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by Robby)

Summary

As pointed out by @gulkily (https://twitter.com/gulkily/status/231069472570621952, https://twitter.com/gulkily/status/232924246307926017) our current default tab switching shortcut - which is "Arrows" - overrides "standard text cursor movement".

This seems unnecessary when "Ctrl + Tab", "Shift + Arrows" and "Brackets" seem to be the typical shortcuts for tab switching in OS X (as in Safari) as mentioned in #15221.

My preference for the default shortcut would be "Ctrl + Tab". Is there an obvious choice?



Edit: we should probably respect existing user preferences if possible.

Attachments (1)

Tab switching shortcut options.png (25.0 KB) - added by Robby 5 years ago.

Download all attachments as: .zip

Change History (14)

Changed 5 years ago by Robby

comment:1 Changed 5 years ago by Robby

  • Milestone set to Adium 1.6

comment:2 Changed 5 years ago by Robby

  • Description modified (diff)

comment:3 Changed 4 years ago by evands

  • Owner set to evands

comment:4 Changed 4 years ago by Evan Schoenberg

  • Resolution set to fixed
  • Status changed from new to closed

(In 1a2cd53342c5) Tab switching now defaults to ctrl+tab, matching Safari's user visible default, as per discussion on IRC today. This only applies to new users as of Adium 1.5.4 and later; anyone who has run a previous version will inherit the keep the old default of command+arrows (unless they've changed it previously, of course). Fixes #16102.

comment:5 Changed 4 years ago by Evan Schoenberg

(In 68bb3f77b1d0) Tab switching now defaults to ctrl+tab, matching Safari's user visible default, as per discussion on IRC today. This only applies to new users as of Adium 1.5.4 and later; anyone who has run a previous version will inherit the keep the old default of command+arrows (unless they've changed it previously, of course). Fixes #16102.

comment:6 Changed 4 years ago by Robby

  • Milestone changed from Adium 1.6 to Adium 1.5.4

comment:7 Changed 4 years ago by Robby

  • Milestone changed from Adium 1.5.4 to Adium 1.5.8
  • Resolution fixed deleted
  • Status changed from closed to new

I'm surprised nobody noticed this yet but the new Safari-like default doesn't seem to be working and it probably never did (?). I have tested both 1.5.4 and 1.5.8 with a fresh Adium profile as well as OS X's guest account, mathuaerknedam checked 1.7hg and we have found that the default shown and in effect is cmd-arrows.

Evan, would you be able to look into this once more?

Last edited 4 years ago by Robby (previous) (diff)

comment:8 Changed 4 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In d1d6ae42a02d) Add the chat cycling default plists to the Adium target so that they can be used. Fixes #16102 again

comment:9 Changed 3 years ago by sphynx

Ticket #16497 has been marked as a duplicate of this ticket.

comment:10 follow-up: Changed 3 years ago by kevinburke

I'm fairly confused about this and was annoyed to learn tab switching was broken when I updated Adium.

The refrain I've been hearing is that "it's the same shortcut as Firefox, Safari and Chrome", see for example https://twitter.com/Adium/status/390496358521917440. However on my machine Firefox and Chrome use Cmd+Option+L/R arrow to switch tabs. (Safari does something different, although I've remapped it to match Chrome and Firefox, so I'm not sure what the setting is initially).

I was also disappointed this changed in a minor point release.

I also tried to find tickets explaining this change recently by searching for "keyboard shortcut", "shortcut" in Adium's Trac and couldn't find this page so maybe some more keywords in this ticket would be nice.

comment:11 in reply to: ↑ 10 Changed 3 years ago by Robby

Replying to kevinburke:

I'm fairly confused about this and was annoyed to learn tab switching was broken when I updated Adium.

The refrain I've been hearing is that "it's the same shortcut as Firefox, Safari and Chrome", see for example https://twitter.com/Adium/status/390496358521917440. However on my machine Firefox and Chrome use Cmd+Option+L/R arrow to switch tabs. (Safari does something different, although I've remapped it to match Chrome and Firefox, so I'm not sure what the setting is initially).

That was my tweet. sphynx told me it is also the default for Firefox and Chrome, I didn't check myself.

I was also disappointed this changed in a minor point release.

Yes, in retrospect, I think that was a mistake. As mentioned in the ticket description, Adium was meant to respect existing settings. With that, it wouldn't have been as much of an issue. :/

I also tried to find tickets explaining this change recently by searching for "keyboard shortcut", "shortcut" in Adium's Trac and couldn't find this page so maybe some more keywords in this ticket would be nice.

Good point, I've edited the title of the ticket.


We're open to suggestions for a better keyboard shortcut based on arguments.

With ctrl-tab being the shortcut in Apple's browser, it seemed like a good choice. And cmd-arrows was overriding standard text cursor movement.

comment:12 Changed 3 years ago by mathuaerknedam

Mozilla lists ctrl-tab among it's standard tab-switching shortcuts. Google only lists cmd-option-> here, but the additional shortcuts listed here (which includes ctrl-tab) also work. Google does list ctrl-tab as the official shortcut for Chromebook.

My experience is that ctrl-tab works in Firefox and Chrome, despite the fact that I've manually set other shortcuts in the OS X system preferences.

comment:13 Changed 3 years ago by jmhodges

This one was very troublesome to get hit with as there were no docs on what the new keybindings were when I searched help. It may help if we also had the Chrome ones myself and others are used to in many apps.

Note: See TracTickets for help on using tickets.