Adium

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16101 closed defect (fixed)

Context menu item Open Link opens website in message window

Reported by: mnatter Owned by:
Milestone: Adium 1.5.5 Component: Adium Core
Version: 1.5.2 Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by wixardy)

Summary

When you right-click / ctrl-click on a link in an Adium message window, the Open Link item opens the link inside the message window, instead of the default browser, what I would expect. Doing so also makes it impossible to get back to the conversation without closing and reopening the message window, or at least choosing Clear the message window (which also clears all the previous conversation messages).

Steps to reproduce

  1. post a URL , or, get a URL posted in the message window
  2. the posted URL is marked as a link
  3. now, right click (secondary click / ctrl+click) on this link for opening the context menu
  4. choose first option: Open Link (Link Öffnen in german version).
  5. the content opens in the message window
  6. it is impossible to get back to the conversation, except the workarounds (what would delete previous messages in the conversation)
  7. close and reopen message window, or
  8. choose display->clear display in menu bar, or
  9. right click / ctrl-click and choose clear display

Expected results

I would expect that clicking on the link opens the content in the default browser, identical to a left click.
In the case of this is intended behavior by the development team, I would at least expect to be able to close the link content / website and return to the conversation.

Actual results

using context menu item Open Link opens the link inside the message window. As said before, this might be intended behavior, even if it is unexpected by me, but, if so, it is not possible to get back to the active conversation without reopen it / or at least clear the message window display (not only the website is cleared, but also the previous messages of the active conversation are deleted).

Regression

The problem occurs since, (at least that I am aware of) MAC OS X 10.6.x using the release versions since mid 2009.
The current release version 1.5.2 also shows this behavior on intel macs OSX 10.7.4 and 10.8.0.
I am using german language.

Notes

There has been a duplicate ticket (#7735), which is five years old and unowned. I am opening this new ticket at request.
Many thanks for your quick reply on the comment :)

Change History (8)

comment:1 Changed 4 years ago by wixardy

  • Description modified (diff)

I don't see it in the English, but do when running in German.

comment:2 Changed 4 years ago by mnatter

I can confirm that, yes. In english it doesn't seem to happen. Maybe it is *.nib file related?

comment:3 Changed 4 years ago by Robby

Weird, I can see "Link Öffnen" neither in 1.5.2 nor in 1.6hg.

comment:4 Changed 4 years ago by sphynx

Still happens, it seems from #adium.

Probably related: http://hg.adium.im/adium/rev/8b3a175ad29d.

comment:5 Changed 4 years ago by Robby

I can reproduce this in German in 1.6hg. Also reported on our forums just now: http://forums.cocoaforge.com/viewtopic.php?f=13&t=26088.

Last edited 4 years ago by Robby (previous) (diff)

comment:6 Changed 4 years ago by Thijs Alkemade <me@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 87047401414b) Check WebCore for the translation of "Open Link" too.

Fixes #16101

comment:7 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.5

I can confirm "Open Link" no longer shows with that fix.

I will backport the fix to 1.5.5.

comment:8 Changed 4 years ago by Robert Vehse <robertvehse@…>

(In 8dd0d808e092) Backport 87047401414b for #16101. References #16101.

Note: See TracTickets for help on using tickets.