Adium

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16095 closed crash (fixed)

Constant Crash after upgrade to Mountain Lion

Reported by: goodblokemouse Owned by:
Milestone: Adium 1.5.3 Component: Adium Core
Version: 1.5.2 Severity: normal
Keywords: Crash, Mountain Lion Cc:
Patch Status:

Description (last modified by David Munch)

Steps to reproduce


  1. Upon load Adium will crash almost every time except after restart when it *may* load for a period of time before crashing in the background.

Expected results

Adium should load.

Actual results

Adium crashes every time, a restart can *sometimes* allow Adium to open for between 15mins to 2 hours until it crashes while in the background, after which it will crash immediately on load every time.

Regression

Adium used to load prior to upgrade to Mountain Lion.

Attachments (1)

Adium_2012-07-26-110358_Richards-MacBook-Pro-2.crash (50.3 KB) - added by goodblokemouse 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by goodblokemouse

comment:1 Changed 5 years ago by goodblokemouse

Sorry, I should have mentioned I have attempted the troubleshooting steps including deleting preference files etc. I have searched the google and the other tickets and can't seem to see any others who have a crashing issue such as mine.

comment:2 Changed 5 years ago by David Munch

  • Description modified (diff)

comment:3 Changed 5 years ago by Robby

19:02:03 Catfish_Man: rob-to86: bogus xml from UPNP is my guess

19:02:41 Catfish_Man: shouldn't crash

19:02:44 Catfish_Man: should just error

19:02:48 Catfish_Man: but it's blowing up in the error handler

comment:4 Changed 5 years ago by Robby

Ticket #16100 has been marked as a duplicate of this ticket.

comment:5 Changed 5 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 339df1349d5e) Fix a crash when handling a XML parsing error.

Fixes #16095

comment:6 Changed 5 years ago by Robby

  • Milestone set to Adium 1.5.3

comment:7 Changed 5 years ago by Robby

Please try 1.5.3rc1 from the beta page and let us know whether it resolves the issue. This version contains a change that should prevent the crash from happening.

comment:8 Changed 5 years ago by Thijs Alkemade <thijsalkemade@…>

(In 7e712e9c1fda) Fix a crash when handling a XML parsing error.

Fixes #16095

Note: See TracTickets for help on using tickets.