Adium

Opened 4 years ago

Closed 3 years ago

#16085 closed defect (fixed)

Some elements have NSAccessibilityRoleDescription attributes where NSAccessibilityTitleAttribute is more appropriate

Reported by: MarcoZ Owned by: MarcoZ
Milestone: Adium 1.5.3 Component: Adium UI
Version: 1.5.2 Severity: normal
Keywords: accessibility Cc:
Patch Status: Accepted

Description

Summary

Some tables and outline views, like the Accounts table in Preferences, have the attribute NSAccessibilityRoleDescriptionAttribute set with a string value/object that is more appropriate as an NSAccessibilityTitleAttribute.

Steps to reproduce

  1. Start Adium and turn on VoiceOver.
  2. Press Cmd+Comma to open Preferences and click on the Accounts tab/button.
  3. Navigate to the Accounts table via the Ctrl+Option+Right/Left Arrow commands.

Expected results

VoiceOver should say something like "Accounts Table".

Actual results

VoiceOver says "Accounts", but omits the fact that this is a table. It suppresses the speaking of the role "Table", which is an important piece of info for further interaction with this widget.

Regression

This was introduced somewhere between Adium 1.4 and 1.5 I believe. There were a lot of great enhancements made for accessibility, it's just that this attribute was not quite the right one to use.

Notes

A simple change of the override statements to use the NSAccessibilityTitleAttribute instead fixes this issue. No localization or other changes are required. I'll attach a patch to this bug that fixes the problem, and I believe it's even safe to take it in Adium 1.5.3.

Attachments (1)

fixTitles.diff (2.6 KB) - added by MarcoZ 4 years ago.
This fixes the occurrences of the wrong usage of NSAccessibilityRoleDescriptionAttribute.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by MarcoZ

This fixes the occurrences of the wrong usage of NSAccessibilityRoleDescriptionAttribute.

comment:1 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.3
  • Patch Status changed from Initially Included to Needs Dev Review

Thanks! :)

comment:2 Changed 4 years ago by ShawnRisk

I have tested this with 1.6 and this works for me. In the old version it says Accounts, but with the patch this now says Accounts table.

comment:3 Changed 4 years ago by Robert Vehse

  • Resolution set to fixed
  • Status changed from new to closed

(In 882f631d2f4e) Patch from Marco Zehe to fix tables not being declared as such via VoiceOver. Fixes #16085. Thanks!

comment:4 Changed 4 years ago by Robby

  • Patch Status changed from Needs Dev Review to Accepted

comment:5 Changed 4 years ago by Robby

Thanks to wixardy for the review. (Forgot to mention that in the commit, sorry.)

comment:6 Changed 4 years ago by Robert Vehse

(In af6d32e3c25f) Patch from Marco Zehe to fix tables not being declared as such via VoiceOver. Fixes #16085. Thanks!

comment:7 Changed 3 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

Reopen for correct attribution.

comment:8 Changed 3 years ago by Robby

  • Owner changed from robotive to MarcoZ

comment:9 Changed 3 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.