Adium

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16046 closed defect (fixed)

Unable to customise chat window toolbar (probably related to iTunes 10.6.3)

Reported by: Robby Owned by:
Milestone: Adium 1.5.3 Component: Adium Core
Version: 1.5.2hg Severity: regression
Keywords: Cc:
Patch Status:

Description (last modified by Robby)

Summary

I am unable to customise the chat window's toolbar. Clicking "Customise Toolbar" does nothing. Instead, I find output in Console (attached).

This is with the latest revision off the 1.5.2 branch (http://hg.adium.im/adium/rev/53975b9cbd27) as well as iTunes 10.6.3 on Mac OS X 10.6.8.

RPMozley reported this first on Cocoaforge:

Anyway, is anyone else having issues with current Adium 1.5.x and iTunes 10.6.3? Specifically with the chat window toolbar and the iTunes item. If the item is added to the toolbar the whole bar fails to show at all (manually adding the item to the plist - as can't be done using customize, see next line). Trying to customize the toolbar (without the iTunes item added) results in no drop down sheet at all and you're left with an unusable toolbar, with the only thing you can do is move the icons around (closing the window and reopening is the only option to restore functionality).

The exact fault is to do with Adium trying to load the iTunes icon file but can't because this version's icon file has only 1024px down to 256px and is missing all the smaller icon sizes. All the smaller sized icons are in a separate file named "iTunes_Leopard.icns" (512px to 16px) and after swapping this for the normal named file Adium no longer has the problems I listed previously.


Eric:

hmm, I wonder if it's worth still linking to that icon or if we should just include it ourselves

Attachments (1)

[Adium] Customise toolbar Console output.txt (7.2 KB) - added by Robby 5 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by Robby

  • Description modified (diff)
  • Milestone set to Adium 1.5.2
  • Severity changed from normal to regression
  • Version changed from 1.5.1 to 1.5.2hg

comment:2 Changed 5 years ago by paulwilde

Works under 10.7.4 (for me) so possibly a 10.6 issue.

comment:3 Changed 5 years ago by Robby

  • Description modified (diff)
  • Summary changed from Unable to customise chat window toolbar to Unable to customise chat window toolbar (probably related to iTunes 10.6.3)

comment:4 Changed 5 years ago by RPMozley

Ah, bum. I had submitted a ticket about this just a few minutes before this one. I suppose that one should be marked as duplicate to this one #16045

Last edited 5 years ago by wixardy (previous) (diff)

comment:5 Changed 5 years ago by Robby

Ticket #16045 has been marked as a duplicate of this ticket.

comment:6 Changed 5 years ago by Robby

Oh, sorry about that. But thanks again for your detective work. :)

comment:7 Changed 5 years ago by Robby

  • Description modified (diff)

comment:8 Changed 5 years ago by paulwilde

  • Milestone changed from Adium 1.5.2 to Adium 1.5.3

comment:9 Changed 5 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 635d3c31c55d) Apparently with iTunes 10.6.3 on Mac OS X 10.6.8, the NSIconRefImageRep that is returned by -iconfForFile: for iTunes fails to encode itself for NSCopying. As a workaround, convert it to TIFF and back before using it.

Fixes #16046

comment:10 Changed 5 years ago by Thijs Alkemade <thijsalkemade@…>

(In 314da3558120) Apparently with iTunes 10.6.3 on Mac OS X 10.6.8, the NSIconRefImageRep that is returned by -iconfForFile: for iTunes fails to encode itself for NSCopying. As a workaround, convert it to TIFF and back before using it.

Fixes #16046

Note: See TracTickets for help on using tickets.