Adium

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16041 closed defect (fixed)

Crash with Novell Groupwise account editor window close

Reported by: jeff_mahoney Owned by:
Milestone: Adium 1.5.2 Component: Service/Other
Version: 1.6hg Severity: normal
Keywords: groupwise Cc:
Patch Status: Accepted

Description (last modified by Robby)

Summary

If the Groupwise Account editor window is opened, closing it via OK or Cancel, regardless of whether anything is modified will cause a crash.

Steps to reproduce

  1. Start Adium
  2. Add Novell Groupwise account if none exists
  3. Edit account settings
  4. Close window *crash*

Expected results

Window should close and Adium should not crash

Actual results

Adium crashes

Regression

I have not tested versions previous to 1.5 but it occurs there and in a Mercurial snapshot taken 18 Jun 2012.

Notes

Attachments (2)

fix-double-release-in-aiaccountviewcontroller-s-dealloc (1.1 KB) - added by jeff_mahoney 5 years ago.
[PATCH] Fix double-release in AIAccountViewController's dealloc
adium-crash.log (54.4 KB) - added by jeff_mahoney 5 years ago.
Crash log

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by jeff_mahoney

[PATCH] Fix double-release in AIAccountViewController's dealloc

Changed 5 years ago by jeff_mahoney

Crash log

comment:1 Changed 5 years ago by Robby

  • Description modified (diff)
  • Milestone set to Adium 1.5.2
  • Patch Status changed from Initially Included to OK; Needs Check-In

Thank you!

Which name would you like to be credited with? (see 4. at http://trac.adium.im/wiki/ContributingCode#Committing)


Catfish_Man: that patch looks good to me

comment:2 Changed 5 years ago by jeff_mahoney

"Jeff Mahoney" works for me. I didn't see the contributing code page earlier. I'll attach a proper patch tomorrow.

comment:3 Changed 5 years ago by Robby

Okay, if you'd like to that's fine. I applied it manually and was ready to commit. ;)

comment:4 Changed 5 years ago by jeff_mahoney

Oh well if you've already gotten it squared away, I'm fine with that too.

comment:5 Changed 5 years ago by Robert Vehse

  • Resolution set to fixed
  • Status changed from new to closed

(In 122e8edb9c89) Patch from Jeff Mahoney to fix a crash when closing the Novell Groupwise account options. Fixes #16041.

"While trying to change the port number for my Novell Groupwise account, Adium crashed consistently when the account options window was closed.

I tracked it down to a double release of view_setup which, at least for Groupwise, is the same as view_options. Releasing them separately caused a problem later with the autorelease was later processed.

This patch only frees both if they are different values."

comment:6 Changed 5 years ago by Robby

  • Patch Status changed from OK; Needs Check-In to Accepted

Thanks again! :)

comment:7 Changed 5 years ago by sphynx

Ticket #15906 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.