Adium

Opened 5 years ago

Closed 2 years ago

Last modified 2 years ago

#16038 closed crash (fixed)

Adium crash each time I receive a file with the "bonjour" protocol

Reported by: Autiwa Owned by: quent
Milestone: Adium 1.5.11 Component: Service/Bonjour
Version: 1.5.1 Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description

Summary

With the 'bonjour' protocol, each time I receive a file, the application freeze. And when I will try to get a response from the software, it crashes.

Steps to reproduce

  1. Ask a friend in 'bonjour' to send you a file
  2. Wait that the transfer complete
  3. Once the file is received, the application freeze

Expected results

I should be able to speak and open the file without restarting the application again

Actual results

The application freeze (and crash when I try to do something with it)

Regression

I use Adium 1.5.1, but the problems already happened with Adium 1.5. Everything was OK with adium 1.4

I use mac OS X 10.6.8

Notes

None

Attachments (4)

Adium-[14-06-12].log (40.1 KB) - added by Autiwa 5 years ago.
error report for Adium
Adium_2012-06-14-093935_MacBook-Pro-de-**-**.crash (38.6 KB) - added by Autiwa 5 years ago.
crash file for the bug (I have 3 others if needed)
Crash report vlb.txt (60.6 KB) - added by vlbrown 3 years ago.
crash report
BonjourDownloadCrashOS10_9_4Adium10_5_10.txt (74.8 KB) - added by quent 2 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 5 years ago by Autiwa

The version before 1.5 was 1.4.5, so I suppose everything was ok up to 1.4.5

comment:2 Changed 5 years ago by Robby

  • Status changed from new to pending

Please follow the instructions to get a crash report and attach it to this ticket.

Changed 5 years ago by Autiwa

error report for Adium

comment:3 Changed 5 years ago by Autiwa

  • Status changed from pending to new

I just added a log file. I copied everything that was displayed in the mac window asking me to report a bug. Before, I could relaunch adium, or report, or ignore.

During the process, no file at all displayed in the folder ~/Library/Logs/DiagnosticReports

[edit]
I don't know how I managed to go in the / directory, but know I have the crash file you asked me. I even have 4's.

Last edited 5 years ago by Autiwa (previous) (diff)

Changed 5 years ago by Autiwa

crash file for the bug (I have 3 others if needed)

Changed 3 years ago by vlbrown

crash report

comment:4 Changed 3 years ago by vlbrown

Sam problem here. Both of us using Adium 1.5.7. One using Lion (10.7.5) one using Mntn Lion (10.8.5)

FIle saves; Adium dies.

comment:5 Changed 2 years ago by quent

+1 same problem still exists on Adium 1.5.10 / OS 10.9.4

Looks like Download object not properly released or not released upon download/upload completion.

Also crashed on machine running OS 10.9.5 / Adium 1.5.10 sending the file
Crash log with stack trace attached

Last edited 2 years ago by quent (previous) (diff)

comment:6 Changed 2 years ago by quent

Created a fix for it: https://bitbucket.org/qles/adium/commits/a21b916829e03953a45f96ffcbf0897d54999ca0

Because the receiver doesn't crash anymore, the sender doesn't anymore either (I didn't investigate why it did in the first place)

comment:7 Changed 2 years ago by wixardy

  • Patch Status set to Needs Dev Review

comment:8 Changed 2 years ago by Quentin Les <quentmail-spam@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 8661cafccf3c) Fixed double release causing crash upon file transfer completion on Bonjour. Fixes #16038, references #16182.

comment:9 Changed 2 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

comment:10 Changed 2 years ago by Robby

  • Milestone set to Adium 1.5.11
  • Owner set to quent

comment:11 Changed 2 years ago by Robby

  • Patch Status changed from Needs Dev Review to Accepted
  • Resolution set to fixed
  • Status changed from new to closed

comment:12 Changed 2 years ago by Robby

Hi everyone, today’s nightly includes the fix mentioned above. Maybe you’d like to try it and confirm the issue as fixed?

Note: See TracTickets for help on using tickets.