Adium

Opened 14 years ago

Closed 11 years ago

Last modified 11 years ago

#1583 closed defect (fixed)

MSN: With multiple group chats, all messages appear in the same chat

Reported by: lenabee@mac.com Owned by: cbarrett
Milestone: Adium 1.3.1 Component: Service/MSN
Version: Severity: normal
Keywords: WasOn1.5 Cc:
Patch Status: Accepted

Description

When I am involved in a multi-user chat on MSN and someone tries to initiate another multi-user chat with me, both chats appear in the same window as if all participants are in the same chat. I believe this is because by default Adium names both chats MSN Chat, but I am not sure.

Attachments (1)

dragoonkainMSNMultiChat.diff (1.3 KB) - added by Casey Lutz 11 years ago.
Possible patch for MSN Multi-GroupChat bug

Download all attachments as: .zip

Change History (33)

comment:1 Changed 14 years ago by David Smith

Milestone: Adium X 1.5

Group chat -> 1.5

Also, getting confirmation on this from someone else would be great.

comment:2 Changed 14 years ago by David Smith

Actually, #804 is a dupe of this, so I'd say it's confirmed.

comment:3 Changed 14 years ago by brett@…

Confirmed, multiple group conversations just dont work with adium.

If i am in one group conversation and get added to another, both chats appear int he same window. Even though there are two physical conversations going.

Real pain in the butt.

comment:4 Changed 13 years ago by PoultryChamp

Yes, very very annoying. I just really hope they fix this bug for Mac 1.3. =(

comment:5 Changed 13 years ago by Evan Schoenberg

field_haspatch: 0
Severity: omgwtfbbqnormal
Summary: multiple chats appear in same windowMSN: With multiple group chats, all messages appear in the same chat

comment:6 Changed 13 years ago by aragost

I can confirm this - I even filed #6075 before seeing this ticket. Still present as of 1.0. I think that this is quite severe, so maybe severity and milestone should be different.

comment:7 in reply to:  description Changed 13 years ago by Félix Cloutier

I confirm, too. http://trac.adiumx.com/ticket/6086

I also think it should go on higher priority.

comment:8 Changed 13 years ago by erik006

Component: MSNlibpurple
Patch Status: None

This seems to be a libpurple limitation, so

comment:9 Changed 13 years ago by Eric Richie

Milestone: Adium X 1.5Waiting on libpurple

libpurple limitation = waiting on libpurple

comment:10 Changed 13 years ago by Evan Schoenberg

I don't think this is a libpurple limitation... Could someone see if Pidgin or Finch have the same behavior?

comment:11 in reply to:  10 Changed 13 years ago by Brett

Replying to evands:

I don't think this is a libpurple limitation... Could someone see if Pidgin or Finch have the same behavior?

Just tried pidgin 2.0 on my work PC. Group chats work fine and as expected. I don't think this problem is a libpurple limitation.

comment:12 Changed 13 years ago by Evan Schoenberg

As suspected. Group chats currently use 'name' as an identifier. There's a separate identifier which should be used.

comment:13 Changed 13 years ago by Evan Schoenberg

Sigh. We really need someone interested in Adium development who actually uses MSN. This took about 30 minutes to create what I believe is a fix, and it has been a major flaw in our MSN implementation for 2 years.

comment:14 in reply to:  13 Changed 13 years ago by Brett

Replying to evands:

Sigh. We really need someone interested in Adium development who actually uses MSN. This took about 30 minutes to create what I believe is a fix, and it has been a major flaw in our MSN implementation for 2 years.

I've been sitting in the background for a while now but have decided to get off my butt and see if I can help out. I use MSN primarily so would be happy to attempt to look at MSN issues. Just grabbed a copy of the latest source and i'll see how i go getting up to speed with it.

comment:15 Changed 13 years ago by Evan Schoenberg

Fantastic :)

I'm committing my changes which should fix the MSN chat issue described here. Do let me know if it's an effective fix.. and beyond that, the sky's the limit for any fixes or improvements you want to make, really. As far as the underlying protocol code (libpurple) goes, there's a Summer of Code student with the Pidgin project who will be making a lot of changes and improvements there, I believe -- you could get involved with him, too, if that angle were interesting to you.

comment:16 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [19733]) Use an identifier, not a name, for uniquely looking up chats from account code. This allows us to have multiple chats with the same name displayed to the user... so MSN's group chat implementation which says 'MSN Chat' for all chats works properly. Fixes #1583

comment:17 in reply to:  16 Changed 13 years ago by Brett

Replying to evands:

(In [19733]) Use an identifier, not a name, for uniquely looking up chats from account code. This allows us to have multiple chats with the same name displayed to the user... so MSN's group chat implementation which says 'MSN Chat' for all chats works properly. Fixes #1583

Had this same problem occur again today out of the blue. Has been working fine since the last update. Today, I was invited to one group conversation, then 15mins later I was invited to another separate group conversation. All contacts (from both group chats) were added to the same 'MSN Chat' window. Didn't seem to affect the other contacts, just me.

Seems there are still problems.

comment:18 Changed 13 years ago by Evan Schoenberg

Milestone: Waiting on libpurpleAdium X 1.5
pending: 0
Resolution: fixed
Status: closedreopened

comment:19 Changed 12 years ago by Chris Forsythe

Keywords: WasOn1.5 added; MSN group chat removed
Milestone: Adium X 1.5Good idea for "later"

As the group chat SoC 2007 project completed successfully, we no longer require a group chat milestone. As such, I'm going to move all of these over to Good Idea for "later". Process these normally, reassign as needed to the new 1.x milestones created last night.

comment:20 Changed 12 years ago by aragost

Happened again to me today, adding some more detail: Let's assume you are talking in group chat 1 and get invited in group chat 2. This is what happens. 1) You see one window with alle the participants from both gc1+gc2. You read messages from both, but what you say gets passed to gc1 only. 2) If you close the window, people from gc1 can invite you back, people from gc2 cannot (you're still in, apparently) 3) As soon as someone in gc2 talks, a window spawn, boasting participants from gc1+gc2. 4) In this new window, you can read what gc2 is saying but no matter how much you write, in adium group chats no one can hear you typing (alien quote). 5) If you close this window you go back to step 2, until you quit and reopen adium. Hope this helps; also, I personally think this bug is quite serious and it's not just a "good idea for later" ;)

comment:21 Changed 12 years ago by Robert

Component: libpurpleMSN

comment:22 Changed 12 years ago by Brett

This is still happening, exactly how aragost explains.

We now have facebook chat in Adium, yet basic group chat in MSN is still bugged.

I'll take another look at the source, it's so hard to get into though.

comment:23 Changed 12 years ago by Carlos Morales

comment:24 Changed 11 years ago by Brett

Was hoping the new version using MSN-Pecan would resolve this issue. Unfortunately not.

Still cannot have multiple group chats with Adium.

As another test, create a new group chat with 3 people. Then go and try to create a new group chat with some other people... they all get added to the same group chat window and not separate group conversations.

Changed 11 years ago by Casey Lutz

Possible patch for MSN Multi-GroupChat bug

comment:25 Changed 11 years ago by Casey Lutz

I looked at the code a bit today and made a change that seems to have worked for the issue I was seeing. I was being invited to multiple group chats, they were all converged into one tab and my text was only seen in the first group chat.

After implementing my change, it seems to work. This is my first foray into Obj-C, so it may need some work.

comment:26 Changed 11 years ago by Robert

Patch Status: NoneInitially Included

comment:27 in reply to:  25 Changed 11 years ago by Colin Barrett

Replying to dragoonkain:

I looked at the code a bit today and made a change that seems to have worked for the issue I was seeing. I was being invited to multiple group chats, they were all converged into one tab and my text was only seen in the first group chat.

After implementing my change, it seems to work. This is my first foray into Obj-C, so it may need some work.

Please read CodingStyle. Also note that for Objective-C objects, use nil not NULL.

comment:28 Changed 11 years ago by Colin Barrett

Owner: changed from nobody to Colin Barrett
Status: reopenednew

comment:29 Changed 11 years ago by Colin Barrett

Patch Status: Initially IncludedNeeds Dev Review

I'm testing this patch to make sure it works.

comment:30 Changed 11 years ago by Colin Barrett

Resolution: fixed
Status: newclosed

(In [25078]) MSN: With multiple group chats, all messages no longer appear in the same chat. Fixes #1583. Patch from Casey "dragoonkain" Lutz. CodingStyle fixes by me.

comment:31 Changed 11 years ago by Colin Barrett

(In [25079]) Merged 25078: MSN: With multiple group chats, all messages no longer appear in the same chat. Fixes #1583. Patch from Casey "dragoonkain" Lutz. CodingStyle fixes by me.

comment:32 Changed 11 years ago by Colin Barrett

Milestone: Good idea for "later"Adium 1.3.1
Patch Status: Needs Dev ReviewAccepted
Note: See TracTickets for help on using tickets.