Adium

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15823 closed defect (fixed)

Adium is unresponsive, then crashes.

Reported by: Robby Owned by:
Milestone: Adium 1.5.2 Component: Adium Core
Version: 1.5hg Severity: regression
Keywords: Cc: sphynx
Patch Status:

Description

Summary

This is probably hard to reproduce but here's what happened:
While chatting I opened the Transcript Viewer to copy a line from a recent chat. After that, I quickly closed it to paste it into the input box. Soon after that, Adium became unresponsive and crashed.

I'm attaching the diagnostic reports, a sample and the crash log,

Attachments (2)

Adium Transcript Viewer hang.txt (5.7 KB) - added by Robby 5 years ago.
Hang
Adium Transcript Viewer crash.txt (5.7 KB) - added by Robby 5 years ago.
Crash

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by Robby

Hang

Changed 5 years ago by Robby

Crash

comment:1 Changed 5 years ago by Robby

  • Cc sphynx added
  • Milestone set to Adium 1.5
  • Severity changed from normal to regression

comment:2 Changed 5 years ago by robotive

  • Milestone changed from Adium 1.5 to Adium 1.5.1

comment:3 Changed 5 years ago by evands

Logs show an apparent race condition between -[AILoggerPlugin _closeLogIndex] and -[AILoggerPlugin removePathsFromIndex:]; one was called while the other was executing.

comment:4 Changed 5 years ago by Robby

  • Milestone changed from Adium 1.5.1 to Adium 1.5.x

comment:5 Changed 5 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In b54f715ec8a7) -logContentIndex now always returns a +1 retained copy, to avoid problems with other threads requesting it while it is being closed.

Fixes #15823, refs #15984

comment:6 Changed 5 years ago by Robby

  • Milestone changed from Adium 1.5.x to Adium 1.5.2

comment:7 Changed 5 years ago by Thijs Alkemade <thijsalkemade@…>

(In ecf20cb0356c) Forgot to also commit this file in b54f715ec8a7.

Refs #15823, refs #15984

comment:14 Changed 5 years ago by sphynx

Ticket #16058 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.