Adium

Opened 9 years ago

Last modified 8 years ago

#15809 new defect

AIM https request required error on every connect

Reported by: IWishThatAdiumWereWorking Owned by:
Milestone: Component: Service/AIM
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

I now receive the following error on every reconnect that Adium makes to AIM. Sometimes, Adium connects afterwards, sometimes it does not. This occurs in particular when my Mac wakes from sleep. I get the error on multiple machines, on multiple networks.

Steps to reproduce

Detail the exact steps taken to produce the bug. Use the following format, each line with " 1." before it:

  1. Connect to AIM
  2. Sleep Mac
  3. Wake Mac
  4. Get error:

Received unexpected response from https://api.screenname.aol.com/auth/clientLogin: Method not allowed - https request required

Expected results

Adium connects properly, using the correct method.

Actual results

Received unexpected response from https://api.screenname.aol.com/auth/clientLogin: Method not allowed - https request required

Regression

This has been happening for several weeks.

Change History (12)

comment:1 Changed 9 years ago by Robert

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Robert

Closed as duplicate of #15807.

comment:3 Changed 9 years ago by Robert

Ticket #15764 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by Robert

Component: Adium CoreService/AIM
Resolution: duplicate
Status: closednew

comment:5 Changed 9 years ago by Robert

Status: newpending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:6 Changed 9 years ago by IWishThatAdiumWereWorking

Looks like I'm getting the original error from #15764 again on wake:

Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid Request. statusDetailCode 1015

comment:7 Changed 9 years ago by David Munch

Is the following enough?

18:21:06: (Libpurple: oscar) startOSCARSession response statusCode was 400: <?xml version="1.0" encoding="UTF-8"?>
<response xmlns="http://developer.aim.com/xsd/aim.xsd"><statusCode>400</statusCode><statusText>Invalid Request.  statusDetailCode 1015</statusText><statusDetailCode>1015</statusDetailCode><data><ts>1328635266</ts><upgradeData></upgradeData><betaData></betaData></data></response>
18:21:06: (Libpurple: connection) Connection error on 0x1026b4ca0 (reason: 16 description: Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid Request.  statusDetailCode 1015)
18:21:06: Connection Disconnected: gc=26b4ca0 (Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid Request.  statusDetailCode 1015)
18:21:06: <ESPurpleAIMAccount:5e29e90 39>:davidmunch1982 accountConnectionReportDisconnect: Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid Request.  statusDetailCode 1015
18:21:06: (Libpurple: account) Disconnecting account DavidMunch1982 (0x103496830)
18:21:06: (Libpurple: connection) Disconnecting connection 0x1026b4ca0
18:21:06: (Libpurple: oscar) Signed off.
18:21:06: Disconnected: gc=26b4ca0

comment:8 Changed 9 years ago by IWishThatAdiumWereWorking

I found the following in my console log this morning after getting the error:

2/7/12 6:39:57.654 AM [0x0-0x3c03c].com.adiumX.adiumX: SocketRead err = -9806
2/7/12 6:39:57.656 AM [0x0-0x3c03c].com.adiumX.adiumX: cdsa: SSLHandshake failed with error -9806 (connection closed via error)
2/7/12 6:57:20.410 AM [0x0-0x3c03c].com.adiumX.adiumX: SocketRead err = -9806
2/7/12 6:57:20.410 AM [0x0-0x3c03c].com.adiumX.adiumX: cdsa: SSLHandshake failed with error -9806 (connection closed via error)
2/7/12 7:36:58.622 AM [0x0-0x3c03c].com.adiumX.adiumX: SocketRead: read(5) error 0
2/7/12 7:36:58.622 AM [0x0-0x3c03c].com.adiumX.adiumX: SocketRead err = -9802
Last edited 9 years ago by Robert (previous) (diff)

comment:9 Changed 9 years ago by mathuaerknedam

Status: pendingnew

comment:10 Changed 8 years ago by ObtuseMastadon

Would it be possible to at least have adium retry this type of connection failure? It's transient so I don't always notice when an account or two failed to reconnect.

comment:11 Changed 8 years ago by hilyin

I've been having this problem for about 3 months now. Extremely annoying. Please fix!

Error: Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid Request.  statusDetailCode 1015

comment:12 Changed 8 years ago by Kelly

I can reproduce this pretty consistently on 10.7.2, version 1.5.4 (11/7/12). It was happening before that update as well. If I have all accounts online, then take them offline and come back online, I get the following error:

Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid Request. statusDetailCode 1015

I can click OK and then AIM doesn't connect, but if I go set it online manually it works fine. If there is a log or anything I can submit to help get this sorted, let me know where it is and I will add it here. (I wouldn't add this here but the ticket that matches my error says it's closed as a duplicate of this ticket.)

Note: See TracTickets for help on using tickets.