Adium

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15772 closed patch (fixed)

Adium 1.5b9 Slovenian localization

Reported by: mojca Owned by: Robby
Milestone: Adium 1.5 Component: Localization
Version: 1.5b9 Severity: normal
Keywords: Cc:
Patch Status:

Description

I'm attaching slovenian localization for Adium. It is not absolutely complete and even if you decide not to include it for the release because of that, I would really like to ask for including it before branching for Adium 1.6.

NIBs should be fine - I have reviewed the layout, but strings might be incomplete and not all of them were heavily tested.

If release of 1.5 gets delayed, I can try to make the translations more complete and accurate, but I wanted to stick to the deadline with the first version.

Attachments (4)

Adium.zip (616.3 KB) - added by mojca 8 years ago.
Slovenian translations of Adium 1.5b9 (300 translations missing)
Adium.2.zip (576.8 KB) - added by mojca 8 years ago.
Latest translations based on v. 1.5rc1
ilocalize-duplicates.png (80.8 KB) - added by mojca 8 years ago.
Some translations were lost and some files appear three times.
ilocalize-sparkle-errors.png (104.1 KB) - added by mojca 8 years ago.
I get many Sparkle-related errors.

Download all attachments as: .zip

Change History (27)

Changed 8 years ago by mojca

Slovenian translations of Adium 1.5b9 (300 translations missing)

comment:1 in reply to: ↑ description Changed 8 years ago by Robby

  • Milestone set to Adium 1.5

Replying to mojca:

I'm attaching slovenian localization for Adium. It is not absolutely complete and even if you decide not to include it for the release because of that, I would really like to ask for including it before branching for Adium 1.6.

Thanks a lot!

NIBs should be fine - I have reviewed the layout, but strings might be incomplete and not all of them were heavily tested.

I checked a few account preferences (Jabber, AIM, ICQ) and it looked like the needed to be rebuilt as they were missing a lot of options.

If release of 1.5 gets delayed, I can try to make the translations more complete and accurate, but I wanted to stick to the deadline with the first version.

It appears 1.5b10 will go out tomorrow but the release candidate will get delayed. For b10, I'll check in tomorrow what you have by then, and I can check in an updated bundle for the release candidate later this week.

comment:2 Changed 8 years ago by mojca

Thank you very much for the information about the need to rebuild. However, I'm unable to figure out how to rebuild it. I just checked ESPurpleJabberAccountView if that is what you are talking about. Right-clicking and "Rebuild files from English" doesn't seem to have any effect at all. I was curious about that ... because many nib files have a lot more strings that I'm able to see in the nib. But I seem to be unable to figure out how to rebuild them properly. I did click on "rebuild" for each and every nib.

However I got many error reports both during import and one red arrow like a warning during export (but no message what it was about). I have constant problems with iLocalize "eating my old translations", I'm unable to transfer data from one computer to the other, even if I transfer everything (it just forgets some of my strings and replaces them with English strings etc.).

If there will be b10, that's great news for me since it will give me some more time to complete translation and fix problems. (Please don't wait for a new version from me to build b10, just take this one. Current translation also has some flaws like missing options in user interface.)

What happens if you try to rebuild my translated nibs? Does it work properly? If somebody can send me updated nibs & everything, maybe I can try to import everything as a new project and start entirely from fresh. Please let me know.

comment:3 Changed 8 years ago by Robert Vehse

(In dcbb4924e6ae) Add Slovenian for a bunch of resources. References #15772.

comment:4 Changed 8 years ago by Robert Vehse

  • Resolution set to fixed
  • Status changed from new to closed

(In fc5137a82462) Updated Slovenian localisation for 1.5b9 from mojca. Fixes #15772.

comment:5 Changed 8 years ago by Robby

Oh deary, deary me. We messed up quite a bit there. We had Slovenian missing from a bunch of resources. That caused the problems you ran into. I found out when setting up a project for Slovenian in iLocalize. I should have tried that earlier when you mentioned in an email that resources were vanishing.

I'm really, really sorry for all the hassle caused. :(

I have committed the changes you submitted here and as far as I can tell, the translation is almost perfect. This also means you can at least rest assured that this work you have done is not lost when working from b10. :)

Last edited 8 years ago by Robby (previous) (diff)

comment:6 Changed 8 years ago by Robert Vehse

(In 5a02366a9b29) Credit Mojca Miklavec for the Slovenian localisation. References #15772.

Fix the width of a button in the Danish "Messages" preferences at David Munch's request.

comment:7 Changed 8 years ago by mojca

Not sure if anyone still reads closed tickets, but I would like to understand why five smilies (like Baring Teeth) are not translated with the latest nightly from 16th January (4514). Other names of smilies definitely come from this latest bunch of translations, so translations seem to be included.

Since translation is not 100% complete it is not such a problem, but I would like to make sure that there are not some other problems hidden somewhere.

comment:8 follow-up: Changed 8 years ago by mojca

Ok, I now see that my files and names of emoticons have a different capitalization (Baring Teeth vs. Baring teeth). I guess that this name will change for 1.5b10?

comment:9 in reply to: ↑ 8 Changed 8 years ago by Robby

Hey mojca, I marked this ticket as fixed as I had checked in the changes you had submitted. Of course, I can still commit more changes. :

Replying to mojca:

Ok, I now see that my files and names of emoticons have a different capitalization (Baring Teeth vs. Baring teeth). I guess that this name will change for 1.5b10?

Sorry, what do you mean by that?

comment:10 Changed 8 years ago by mojca

For 1.5b9 I was asked to translate "Don't Tell Anyone" for example (inside EmoticonNames.strings) which resulted in

/* Emoticon name */
"Don't Tell Anyone" = "Ne povej nikomur";

but in latest nightly version (4515) I see "Don't tell anyone :-#" instead of "Ne povej nikomur :-#". The reason is that "Don't Tell Anyone" and "Don't tell anyone" are not the same string.

I guess that this change was intentional and that translators will be asked to fill in the gaps for 1.5b10 again?

Last edited 8 years ago by mojca (previous) (diff)

comment:11 Changed 8 years ago by Robby

Oh, I'm seeing the same in German. I'll see if I can get someone to investigate that. Thanks!

comment:12 follow-up: Changed 8 years ago by mojca

I tried a fresh rc1 and tried to create a new project. I get the following "problems":

  • I see 10 files InfoPlist.strings (for example one with (C) Kaabomerang LLC, 2007) which appear to have untranslated strings, but a red sign under Status saying "File does not exist on disk".
  • Same is true for Sparkle.strings. A red message saying that files don't exist. There are two identical Sparkle.strings. I have sent translation to Sparkle and I have probably sent translation to Adium last time. Is there any way to "get rid of message"?
  • Localizable.strings with 1222 translations appears as if it was completely translated. It seems that something in the process fills in all the missing translations with English strings. OK, they are easy to spot (just sorting according to status, delete all with identical string and then redo all where string should indeed be identical), but this is one of those nasty situations where iLocalize is behaving weird and in a way that I don't like. It makes it hard to figure out what exactly needs to be translated.

In the meantime I have noticed that double-clicking, say, ESPurpleJabberAccountView.nib, leads to xcode with 4 different objects on the left (setup, Options, Privacy, Registration Server panel). I didn't see any of those earlier and this was the piece of information I was looking for earlier. I didn't check any other object earlier apart from the first one that appeared on screen.

comment:13 in reply to: ↑ 12 ; follow-ups: Changed 8 years ago by Robby

Thanks again, for going to great lengths to help us improve the localisation process.

Replying to mojca:

<snip>but I would like to understand why five smilies (like Baring Teeth) are not translated with the latest nightly from 16th January (4514). Other names of smilies definitely come from this latest bunch of translations, so translations seem to be included.

This will be fixed tonight. Thanks for pointing out this issue.

Replying to mojca:

I tried a fresh rc1 and tried to create a new project. I get the following "problems":

  • I see 10 files InfoPlist.strings (for example one with (C) Kaabomerang LLC, 2007) which appear to have untranslated strings, but a red sign under Status saying "File does not exist on disk".
  • Same is true for Sparkle.strings. A red message saying that files don't exist. There are two identical Sparkle.strings. I have sent translation to Sparkle and I have probably sent translation to Adium last time. Is there any way to "get rid of message"?

You can ignore those for now. I will inquire if it possible to make them not show up in iLocalize.

  • Localizable.strings with 1222 translations appears as if it was completely translated. It seems that something in the process fills in all the missing translations with English strings. OK, they are easy to spot (just sorting according to status, delete all with identical string and then redo all where string should indeed be identical), but this is one of those nasty situations where iLocalize is behaving weird and in a way that I don't like. It makes it hard to figure out what exactly needs to be translated.

That sounds very bad. The Slovenian project I created from rc1 in iLocalize also shows some identical strings. I will try to find out about that as well.

In the meantime I have noticed that double-clicking, say, ESPurpleJabberAccountView.nib, leads to xcode with 4 different objects on the left (setup, Options, Privacy, Registration Server panel). I didn't see any of those earlier and this was the piece of information I was looking for earlier. I didn't check any other object earlier apart from the first one that appeared on screen.

Yes, some .nibs need adjustments.

Last edited 8 years ago by Robby (previous) (diff)

comment:14 in reply to: ↑ 13 Changed 8 years ago by Robby

Replying to Robby:

This will be fixed tonight. Thanks for pointing out this issue.

http://hg.adium.im/adium/rev/065615aec05d

comment:15 in reply to: ↑ 13 Changed 8 years ago by Robby

Replying to Robby:

This will be fixed tonight. Thanks for pointing out this issue.

This fix is in rc2 which we just released.

comment:16 Changed 8 years ago by Robby

Any updates here? :)

Changed 8 years ago by mojca

Latest translations based on v. 1.5rc1

comment:17 Changed 8 years ago by mojca

I'm sorry for the very long delay and for missing the main release, I was travelling and busy. I now did a very careful check of nib files (with lots of modifications). There are still approximately 100 missing translations (I have problems figuring out how exactly to use them or how they are being used). I hope that there are not too many differences with the latest version in repository. When importing translations, please check that they will be in consistent state with latest version. I have many warnings/errors here (File does not exist on disk), but I don't think that they matter - they are mostly related to Sparkle.

comment:18 follow-up: Changed 8 years ago by mojca

I have a few more questions. For example, I was unable to find how to translate the following:

Edit -> Undo
Edit -> Redo
Edit -> Spelling -> Show Spelling and Grammar
Edit -> Special Characters
Help -> View Release Notes

And I wasn't able to find where to change:

Uredi vCard za XMPP
...
Družinsko ime (it should be "Priimek" instead)

comment:19 in reply to: ↑ 18 Changed 8 years ago by Robby

Thanks for the update, I will have a look. Don't worry about the delay, we're all volunteers. :)

Replying to mojca:

I have a few more questions. For example, I was unable to find how to translate the following:

Edit -> Undo
Edit -> Redo
Edit -> Spelling -> Show Spelling and Grammar
Edit -> Special Characters

I cannot find those strings in source either. I suspect these strings are handled by OS X...

Help -> View Release Notes

Oh, I think that strings wasn't made localisable. Would you mind filing a ticket for that?

And I wasn't able to find where to change:

Uredi vCard za XMPP
...
Družinsko ime (it should be "Priimek" instead)

I didn't find that string either. I suspect it's a libpurple one. You could file a ticket here: http://developer.pidgin.im/.

comment:20 Changed 8 years ago by Robert Vehse

(In 988dd03dc2cb) Updated Slovenian localisation based on 1.5rc1 from mojca. References #15772.

comment:21 Changed 8 years ago by Robby

Looked spotless to me. :)

Changed 8 years ago by mojca

Some translations were lost and some files appear three times.

Changed 8 years ago by mojca

I get many Sparkle-related errors.

comment:22 Changed 8 years ago by mojca

I'm not sure if I need a new ticket for this or not (I can create a new one if needed - just tell me). See the two attached PNGs.

When I try to create a new project with iLocalize (using nightly 1.6ghr4738) I get a lot of Sparkle-related errors, some duplicates (or rather "triplicates": same file displayed three times), some translations lost (the latter might be because of different capitalization in English - I need to check that). Is it possible to get rid of those somehow?

Also, many strings that were left untranslated are now equal to their English counterpart (please see the largest Localizable.strings; I can attach a screenshot if needed), so after any upgrade I always have to manually check each and every file, delete all English expressions on the right and then add again those that are indeed equivalent (like "%.1f KB").

comment:23 Changed 8 years ago by Robby

Sorry for the late response. I just created another Slovenian project from scratch in ILocalize and I cannot reproduce the issue of duplicate resources.

I do see some strings were made equal to their originals. That sucks but I do not know how that would come about.

Last edited 8 years ago by Robby (previous) (diff)
Note: See TracTickets for help on using tickets.