Adium

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15733 closed defect (fixed)

Incorrect German localization for attention requests

Reported by: sflothow Owned by: mwulftange
Milestone: Adium 1.5 Component: Localization
Version: 1.4.5 Severity: normal
Keywords: Cc:
Patch Status:

Description

When requesting someone's attention via Jabber, Adium displays the text "Sie bitten [user] um seine Aufmerksamkeit". However, "seine" is the masculine form, for a female user it'd have to be "ihre". Since Adium can't know the correct gender, I suggest leaving it out completely, i.e. just "Sie bitten [user] um Aufmerksamkeit".

Also, the menu entry for sending an attention request is labeled "Benachrichtigung senden", which is very unspecific, and not consistent with the action the menu entry performs. I think "Um Aufmerksamkeit bitten" would be better.

Attachments (1)

Adium 1.5rc1 build 1.5rc1 (de).zip (647.6 KB) - added by mwulftange 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by Robby

  • Owner changed from Robby to mwulftange

comment:2 in reply to: ↑ description ; follow-up: Changed 8 years ago by mwulftange

Replying to sflothow:

When requesting someone's attention via Jabber, Adium displays the text "Sie bitten [user] um seine Aufmerksamkeit". However, "seine" is the masculine form, for a female user it'd have to be "ihre". Since Adium can't know the correct gender, I suggest leaving it out completely, i.e. just "Sie bitten [user] um Aufmerksamkeit".

Acknowledged.

Also, the menu entry for sending an attention request is labeled "Benachrichtigung senden", which is very unspecific, and not consistent with the action the menu entry performs. I think "Um Aufmerksamkeit bitten" would be better.

Well, the original label is “Send Notification” and every “notification” is translated as “Benachrichtigung”. So consequently translating “Send Notification” as “Benachrichtigung senden” is right.

I’ve never used one of these features intentionally and I don’t know the difference between notifications and mentions (if there is any) and thus cannot judge whether changing the localization is appropriate. Maybe anyone else can help if notifications and mentions can be used interchangeably in Adium.

comment:3 follow-up: Changed 8 years ago by Robby

"Send Notification" refers to the "Nudge" (MSN) and "Buzz" (Yahoo) features (http://adium.im/blog/2007/08/how-to-use-nudgebuzz-in-adium/, http://adium.im/help/pgs/AdvancedFeatures-NudgeBuzz.html). We might want to change this label, yeah. "Send notification" seems quite unspecific to me. I'll check with zacw who added this feature.

Mentions are somewhat different: http://adium.im/help/pgs/Messaging-Mentions.html.

Last edited 8 years ago by Robby (previous) (diff)

comment:4 in reply to: ↑ 2 Changed 8 years ago by sflothow

Replying to mwulftange:

Well, the original label is “Send Notification” and every “notification” is translated as “Benachrichtigung”. So consequently translating “Send Notification” as “Benachrichtigung senden” is right.

Taken for itself, this is correct. However, the problem is that the wording in the menu entry doesn't match the resulting message in the chat window.

I noticed this when someone sent me an attention request, which I didn't even know was possible, so I then started looking for a way to send attention requests myself. However, I couldn't find any button or menu entry labeled "Aufmerksamkeit" or similar, and I had pretty much given up when in desperation I tried "Benachrichtigung senden", expecting it to do something entirely different, only to find that it was indeed what I was looking for. So a more specific label for this menu entry would have saved some pointless foraging in the menus, though I guess strictly speaking this isn't a L10N issue, as the vagueness actually originates from the English wording.

comment:5 in reply to: ↑ 3 Changed 8 years ago by sflothow

Replying to Robby:

"Send Notification" refers to the "Nudge" (MSN) and "Buzz" (Yahoo) features

In XMPP it's known as "Attention" (see XEP-0224, http://xmpp.org/extensions/xep-0224.html), so there are (at least) three choices for the wording in Adium. Actually "buzz" seems a bit weird to me, and I wouldn't know how to translate it to German (but then again English is not my native tongue). While I suppose "Nudge" and "Request attention" could both work, I'd prefer "Request attention" - it may sound a bit formal, but it's much clearer as to what it does.

comment:6 Changed 8 years ago by Robby

Sorry to nitpick, mwulftange, but I (and the reporter likely too) would be interested to know which changes this bundles has in relation to the issues brought up in this ticket.

Changed 8 years ago by mwulftange

comment:7 Changed 8 years ago by mwulftange

Replying to Robby:

Sorry to nitpick, mwulftange, but I (and the reporter likely too) would be interested to know which changes this bundles has in relation to the issues brought up in this ticket.

Sorry, I forgot. I’ve updated the localization as follows:

  • “Sie bitten %@ um seine Aufmerksamkeit” ⟹ “Sie bitten %@ um Aufmerksamkeit”
  • “Benachrichtigung senden” ⟹ “Um Aufmerksamkeit bitten”

comment:8 in reply to: ↑ description Changed 8 years ago by Robby

Thanks, mwulftange.

Replying to sflothow:
<snip>

Also, the menu entry for sending an attention request is labeled "Benachrichtigung senden", which is very unspecific, and not consistent with the action the menu entry performs. I think "Um Aufmerksamkeit bitten" would be better.

I think the root problem for this lies in the original wording in English. "Benachrichtigung senden" translates "Send Notification" which is inaccurate itself in my opinion.

Hence, I have filed #15789.

Last edited 8 years ago by Robby (previous) (diff)

comment:9 Changed 8 years ago by Robert Vehse

  • Resolution set to fixed
  • Status changed from new to closed

(In 202d3335d827) Updated German localisation for 1.5rc1 from mwulftange. References #15586. Half fixes #15733. (See #15789)

comment:10 Changed 8 years ago by Robby

  • Milestone set to Adium 1.5

Issue 1 is fixed. Issue 2 needs to be fixed in English still (#15789).

Thanks, everyone!

Note: See TracTickets for help on using tickets.