Adium

Opened 8 years ago

Closed 8 years ago

#15581 closed crash (fixed)

Adium crashes under Lion 10.7.2 when clicking install on an xtra

Reported by: tigersoul Owned by: earthmkii
Milestone: Adium 1.4.4 Component: Adium Core
Version: 1.4.3 Severity: regression
Keywords: Lion 10.7 Cc:
Patch Status:

Description (last modified by Robby)

Summary

Adium crashes when clicking install on an adium xtra at the xtras site.

Steps to reproduce

  1. Click install link in adium xtras site w Lion 10.7.2 installed
  2. The percent meter starts but adium crashes at about 80%

Expected results

It working?

Actual results

It crashes

Regression

Only affects 10.7.2

Notes

None needed reproducible on all systems.

Attachments (3)

crash.log (47.0 KB) - added by larry 8 years ago.
crash log
Adium_2011-10-29-165531_Markov.crash (66.3 KB) - added by earthmkii 8 years ago.
Adium 1.5b2 crashlog
Adium Xtras Crash.txt (60.2 KB) - added by cometbus 8 years ago.
Additional saved crash log from a Lion MacBook for reference

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by sphynx

  • Status changed from new to pending

Please attach a crash log from the crash reporter.

comment:2 Changed 8 years ago by Robby

  • Description modified (diff)

comment:3 Changed 8 years ago by mathuaerknedam

larry_ in IRC reported that he was able to install xtras if he used the download and doble-click method.

tigersoul, can you install xtras using download and doble-click?

Last edited 8 years ago by mathuaerknedam (previous) (diff)

Changed 8 years ago by larry

crash log

comment:4 Changed 8 years ago by tigersoul

Correct, they can still be installed by downloading and doubleclicking manually, forgot to add this.

comment:5 Changed 8 years ago by Robby

  • Keywords Lion 10.7 added

comment:6 Changed 8 years ago by Robby

  • Status changed from pending to new

comment:7 Changed 8 years ago by earthmkii

  • Milestone set to Adium 1.5
  • Owner set to earthmkii
  • Status changed from new to assigned

Changed 8 years ago by earthmkii

Adium 1.5b2 crashlog

comment:8 Changed 8 years ago by sphynx

I must have broken something in XtrasInstaller.m when implementing the quarantining. If you don't beat me to it sholt, I'll look into this.

comment:9 Changed 8 years ago by Robby

  • Severity changed from normal to regression

comment:10 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

(In 035bd5aaed27) XtrasInstaller seems to have some memory management failures. Fix these by using properties.

Fixes #15581

comment:11 Changed 8 years ago by Robby

  • Milestone changed from Adium 1.5 to Adium 1.4.4
  • Resolution fixed deleted
  • Status changed from closed to new

We need to port the fix to 1.4.4.

Changed 8 years ago by cometbus

Additional saved crash log from a Lion MacBook for reference

comment:12 Changed 8 years ago by cometbus

I added an additional crash log in case it would be helpful. My system specs are

  • Processor 1.83 GHz Intel Core 2 Duo
  • Memory 4 GB 667 MHz DDR2 SDRAM
  • Graphics Intel GMA 950 64 MB
  • Software Mac OS X Lion 10.7.2 (11C74)

If there is any testing that I can aid in, please let me know. Mainly this addition is to be added to this ticket.

comment:13 Changed 8 years ago by mathuaerknedam

  • Resolution set to fixed
  • Status changed from new to closed

It looks like this fix should now be in 1.4.4b2 and q.5b3.

Last edited 8 years ago by mathuaerknedam (previous) (diff)
Note: See TracTickets for help on using tickets.