Adium

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#15577 closed defect (fixed)

Grey space when window width is dragged very small

Reported by: mathuaerknedam Owned by:
Milestone: Component: Adium UI
Version: 1.5b1 Severity: regression
Keywords: Cc:
Patch Status:

Description

Summary

Provide a descriptive summary of the issue.

Steps to reproduce

  1. open a MUC chat window with the user list open (it's not required that adium be connected, any open MUC window will work)
  2. drag the left or right edge of the window to resize very small. Occasionally I can see the grey appear if resizing from a corner, but the grey always disappears when I let go.

Regression

I'm using OSX 10.7.2 and Adium 1.5b1r4258.

Notes

The grey area is 1px wide at a window width of ~406px. At the minimum window width of 327px, the grey area is 41px wide. I've circled the grey area in the attached pics.

Attachments (3)

Screen Shot 2011-10-27 at 8.26.09 PM.png (57.8 KB) - added by mathuaerknedam 2 years ago.
Screen Shot 2011-10-27 at 8.26.19 PM.png (46.9 KB) - added by mathuaerknedam 2 years ago.
bigger.png (57.0 KB) - added by mathuaerknedam 2 years ago.
what happens when drag the window bigger

Download all attachments as: .zip

Change History (25)

Changed 2 years ago by mathuaerknedam

Changed 2 years ago by mathuaerknedam

comment:1 Changed 2 years ago by mathuaerknedam

  • Summary changed from Grey space when windows width is dragged very small to Grey space when window width is dragged very small

comment:2 Changed 2 years ago by mathuaerknedam

The grey are is as shown with side tabs, but narrower when top or bottom tabs are used. Also, the grey area is the sidebar drag area; any oint on the grey are can be used to drag the user list larger or smaller.

Changed 2 years ago by mathuaerknedam

what happens when drag the window bigger

comment:3 Changed 2 years ago by mathuaerknedam

I added a pic that shows what happens when I drag the windows bigger. The grey space "moves" to the tab shelf!

comment:4 Changed 2 years ago by Robby

  • Milestone set to Adium 1.5
  • Severity changed from normal to regression

comment:5 Changed 2 years ago by earthmkii

I'm unable to reproduce this, does it still exist in the latest nightly (1.5b1r4263)?

comment:6 Changed 2 years ago by mathuaerknedam

It's still in 1.5b1r4263. :(

I'll check if I see it in a completely clean account.

comment:7 Changed 2 years ago by mathuaerknedam

I reproduced it in a clean account after making these changes:

  1. added a different gtalk account
  2. joined a MUC using the default settings
  3. moved the userlist to the left-side
  4. Made the window very narrow, as described above.

So it seems the bug is related to having a left-hand userlist.

Incidentally, when the chat window was originally created, half of the height was text-input area. It was friggin huge.

comment:8 Changed 2 years ago by Stephen Holt <sholt@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In f471f0bbbc83) Increase the minimum size of the message window, which was absurdly small for our message views anyway. Works around / fixes #15577.

comment:9 Changed 2 years ago by Robby

Hm, was this a regression, Matthew?

comment:10 Changed 2 years ago by mathuaerknedam

  • Resolution fixed deleted
  • Status changed from closed to new

Unfortunately, this doesn't actually avoid the problem if the userlist is larger than the default size. If I start with a larger window, drag the userlist larger, and then horizontally drag the window smaller, the grey area returns. Sometime it will disappear, but not always. Even with 1.5b1r4265.

And Yes, this does appear to be a regression, as I can't reproduce it in 1.4.3.

comment:11 Changed 2 years ago by Stephen Holt <sholt@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In bb9f69f82a5b) Fix improper view layout when resizing with a MUC's user list on the right side. Fixes #15577.

comment:12 Changed 2 years ago by Robby

  • Milestone Adium 1.5 deleted

comment:13 Changed 2 years ago by Stephen Holt <sholt@…>

(In 342f1dec6aa6) Remove the user list from the vertical split view when we have a single user chat. Restore it if, by some magical faerie dust, the chat becomes a MUC. This removes the grey line on the side of single user chats.

Note that this line *must* remain on MUCs so the user list may be dragged open with the mouse. Refs #15577.

comment:14 Changed 2 years ago by mathuaerknedam

  • Resolution fixed deleted
  • Status changed from closed to new

The Good: Using 1.5b1r4266, I can no longer reproduce this using the instructions in comment 7!

The Bad: I can still reproduce it with a slight change in the instructions! Rather than dragging the window smaller, use the side-tab width-dragger to make the message view smaller.

  1. add a new gtalk account
  2. join (really it's create) a MUC using the default settings
  3. set the tabs to be on either side.
  4. drag the tab width toward the opposite side, reducing the amount of space for the messageview and userlist.

This always results in some weirdness, regardless of on which side one sets the tabs or the userlist. Sometimes the weirdness is only visible while the mouse is moving, sometimes only when the mouse click is down, sometimes it will go away of the wried are is moused over, and sometimes it persists until something is resized. I can try to make a movie if that would help, but I'm literally starting from scratch with a guest account, downloading Adium, etc, so I'd expect this to be pretty easily reproduced.

comment:15 Changed 2 years ago by Robby

  • Milestone set to Adium 1.5

comment:16 follow-up: Changed 2 years ago by mathuaerknedam

1.5b2r4274 seems better, but still has some weirdness.

comment:17 Changed 2 years ago by maryisdead

Is there any way to make this new 300 px minimum wide for the message view (see f471f0bbbc83, comment 8) an option or something?

I had my message view set to about 230 px as I had my Adium visible all the time like a sidebar. 300 px is too much for this.

Last edited 2 years ago by wixardy (previous) (diff)

comment:18 in reply to: ↑ 16 Changed 2 years ago by earthmkii

  • Status changed from new to pending

Replying to mathuaerknedam:

1.5b2r4274 seems better, but still has some weirdness.

details?

comment:19 Changed 2 years ago by mathuaerknedam

Here's a link to a movie that demonstrates the weirdness.

comment:20 Changed 2 years ago by mathuaerknedam

  • Status changed from pending to new

comment:21 Changed 2 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In e80fc203ad64) Correct the user list's size calculation by verifying the allowed width after the minimum is set. Fixes #15577

comment:22 Changed 2 years ago by Robby

  • Milestone Adium 1.5 deleted
Note: See TracTickets for help on using tickets.