Adium

Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#15518 closed defect (fixed)

Dragging a tab when tab is the only chat in a window causes invisible window

Reported by: Nib Owned by: wixardy
Milestone: Adium 1.5.10 Component: Adium UI
Version: 1.4.3 Severity: normal
Keywords: PSMtabbarcontrol Cc:
Patch Status:

Description

Summary

Dragging a tab from its own window and then releasing it will cause the window to cease being visible. It will still respond to mouse and keyboard events.

Steps to reproduce

Detail the exact steps taken to produce the bug. Use the following format, each line with " 1." before it:

  1. Open a new chat in a new window.
  2. Drag the chat by its tab to a new location on the screen.

Expected results

Window is now at the new position.

Actual results

Window turned invisible.

Regression

Open two chats and drag one from the other and both chats will have one window each and both windows will be visible.

Notes

See attached screen recording. Console.app does not register anything or any errors when this happens.

Attachments (2)

adium tab drag missing window.mov (1.1 MB) - added by Nib 6 years ago.
Screen recording.
Skärmavbild 2011-09-25 kl. 21.11.56.png (355.5 KB) - added by Nib 6 years ago.
Screen shot, Mission Control.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Nib

Screen recording.

Changed 6 years ago by Nib

Screen shot, Mission Control.

comment:1 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.5

Looks like updating our tab framework might fix this: https://github.com/dorianj/PSMTabBarControl/pull/31. (Thanks to Paul Wilde for the hint!)

comment:2 Changed 4 years ago by Robby

  • Keywords PSMtabbarcontrol added; tab removed
  • Milestone changed from Adium 1.5.5 to Adium 1.6

comment:3 Changed 4 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 7658a4afc14d) Updated PSMTabBarControl to github.com/wixardy/PSMTabBarControl/commit/12ee3ecf023d44c6737d52ab6502bc0e8fff0957 fixes #16305 and #15518 and #15414 and #16286.

comment:4 Changed 3 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

Reopening for attribution

comment:5 Changed 3 years ago by Robby

  • Owner set to wixardy

comment:6 Changed 3 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 3 years ago by Robby

  • Milestone changed from Adium 1.6 to Adium 1.5.10
Note: See TracTickets for help on using tickets.