Adium

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15480 closed defect (fixed)

Auto hidden contact list misplaced on Lion

Reported by: gklka Owned by:
Milestone: Adium 1.5 Component: Adium UI
Version: 1.4.3 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

If you have auto hide option enabled for the contact list, it will hide itself if you don't leave the pointer over it. Starting from Lion, quitting Adium while the contact list is hidden and relaunching it causes the contact list remains at the hidden position, but it does not come forward if you move the pointer to the screen edge. You can only see one pixel from it's window. You can resize it's window dragging the 1 pixel bar of it's title bar, then move it, then resize it again to restore the normal behaviour.

Steps to reproduce

  1. Enable Advanced > Contact List > Automatically hide the contact list > On screen edges
  2. Move the pointer away to let the window hide
  3. Quit Adium
  4. Relaunch Adium

Expected results

The user list should reappear hidden, but you should be able to reveal it by using your pointer to the screen edge.

Actual results

The window is shown, but only a 1-pixel wide bar can be seen from it. It does not comes forward if you move the pointer to the screen edge.

Regression

OS X Lion 10.7.1, I think all Adium versions

Change History (7)

comment:1 Changed 8 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 39c300ae1d0c) Disable the contact list windows' restorable property which fixes #15341 and #15480.

comment:2 Changed 8 years ago by wixardy

  • Milestone set to Adium 1.5

comment:3 Changed 8 years ago by gklka

It is not fixed, please reopen this ticket!

See my video of Adium 1.5b9:
http://gk.lka.hu/x/adium_contact_list_bug.mov

comment:4 Changed 8 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

comment:5 Changed 8 years ago by Olli91

Much worse: Hidden contact list leads to Adium being shown in Mission Control! If you hover over the empty space over the Adium icon you can see a blue shape in form of the contact list. Of course you can only see that effect with no chat window open.
It only occurs on having normal window behaviour set for contact list.

Second bug: When searching for a name in a contact list with hidden names (hidden in a group) the group of course opens and changes the position of the window. When closing the search field, the contact list stays in the new, wrong position and doesn't flip back (of course it still hides).

Tested on 10.7.2, 1.5rc1r4530

Last edited 8 years ago by Olli91 (previous) (diff)

comment:6 Changed 8 years ago by Adrian Godoroja <robotive@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In ea26f9795cb9) Fixed contact list wrong position at start-up under Mac OS X Lion. Fix suggested by wixardy. Fixes #15341. Fixes #15480.

comment:27 Changed 8 years ago by wixardy

Ticket #15842 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.