Adium

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15419 closed defect (fixed)

Adium can't handle XML prefixes

Reported by: natevw Owned by: sphynx
Milestone: Adium 1.4.3 Component: Service/XMPP (Jabber)
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

Adium does not understand XML namespace prefixes, which makes it unable to handle completely valid XHTML-IM.

Steps to reproduce

Use iChat in Lion to send a Jabber message. It will often (although only intermittently with GTalk) display in Adium like:

<im:html xmlns:im='http://jabber.org/protocol/xhtml-im'><xht:body xmlns:xht='http://www.w3.org/1999/xhtml' style='background-color:#7bb5ee;color:#000000;'><xht:span style='font-family: 'Helvetica';font-size: 12px;'>hello are you there?</xht:span></xht:body></im:html>

Expected results

This is valid XMPP/XML, Adium should handle it.

Actual results

Adium can't XML.

Attachments (3)

XMLGMailAlternating.txt (2.4 KB) - added by pks 8 years ago.
adium-xml-fix.zip (2.1 MB) - added by joey.parrish 8 years ago.
Binary patch for current version of Adium
Picture 77.png (178.0 KB) - added by coolbeansdeb 8 years ago.
ticket says closed, Am I missing the fix on this one, mine is still doing it

Change History (58)

comment:1 Changed 8 years ago by Robby

Ticket #15420 has been marked as a duplicate of this ticket.

comment:2 Changed 8 years ago by Robby

Ticket #15423 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by schwifty

I've seen this repeatedly between multiple different users, all running 10.6, Adium 1.4.2, GTalk.

comment:4 Changed 8 years ago by SireTRM

I can confirm this with Adium 1.4.3b2 and 10.6.8 over GTalk. Currently, I have only seen this in group chats, but I have not extensively tested individual chats.

comment:5 Changed 8 years ago by schwifty

I can't get it to repeat, but all of the examples I've seen thus far are individual chats.

comment:6 Changed 8 years ago by dominikschwind

I can confirm this, started to appear yesterday, always with GTalk conversations.

comment:7 Changed 8 years ago by gonzaloserrano

Yep, same here. Today i reinstalled Adium in my Mac and i'm getting this (and happens to some workmates too).

comment:8 Changed 8 years ago by Bianca

Also receiving the XML code when talking to Adium users on gchat, Adium version 1.4.2.

Last edited 8 years ago by Bianca (previous) (diff)

comment:9 Changed 8 years ago by gonzaloserrano

When both users use last adium version (1.4.2) then the text is clean (no XHTML codes).

comment:10 Changed 8 years ago by schwifty

Every user I've seen with this has been using 1.4.2.

comment:11 Changed 8 years ago by Robby

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

A debug log would help us here.

comment:12 Changed 8 years ago by Robby

Ticket #15426 has been marked as a duplicate of this ticket.

comment:13 Changed 8 years ago by joey.parrish

Formatting used to work fine. Why did this problem only manifest so recently? Why does OTR work around it? (See #15426)

comment:14 Changed 8 years ago by Robby

Apparently, Google must have changed something. The issue is being investigated. Again, a debug log would help.

comment:15 Changed 8 years ago by mkasu

Here a debug log on this case. I am using Adium 1.4.3b3 with my GTalk Account. The guy I am chatting with uses Pidgin 2.7.11 for Windows.

http://pastebin.com/vGfAmxjn

Edit: Ah yeah, forgot screenshot http://cl.ly/0d0q1s0W3b2i0C450r0r

Last edited 8 years ago by mkasu (previous) (diff)

comment:16 Changed 8 years ago by bleything

Here's another, where my chat partner is using Digsby (build 30088) on Windows: https://gist.github.com/1154530

Here's how it renders: https://skitch.com/bleything/ftbqn/carmen

comment:17 Changed 8 years ago by Robby

Ticket #15429 has been marked as a duplicate of this ticket.

comment:18 Changed 8 years ago by pks

I just tried debugged this issue.
Steps to reproduce:

  1. log in to Google, write a message to someone from Google
  2. write a message to someone from Adium
  3. receive crappy XML output

This isn't deterministic, sometimes I had to send the message multiple times to get it display the message in XML.

I'll attach the debug log. It's interesting, as I first wrote a message from within Adium, then copied the outgoing stanza, wrote a message in Google, pasted the stanza and sent it again. Incoming stanzas were obviously alternated by Google as incoming stanzas weren't the same for the same input.

Changed 8 years ago by pks

comment:19 Changed 8 years ago by pks

Ticket #15430 has been marked as a duplicate of this ticket.

comment:20 Changed 8 years ago by josephfreynolds

Note that I am logged into gmail at the same time. There does seem to be some relationship but I am unable to reliably determine what it is.

I have modified the log so that I appear as myself@…, and the person sending me the message appears as sender@…. When he sends me plain text I have a normally formatted message, however when he sends me a url, the XML formatting comes through in the text.

Attachment not working, here is pastie link.

http://pastie.org/2393000

Last edited 8 years ago by josephfreynolds (previous) (diff)

comment:21 Changed 8 years ago by ivymyt

Using Adium 1.4.3b3, logged in to Google but not into Gmail/web GChat. Both me and the person sending me messages are using Adium with GChat.

Log: https://gist.github.com/1155694

Screenshot: http://i.imgur.com/4WmWt.png

comment:22 Changed 8 years ago by Robby

Ticket #15432 has been marked as a duplicate of this ticket.

comment:23 Changed 8 years ago by Robby

Ticket #15433 has been marked as a duplicate of this ticket.

comment:24 Changed 8 years ago by robotive

Ticket #15434 has been marked as a duplicate of this ticket.

comment:25 Changed 8 years ago by tmartin

I can confirm this happens for me using OSX 10.6.8 with Adium 1.4.3b3 and 1.4.3b2 (don't know about prior versions). Has only happened when talking to gChat buddies. This particular buddy is using Digsby. Happens with all messages from this buddy.

comment:26 follow-up: Changed 8 years ago by bananastalktome

Confirmed with Adium 1.4.2, same odd XML in chat window as noted by others here. Just noticed this starting on August 18th (had a normal non-xml conversation with someone on the 17th, and the oddly XML formatted conversation with the same person on the 18th). I am using Adium 1.4.2 on OSX 10.6.8 and the other person is using iChat in Lion (newest versions of both iChat and Lion). Not exactly sure if this is the cause, but the other person said they applied an OS update around the time that their IM's started coming across strangely for me. As far as I can tell, this is the only thing that changed between the normal conversation we had the 17th and the XML formatted one on the 18th.

I logged out of adium and into iChat, and messages from this person were fine. I logged back into Adium, and I had them send messages from within gMail, and messages were fine. Seems to only impact messages from iChat to Adium.

Last edited 8 years ago by bananastalktome (previous) (diff)

comment:27 Changed 8 years ago by sphynx

Ticket #15435 has been marked as a duplicate of this ticket.

comment:28 in reply to: ↑ 26 Changed 8 years ago by venutip

Replying to bananastalktome:

Seems to only impact messages from iChat to Adium.

I can't comment on iChat, but I've encountered this problem on Adium-to-Adium chats.

comment:29 Changed 8 years ago by Jeroen

Not sure if you've found a reproducible yet, but it's really easy... just type this:

cmd+b bold <return>

to type bold in bold and receive it in Adium via gtalk. Any formatting of text other than standard text triggers the xml output.

comment:30 Changed 8 years ago by sphynx

We have confirmed this problem, and it is currently under investigation. We have found the cause, and don't need more confirmations right now. Thanks for your info.

comment:31 Changed 8 years ago by egoldin

Sounds like this has been flagged as an issue. Just wanted to share I'm seeing this too, when sending messages from Adium to friends using Gtalk. I'm not seeing any HTML, but they see my IMs like this:

<im:html xmlns:im='http://jabber.org/protocol/xhtml-im'><xht:body xmlns:xht='http://www.w3.org/1999/xhtml'><xht:p><xht:span style='font-family: Lucida Grande; font-size: medium;'>hey</xht:span></xht:p></xht:body></im:html>

comment:32 Changed 8 years ago by jbold

experiencing the same issue - my set up Mac OSX 10.6.8, Adium 1.4.2, Gtalk

My friend is on windows, using digsby, and Gtalk

I can send a message fine - but when she sends a message it is received as the xml:

<im:html xmlns:im='http://jabber.org/protocol/xhtml-im'><xht:body xmlns:xht='http://www.w3.org/1999/xhtml'><xht:span style='font-family: arial; font-size: 10pt; color: #000000;'>testing</xht:span></xht:body></im:html>

comment:33 Changed 8 years ago by sphynx

  • Component changed from Adium Core to Service/Jabber (XMPP)
  • Milestone set to Adium 1.4.3
  • Owner set to sphynx
  • Status changed from pending to assigned

Filed #p14529 with a patch to fix this, which will probably be backported for Adium.

comment:34 Changed 8 years ago by sphynx

Ticket #15438 has been marked as a duplicate of this ticket.

comment:35 Changed 8 years ago by sphynx

Ticket #15440 has been marked as a duplicate of this ticket.

comment:36 Changed 8 years ago by docawkward

I'm also having this problem, both users are on Adium 1.4.2, and both running OSX 1.6.8.

comment:37 Changed 8 years ago by tronewy

I am experiecing this no OSX 10.6.6 and Adium 1.4.2, it started with just links being sent last night and progressed to all messages a few minutes ago, all messages over Gtalk.

comment:38 Changed 8 years ago by David Munch

Ticket #15441 has been marked as a duplicate of this ticket.

comment:39 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

(In 004d5ce5ac04) im.pidgin.adium.1-4 @ 41ecbfc19cc8b1a53505ed08eca6ed9944d699de which fixes a remote crash on IRC with certain names and fixes xhtml tags showing up on GTalk.

Fixes #15419

comment:40 Changed 8 years ago by proton

Ticket #15445 has been marked as a duplicate of this ticket.

comment:41 follow-up: Changed 8 years ago by n0nick

I can still reproduce this on Adium 1.4.3b3, OS X 10.6.8.

comment:42 in reply to: ↑ 41 Changed 8 years ago by paradoxmo

Replying to n0nick:

I can still reproduce this on Adium 1.4.3b3, OS X 10.6.8.

The fix is only in nightlies right now. Try a nightly: http://nightly.adium.im

comment:43 Changed 8 years ago by Skade

I can still reproduce this problem, even when both sides use Adium_1.5hgr4170.

Log: https://gist.github.com/1162051

Last edited 8 years ago by Skade (previous) (diff)

comment:44 Changed 8 years ago by sphynx

Yes, it's currently only in the adium-1.4 nightlies.

comment:45 Changed 8 years ago by Skade

Ah, I see. In that case, I can confirm that the problem is fixed.

comment:46 Changed 8 years ago by n0nick

Confirming too. Thanks.

comment:47 Changed 8 years ago by iampivot

Is version 1.5hgr4170 not the latest nightly? If so where can one get the absolute latest nightly? I'm still seeing this issue with 1.5hgr4170.

comment:48 Changed 8 years ago by Skade

As sphynx wrote above: 1.5 is the absolutely latest 1.5 nightly, but the fix is not in 1.5 yet.

The current 1.4 nightly can be found here:

http://nightly.adium.im/?repo_branch=adium-1.4-default

Changed 8 years ago by joey.parrish

Binary patch for current version of Adium

comment:49 follow-up: Changed 8 years ago by Robby

Hey joey-parrish, we're about to release 1.4.3rc1 which contains the fix.

comment:50 Changed 8 years ago by joey.parrish

Okay, fair enough. Just trying to help others avoid the nightlies. :)

comment:51 Changed 8 years ago by coolbeansdeb

Just tried to download the adium-xml-fix.zip, not sure what to do with it. I'm having the xml problem on a mac. Everything I sent from gtalk has the code in it. Is there a patch I can download for mac adium?

comment:52 in reply to: ↑ 49 Changed 8 years ago by Robby

From 80 minutes ago:

Hey joey-parrish, we're about to release 1.4.3rc1 which contains the fix.

Changed 8 years ago by coolbeansdeb

ticket says closed, Am I missing the fix on this one, mine is still doing it

comment:53 Changed 8 years ago by coolbeansdeb

got it, i'll wait.

comment:54 Changed 8 years ago by Robby

Okay, 1.4.3rc1 is out.

comment:55 Changed 8 years ago by sphynx

Ticket #15546 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.