Adium

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#15405 closed defect (fixed)

Cannot log into Adium

Reported by: marebear74112@hotmail.com Owned by:
Milestone: Adium 1.5.7 Component: Adium Core
Version: 1.4.2 Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by Robby)

Summary

I recently downloaded the new Lion OS for my iMac. Since then I have not been able to open MSN. I have not experienced this problem with Yahoo or AIM

Steps to reproduce

Detail the exact steps taken to produce the bug. Use the following format, each line with " 1." before it:

  1. I opened Adium. Yahoo and AIM opened immediately.
  2. I attempted to go online with MSN
  3. I was asked for my password and typed it in

Expected results

I expected to be connected to MSN

Actual results

I received a message saying that my password was not accepted

Regression

This problem has only occurred since I downloaded the Lion operating system

Notes

12:10:57: -[AIAccount(Abstract) retrievePasswordThenConnect]: Retrieving <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com's password (promptOption 0)
12:10:57: adiumPurpleCoreDebugInit: 
12:10:57: (Libpurple: util) Reading file xmpp-caps.xml from directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:10:57: (Libpurple: util) File /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple/xmpp-caps.xml does not exist (this is not necessarily an error)
12:10:57: (Libpurple: jabber) creating hash tables for data objects
12:10:57: (Libpurple: prefs) /purple/status/scores/offline changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/status/scores/available changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/status/scores/invisible changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/status/scores/away changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/status/scores/extended_away changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/status/scores/idle changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/status/scores/offline_msg changed, scheduling save.
12:10:57: (Libpurple: util) Reading file accounts.xml from directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:10:57: (Libpurple: util) Reading file status.xml from directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:10:57: (Libpurple: util) File /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple/status.xml does not exist (this is not necessarily an error)
12:10:57: (Libpurple: certificate) CertificateVerifier x509, singleuse requested but not found.
12:10:57: (Libpurple: certificate) CertificateVerifier singleuse registered
12:10:57: (Libpurple: certificate) CertificatePool x509, ca requested but not found.
12:10:57: (Libpurple: certificate) CertificateScheme x509 requested but not found.
12:10:57: (Libpurple: certificate/x509/ca) Lazy init failed because an X.509 Scheme is not yet registered. Maybe it will be better later.
12:10:57: (Libpurple: certificate/x509/ca) Init failed, probably because a dependency is not yet registered. It has been deferred to later.
12:10:57: (Libpurple: certificate) CertificatePool ca registered
12:10:57: (Libpurple: certificate) CertificatePool x509, tls_peers requested but not found.
12:10:57: (Libpurple: certificate) CertificatePool tls_peers registered
12:10:57: (Libpurple: certificate) CertificateVerifier x509, tls_cached requested but not found.
12:10:57: (Libpurple: certificate) CertificateVerifier tls_cached registered
12:10:57: (Libpurple: prefs) /purple/logging/format changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/logging/format changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/proxy/type changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/proxy/host changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/proxy/port changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/proxy/username changed, scheduling save.
12:10:57: (Libpurple: prefs) /purple/proxy/password changed, scheduling save.
12:10:57: (Libpurple: sslconn) Unable to initialize SSL.
12:10:57: (Libpurple: util) Reading file smileys.xml from directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:10:57: (Libpurple: util) File /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple/smileys.xml does not exist (this is not necessarily an error)
12:10:57: (Libpurple: stun) using server 
12:10:57: (Libpurple: nat-pmp) Found a default gateway
12:10:57: (Libpurple: nat-pmp) Attempting to retrieve the public ip address for the NAT device at: 192.168.1.1
12:10:57: (Libpurple: nat-pmp) 	Timeout: 0s 250000us
12:10:57: (Libpurple: nat-pmp) Response was not received from our gateway! Instead from: 167.1.125.0
12:10:57: Setting en as LC_ALL
12:10:57: adiumPurpleCore: load_all_plugins()
12:10:57: adiumPurpleCoreUiInit
12:10:57: adiumPurpleCore: purple_blist_load()...
12:10:57: (Libpurple: util) Reading file blist.xml from directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:10:57: Created PurpleAccount 0x857f2c0 with UID marebear74112@hotmail.com and protocolPlugin prpl-msn
12:10:57: Created PurpleAccount 0x857f2c0 with UID marebear74112@hotmail.com, protocolPlugin prpl-msn
12:10:57: Original image of size 218.000000 218.000000
12:10:57: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com: Scaled image to size {96, 96}
12:10:57: -[CBPurpleAccount setAccountUserImage:withData:]: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com setting icon data of length 26497
12:10:58: (Libpurple: util) Writing file /Users/marilyn/Library/Caches/Adium/Default/252fa61d509e1eb9320228c558760f9247ff151b.png
12:10:58: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com: Updating status for key: User Icon
12:10:58: Adium: Connect: marebear74112@hotmail.com initiating connection using status state <AIStatus: 23a2c10 [Invisible]> ((null)).
12:10:58: Setting status on 857f2c0 (marebear74112@hotmail.com): ID invisible, isActive 1, attributes {
}
12:10:58: (Libpurple: account) Connecting to account marebear74112@hotmail.com.
12:10:58: (Libpurple: connection) Connecting. gc = 0x8576610
12:10:58: (Libpurple: msn) new httpconn (0x8576f40)
12:10:58: (Libpurple: dns) DNS query for 'messenger.hotmail.com' queued
12:10:58: Called write with no write_tag <SourceInfo 0x857c710: Socket 0x857c820: fd 13; timer_tag 0; read_tag 4; write_tag 0>
12:10:58: -[AdiumPurpleDnsRequest startLookup]: Performing DNS resolve: messenger.hotmail.com:1863
12:10:58: DNS resolve complete for messenger.hotmail.com:1863; 1 addresses returned
12:10:58: (Libpurple: dnsquery) IP resolved for messenger.hotmail.com
12:10:58: (Libpurple: proxy) Attempting connection to 64.4.9.190
12:10:58: (Libpurple: proxy) Connecting to messenger.hotmail.com:1863 with no proxy
12:10:58: (Libpurple: proxy) Connection in progress
12:10:58: (Libpurple: proxy) Connecting to messenger.hotmail.com:1863.
12:10:58: (Libpurple: proxy) Connected to messenger.hotmail.com:1863.
12:10:58: Connecting: gc=0x8576610 (Handshaking) 1 / 8
12:10:58: (Libpurple: msn) C: NS 000: VER 1 MSNP16 MSNP15 CVR0
12:10:58: ************ marebear74112@hotmail.com --step-- 1
12:10:58: (Libpurple: msn) S: NS 000: VER 1 MSNP16
12:10:58: (Libpurple: msn) Negotiated protocol version 16 with the server.
12:10:58: (Libpurple: msn) C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 8.5.1302 BC01 marebear74112@hotmail.com
12:10:58: (Libpurple: msn) S: NS 000: CVR 2 14.0.8117 14.0.8117 14.0.8117 http://msgruser.dlservice.microsoft.com/download/A/6/1/A616CCD4-B0CA-4A3D-B975-3EDB38081B38/en/wlsetup-cvr.exe http://download.live.com/?sku=messenger
12:10:58: (Libpurple: msn) C: NS 000: USR 3 SSO I marebear74112@hotmail.com
12:10:58: (Libpurple: msn) S: NS 000: XFR 3 NS 207.46.124.241:1863 U D
12:10:58: Connecting: gc=0x8576610 (Transferring) 2 / 8
12:10:58: (Libpurple: dns) DNS query for '207.46.124.241' queued
12:10:58: ************ marebear74112@hotmail.com --step-- 2
12:10:58: (Libpurple: dnsquery) IP resolved for 207.46.124.241
12:10:58: (Libpurple: proxy) Attempting connection to 207.46.124.241
12:10:58: (Libpurple: proxy) Connecting to 207.46.124.241:1863 with no proxy
12:10:58: (Libpurple: proxy) Connection in progress
12:10:58: (Libpurple: proxy) Connecting to 207.46.124.241:1863.
12:10:58: (Libpurple: proxy) Connected to 207.46.124.241:1863.
12:10:58: Connecting: gc=0x8576610 (Handshaking) 3 / 8
12:10:58: (Libpurple: msn) C: NS 000: VER 4 MSNP16 MSNP15 CVR0
12:10:58: ************ marebear74112@hotmail.com --step-- 3
12:10:58: (Libpurple: msn) S: NS 000: VER 4 MSNP16
12:10:58: (Libpurple: msn) Negotiated protocol version 16 with the server.
12:10:58: (Libpurple: msn) C: NS 000: CVR 5 0x0409 winnt 5.1 i386 MSNMSGR 8.5.1302 BC01 marebear74112@hotmail.com
12:10:58: (Libpurple: msn) S: NS 000: CVR 5 14.0.8117 14.0.8117 14.0.8117 http://msgruser.dlservice.microsoft.com/download/A/6/1/A616CCD4-B0CA-4A3D-B975-3EDB38081B38/en/wlsetup-cvr.exe http://download.live.com/?sku=messenger
12:10:58: (Libpurple: msn) C: NS 000: USR 6 SSO I marebear74112@hotmail.com
12:10:58: (Libpurple: msn) S: NS 000: GCF 0 5700
12:10:58: (Libpurple: msn) Processing GCF command
12:10:58: (Libpurple: msn) S: NS 000: USR 6 SSO S MBI_KEY WynqlxiYdAc2qtrbqZyruprtAMYYss53SE4Zvc0YrpuDyaRnHmwyYEA9yH5AztEg
12:10:58: Connecting: gc=0x8576610 (Starting authentication) 4 / 8
12:10:58: (Libpurple: msn) Starting Windows Live ID authentication
12:10:58: Connecting: gc=0x8576610 (Getting cookie) 5 / 8
12:10:58: (Libpurple: msn) Logging on marebear74112@hotmail.com, with policy 'MBI_KEY', nonce 'WynqlxiYdAc2qtrbqZyruprtAMYYss53SE4Zvc0YrpuDyaRnHmwyYEA9yH5AztEg'
12:10:58: ************ marebear74112@hotmail.com --step-- 4
12:10:58: ************ marebear74112@hotmail.com --step-- 5
12:10:58: (Libpurple: dns) DNS query for 'login.live.com' queued
12:10:58: -[AdiumPurpleDnsRequest startLookup]: Performing DNS resolve: login.live.com:443
12:10:58: DNS resolve complete for login.live.com:443; 8 addresses returned
12:10:58: (Libpurple: dnsquery) IP resolved for login.live.com
12:10:58: (Libpurple: proxy) Attempting connection to 65.54.165.141
12:10:58: (Libpurple: proxy) Connecting to login.live.com:443 with no proxy
12:10:58: (Libpurple: proxy) Connection in progress
12:10:58: (Libpurple: proxy) Connecting to login.live.com:443.
12:10:58: (Libpurple: proxy) Connected to login.live.com:443.
12:10:58: (Libpurple: cdsa) Connecting
12:10:58: (Libpurple: cdsa) Connecting
12:10:58: Called write with no write_tag <SourceInfo 0xc23cea0: Socket 0xc2a1380: fd 18; timer_tag 0; read_tag 18; write_tag 0>
12:10:58: (Libpurple: cdsa) Connecting
12:10:58: Called write with no write_tag <SourceInfo 0x8592a10: Socket 0x85933d0: fd 13; timer_tag 0; read_tag 20; write_tag 0>
12:10:58: (Libpurple: cdsa) Connecting
12:10:58: (Libpurple: cdsa) SSL_connect: verifying certificate
12:10:58: (Libpurple: cdsa) SSL_connect complete
12:10:58: (Libpurple: soap) Sending secure request.
12:10:58: Called write with no write_tag <SourceInfo 0x8577110: Socket 0x8590a70: fd 18; timer_tag 0; read_tag 23; write_tag 0>
12:10:58: (Libpurple: soap) read 350 bytes
12:10:58: (Libpurple: soap) read 1133 bytes
12:10:58: (Libpurple: cdsa) receive failed (-9802): Undefined error: 0
12:10:58: (Libpurple: soap) read: Undefined error: 0
12:10:58: (Libpurple: soap) Received secure request.
12:10:58: (Libpurple: msn) C: NS 000: OUT
12:10:58: (Libpurple: connection) Connection error on 0x8576610 (reason: 2 description: Unable to authenticate: Authentication Failure)
12:10:58: Connection Disconnected: gc=8576610 (Unable to authenticate: Authentication Failure)
12:10:58: -[AIAccount(Abstract) serverReportedInvalidPassword]: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com
12:10:58: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com accountConnectionReportDisconnect: Unable to authenticate: Authentication Failure
12:10:59: (Libpurple: account) Disconnecting account marebear74112@hotmail.com (0x857f2c0)
12:10:59: (Libpurple: connection) Disconnecting connection 0x8576610
12:10:59: (Libpurple: msn) destroy the OIM 0x85771d0
12:10:59: (Libpurple: msn) destroy httpconn (0x8576f40)
12:10:59: Disconnected: gc=8576610
12:10:59: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com: Telling the core we disconnected
12:10:59: -[AIContactObserverManager endListObjectNotificationsDelaysImmediately]: 
12:10:59: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com: Disconnected ("Unable to authenticate: Authentication Failure"): Automatically reconnecting immediately
12:10:59: -[AIAccount(Abstract) retrievePasswordThenConnect]: Retrieving <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com's password (promptOption 1)
12:10:59: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com: Updating status for key: Online
12:10:59: (Libpurple: connection) Destroying connection 0x8576610
12:10:59: (Libpurple: util) requesting to fetch a URL
12:10:59: (Libpurple: dns) DNS query for '192.168.1.1' queued
12:10:59: (Libpurple: dnsquery) IP resolved for 192.168.1.1
12:10:59: (Libpurple: proxy) Attempting connection to 192.168.1.1
12:10:59: (Libpurple: proxy) Connecting to 192.168.1.1:2555 with no proxy
12:10:59: (Libpurple: proxy) Connection in progress
12:10:59: (Libpurple: proxy) Connecting to 192.168.1.1:2555.
12:10:59: (Libpurple: proxy) Connected to 192.168.1.1:2555.
12:10:59: (Libpurple: util) request constructed
12:10:59: (Libpurple: util) Response headers: 'HTTP/1.1 200 OK
CONTENT-LENGTH: 3326
CONTENT-TYPE: text/xml; charset="utf-8"
LAST-MODIFIED: Sat, 13 Aug 2011 19:10:57 GMT
DATE: Sat, 13 Aug 2011 19:10:57 GMT
SERVER: OpenRG/4.0.16.1.56.0.10.14.4 UPnP/1.0 Actiontec/RG_VERSION
CONNECTION: close

'
12:10:59: (Libpurple: util) parsed 3326
12:10:59: (Libpurple: upnp) parse_description_response(): could not get serviceTypeNode 7
12:10:59: (Libpurple: upnp) purple_upnp_parse_description(): control URL is NULL
12:11:02: (Libpurple: util) Writing file prefs.xml to directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:11:02: (Libpurple: util) Writing file /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple/prefs.xml
12:11:02: (Libpurple: util) Writing file accounts.xml to directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:11:02: (Libpurple: util) Writing file /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple/accounts.xml
12:11:02: (Libpurple: util) Writing file blist.xml to directory /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple
12:11:02: (Libpurple: util) Writing file /Users/marilyn/Library/Application Support/Adium 2.0/Users/Default/libpurple/blist.xml
12:17:45: <ESPurpleYahooAccount:23bf240 1>:marebear439: Updating status for key: IdleSince
12:17:45: <ESPurpleMSNAccount:23c00d0 2>:marebear74112@hotmail.com: Updating status for key: IdleSince
12:17:45: <ESPurpleAIMAccount:23c1ae0 3>:marebear657: Updating status for key: IdleSince
12:17:45: <ESPurpleYahooAccount:23c1620 4>:mlg439: Updating status for key: IdleSince

Change History (4)

comment:1 Changed 6 years ago by Robby

  • Description modified (diff)

comment:2 Changed 6 years ago by Robby

Ticket #15406 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by Thijs Alkemade <me@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In ef796c40efb0) Fix a read returning 0 in the SocketRead callback for SSL being handled as an error, while it's meant to indicate "no data available".

This would cause disconnections with the error "(Libpurple: cdsa) receive failed (-9802): Undefined error: 0".

Fixes #16356, fixes #15405, fixes #15411, fixes #15741

comment:4 Changed 4 years ago by Robby

  • Milestone set to Adium 1.5.7
Note: See TracTickets for help on using tickets.