Adium

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#15377 closed defect (fixed)

Message History Only Shows on 1st Tab on Startup

Reported by: animally Owned by:
Milestone: Adium 1.5 Component: Adium Core
Version: Severity: major
Keywords: Lion 10.7 Cc:
Patch Status:

Description (last modified by Robby)

Summary

When multiple tabs are open and Adium is restarted, only the 1st tab contains the message history. In previous versions all tabs contained the message history upon restart. Once Adium is started, I can close a tab and reopen it and the history is there.

Steps to reproduce

  1. Make sure the "Reopen chats from last time on startup" is checked under General preferences.
  2. Make sure "Show 'n' recent messages in new chats" is checked under General preferences.
  3. Open several chats (i.e., tabs) making sure there is some message exchanges.
  4. Close Adium
  5. Open Adium
  6. Review the contents of all tabs/chats.

Expected results

I would expect to see 'n' number of messages associated with the chat in each tab.

Actual results

Only the 1st chat tab contains the message history.

Regression

Since upgrading to 1.4.3b2 this behavior surfaced. Prior to this version it behaved as expected.

Notes

N/A

Attachments (1)

Screen Shot 2011-08-15 at 9.18.23 PM.png (272.4 KB) - added by mathuaerknedam 8 years ago.
javascript errors

Download all attachments as: .zip

Change History (43)

comment:1 in reply to: ↑ description Changed 8 years ago by Robby

  • Description modified (diff)

Replying to animally:

Since upgrading to 1.4.3b2 this behavior surfaced. Prior to this version it behaved as expected.

Any chance it in fact correlates with updating to Lion?

Last edited 8 years ago by Robby (previous) (diff)

comment:2 Changed 8 years ago by animally

It could very well be related to updating to Lion. Any recommendations on how to verify this? I don't have any machines that don't have Lion on them :(

comment:3 Changed 8 years ago by Robby

I don't know, sorry.

This being related to Lion just seemed more probable, especially with #15346.

Last edited 8 years ago by Robby (previous) (diff)

comment:4 Changed 8 years ago by mathuaerknedam

Last night this started happening to me, and I was on Lion. I don't *think* it happened last time I used Adium on this Lion machine, but I'm not certain. There's nothing in the console, and I can reorder the tabs to get a different chat's content to be displayed on next launch.

comment:5 Changed 8 years ago by mathuaerknedam

I saved a debug log from when this happened, but I'm hesitant to post it here. I don't see anything useful in it, but let me know if you'd like a copy.

comment:6 Changed 8 years ago by mathuaerknedam

A few more things I've noticed:

  1. This happens with 1.4.3b2 or 1.5hgr4141.
  2. #Chat is empty (It's not just hidden, not-displayed, etc).
  3. This problem only occurs for message styles that have custom javascript. The bundled minimal_mod is fine, but the version in the xtras repo (which has javascript only to hide the header on scroll) has problems.
  4. This doesn't appear to happen with *every* message style containing javascript. Styles that include a custom Template.html are unaffected.

comment:7 Changed 8 years ago by mathuaerknedam

@animally, what message style are you using?

comment:8 Changed 8 years ago by mathuaerknedam

I experimented with taking the latest minimal_mod and embedding the Template.html from various commits. Here are the abridged results:

  1. Broken: rev 4120 (The latest) - http://hg.adium.im/adium/rev/34999f4a034b
  2. Working: rev 523 - http://hg.adium.im/adium/rev/be67d382603f
  3. Working: rev 2531 - http://hg.adium.im/adium/rev/1b797e2e9b8e
  4. Broken: rev 2738 - http://hg.adium.im/adium/rev/58dcead8d4c0

2738 is the first revision to Template.html after 2531, and is where sholt started adding the batch appending of new messages. It seems likely that something introduced in 2738 creates an incompatibility with javascript inserted in footer.html when used under Lion.

Last edited 8 years ago by mathuaerknedam (previous) (diff)

Changed 8 years ago by mathuaerknedam

javascript errors

comment:9 Changed 8 years ago by mathuaerknedam

Incidentally, I'm now seeing this in every chat on the machine originally used for testing; the first tab has no content either.

I've started testing on a different Lion machine, and there only get content in the first window.

Last edited 8 years ago by mathuaerknedam (previous) (diff)

comment:10 Changed 8 years ago by mathuaerknedam

I suspect this has the same root cause as #14346. http://colloquy.info/project/ticket/576#comment:34 (linked from #14346) seems to describe this pretty closely.

comment:11 Changed 8 years ago by mathuaerknedam

  • Keywords Lion 10.7 added

comment:12 Changed 8 years ago by mathuaerknedam

two unrelated notes:

  1. The chats will load if I move a message style's custom javascript from footer.html to header.html.
  2. The problem also occurs if there are multiple chats in separate windows. You can see that one of them gets content, and the others do not.

comment:13 Changed 8 years ago by animally

I just updated to 1.5b4 and this issue is now resolved. All tabs (not just the first one) show the history as I would expect them to.

comment:14 Changed 8 years ago by mathuaerknedam

  • Resolution set to fixed
  • Status changed from new to closed

Confirmed fixed.

comment:15 Changed 8 years ago by animally

I spoke too soon. When I opened Adium today the issue still exists. Interestingly enough, when it didn't show yesterday was when it upgraded and restarted from the upgrade.

comment:16 Changed 8 years ago by Robby

  • Milestone set to Adium 1.5
  • Resolution fixed deleted
  • Severity changed from normal to major
  • Status changed from closed to new

comment:17 Changed 8 years ago by vol

I've got exactly same problem here.

Adium 1.4.3
Lion 10.7.2

I'm lunching Adium, and when I recive my Gadu-Gadu massages that people send me when i was offline, only the massage from the first tab that was sent to me appears correctly on Adium conversation window. Every other tabs are blank.

Growl notification system is displaying them correctly, and i can see the massages in history window. If I reopen tab everything is getting back to normal.

This problem is also accuring when i put my Mac to sleep mode and than wake it after a while; Adium reconnects and problem accurs.

comment:18 Changed 8 years ago by earthmkii

  • Resolution set to fixed
  • Status changed from new to closed

People following this ticket on the 1.5 betas: please confirm that this issue is no longer present on 1.5b5.

Since 1.5 is targeting 10.6 and 10.7 users, and they're the only ones this bug affects, this fix will not be included in the 1.4 maintenance releases.

For reference, the fixes were included in revisions ef4f9d2b8336 and 6e513a922a44.

comment:19 Changed 8 years ago by animally

As I said earlier, I thought it was fixed in 1.5b5 but spoke too soon. It still exists on 1.5b5 for me running OS X 10.7.2.

comment:20 Changed 8 years ago by earthmkii

Does this problem persist across all message styles?

comment:21 Changed 8 years ago by Stephen Holt <sholt@…>

(In e25448d743b3) Some more reworking of how the WebKit Message Views are configured. Fixes #15377

comment:22 Changed 8 years ago by Stephen Holt <sholt@…>

(In 9fea67859bc8) More message view tweaks. Fix a deadlock. Refs #15377.

comment:23 Changed 8 years ago by vol

There is no change after changing from 1.4.3 to 1.5b5

Problem is still there!

comment:24 Changed 8 years ago by Robby

Please try the newest build from http://nightly.adium.im/ and let us know whether you are still seeing the problem there.

comment:25 Changed 8 years ago by vol

1.5b6

will check that out as soon as i will get multiple msgs from different ppl at startup:)

comment:26 Changed 8 years ago by fuzzy76

My initial test does not reveal any problems in the last nightly..

comment:27 Changed 8 years ago by Robby

Ticket #15346 has been marked as a duplicate of this ticket.

comment:28 follow-up: Changed 8 years ago by vol

The bug is still here I think. 2nd conversation tab was empty, when i lunched Adium today. After reopening there was content.

comment:29 in reply to: ↑ 28 ; follow-up: Changed 8 years ago by David Munch

Replying to vol:

The bug is still here I think. 2nd conversation tab was empty, when i lunched Adium today. After reopening there was content.

Don't eat the duck! -What version of Adium are you running?

Last edited 8 years ago by David Munch (previous) (diff)

comment:30 Changed 8 years ago by mathuaerknedam

Today I saw it too: 1.5b7r4354.

comment:31 in reply to: ↑ 29 Changed 8 years ago by vol

Replying to David Munch:

Replying to vol:

The bug is still here I think. 2nd conversation tab was empty, when i lunched Adium today. After reopening there was content.

Don't eat the duck! -What version of Adium are you running?

1.5b6 Is there newer version?

comment:32 Changed 8 years ago by Robby

AdiumBeta: b7

comment:33 Changed 8 years ago by fuzzy76

Not fixed. :( Just experienced this in 1.5b8 using yMous :(

comment:34 Changed 8 years ago by fuzzy76

Though I am not 100% sure this bug is the same as #15346

I am experiencing blank message views on random tabs (in this case just one in the middle). And the issue is not just missing history, but no text will show in the message view at all (including new activity).

comment:35 Changed 8 years ago by mathuaerknedam

  • Resolution fixed deleted
  • Status changed from closed to new

I see this again, using 1.5b9r4490. New content displays fine, but no message history shows except in the first tab.

Last edited 8 years ago by mathuaerknedam (previous) (diff)

comment:36 Changed 8 years ago by Adrian Godoroja <robotive@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 8fc9e07216a8) We should add content to the WKMV after DOM is ready. Fixes #15377, Message History Only Shows on 1st Tab on Startup.

comment:37 Changed 8 years ago by Adrian Godoroja <robotive@…>

(In c8f4e9819f53) Because some/lots of message styles override our Template.html, we inject the event listener, instead of having it in the default Template.html. Refs #15377.

comment:38 follow-up: Changed 7 years ago by hilyin

I am having this issue currently on OSX 10.8, adium 1.5.3.

To recreate it, I close adium while a window connected through Jabber (unsure if its limited to this) is open, and then re-open adium.

The chat window then has no history displaying and also incoming/outgoing messages do not show in the message window.

http://f.cl.ly/items/2k3y1h0k01103G0z2M04/adium-bug.png

comment:39 in reply to: ↑ 38 ; follow-up: Changed 7 years ago by mathuaerknedam

Replying to hilyin:

I am having this issue currently on OSX 10.8, adium 1.5.3.

To recreate it, I close adium while a window connected through Jabber (unsure if its limited to this) is open, and then re-open adium.

The chat window then has no history displaying and also incoming/outgoing messages do not show in the message window.

I believe this is likely to be a new issue. Could you please create a new ticket for it, and include a screenshot of your messages preference pane?

Thanks.

comment:40 in reply to: ↑ 39 Changed 7 years ago by hilyin

Replying to mathuaerknedam:

Replying to hilyin:

I am having this issue currently on OSX 10.8, adium 1.5.3.

To recreate it, I close adium while a window connected through Jabber (unsure if its limited to this) is open, and then re-open adium.

The chat window then has no history displaying and also incoming/outgoing messages do not show in the message window.

I believe this is likely to be a new issue. Could you please create a new ticket for it, and include a screenshot of your messages preference pane?

Thanks.

You know, I think I just discovered the reason. I was using a custom messages theme, and when I changed it to default message theme, it started working again.

Thanks for making me start to make a ticket, this being solved is such a weight off my back, dealing with this for months!

comment:41 follow-up: Changed 7 years ago by mathuaerknedam

You're welcome. What message style were you using?

comment:42 in reply to: ↑ 41 Changed 7 years ago by hilyin

Replying to mathuaerknedam:

You're welcome. What message style were you using?

iPhone, variant iPhone Mini

Note: See TracTickets for help on using tickets.