Adium

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15364 closed defect (fixed)

MSN Friendly name changes too often - no iTunes etc

Reported by: cscashby Owned by:
Milestone: Adium 1.4.3 Component: Service/MSN
Version: 1.5hg Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

This has been raised before, but not since 2008. In the latest nightly build (30 Jul 2011) I get 'Friendly name has changed too often' errors many many times, every 30s. I am not running iTunes, nor is the MSN account set to sync to it. As far as I know I have no Yahoo / OCS contacts in my contact list.

Steps to reproduce

Detail the exact steps taken to produce the bug. Use the following format, each line with " 1." before it:

  1. Run Adium
  2. Sign in to MSN

Actual results

Growl & popup notification of the error 'MSN Friendly name changed too often'

Regression

OSX Lion on Adium nightly (30 Jul 2011 1.5hgr4087), also tested on 1.4.2 and 1.4.3b1

Attachments (1)

debug.txt (122.2 KB) - added by rcarlsen 8 years ago.
Debug of adium

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by rcarlsen

Debug of adium

comment:1 Changed 8 years ago by rcarlsen

I am having the same problem. More info: http://forums.cocoaforge.com/viewtopic.php?p=130689#p130689

comment:2 Changed 8 years ago by sphynx

Possibly related to #15147. From the log it appears Adium is erroneously thinking every second you became idle, and telling the server that.

comment:3 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In c80f7570db0a) Separate the setting of auto-idle and auto-away, which can both be enabled or disabled by the user. Compare the new idle time with the old idle time only on seconds, the comparison seemed to fail even when using objects that should be identical, causing Adium to send and write to disk every second.

Fixes #15147, fixes #15364

comment:4 Changed 8 years ago by sphynx

  • Milestone set to Adium 1.4.3

There will hopefully be a new beta next week. Please report if this bug still occurs with that. :)

comment:5 Changed 8 years ago by rcarlsen

Update:

I solved this case!

When I looked more in detail into it, after another kind of tips from one of adiums developers, i noticed that adium was constantly in IDLE mode.

I created a new status;
https://img.skitch.com/20110810-et87325k9whujj4egn9w421h48.jpg

After selecting this status, everything is back to normal.

So, somehow, my client got stuck in idle mode. I have no clue why and how, but after creating a new status, everything is back to normal.

Note: See TracTickets for help on using tickets.