Adium

Opened 8 years ago

Closed 8 years ago

#15239 closed defect (fixed)

Adium Twitter failure: "unable to retrieve user list"

Reported by: greenmoss Owned by: evands
Milestone: Adium 1.4.3 Component: Service/Twitter
Version: 1.4.1 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

Adium fails to connect to my Twitter account.

Steps to reproduce

  1. Start Adium

Expected results

Expected Twitter to be online.

Actual results

Twitter remains offline.

Regression

This has been happening since the afternoon of June 8, 2011 (yesterday). Adium version is 1.4.1 on Mac OS 10.6.7. Quitting and restarting Adium does not fix it.

Notes

Looking in the account status/preferences, I see the message: "Error: Unable to retrieve user list [fail]", then attempted and failed reconnects. Twitter appears to be working when I log into my account via the web interface.

Attachments (1)

TwitterAccount.diff (1003 bytes) - added by ShawnRisk 8 years ago.
Changed the default Server from twitter.com to twitter.com/1/ and the twitterEngine info URL from adiumx.com to adium.im

Download all attachments as: .zip

Change History (17)

comment:1 Changed 8 years ago by leedm777

This also happens with 1.4.2b2.

comment:2 follow-up: Changed 8 years ago by leedm777

More info: disabling "Show people I follow in the contact list" allows Adium to connect.

comment:3 follow-up: Changed 8 years ago by darkid

How do you disable that feature?

comment:4 Changed 8 years ago by zacw

Looks like we need to fix the API hostname we connect to, and prepend "1/" to all method calls.

comment:5 in reply to: ↑ 3 Changed 8 years ago by leedm777

Replying to darkid:

How do you disable that feature?

Edit your Twitter accounts preferences. On the Options tab, disable the "Show people I follow in the contact list" checkbox.

comment:6 in reply to: ↑ 2 Changed 8 years ago by greenmoss

Replying to leedm777:

More info: disabling "Show people I follow in the contact list" allows Adium to connect.

This workaround worked for me as well.

Changed 8 years ago by ShawnRisk

Changed the default Server from twitter.com to twitter.com/1/ and the twitterEngine info URL from adiumx.com to adium.im

comment:7 Changed 8 years ago by Thruston

It would be better if this type of service configuration detail were externalized so that the user could change them.
They could easily be included on the options tab of the edit account preferences page.

comment:8 Changed 8 years ago by zacw

This needs to be "api.twitter.com/1", and the info URL shouldn't change since it is not really used anywhere anyway.

This detail should not be a preference because it's the official Twitter service. StatusNet has a 'server' field, since its server varies. Twitter just needs to settle on an API and stop causing breaking changes, really.

comment:9 Changed 8 years ago by wixardy

BTW it'd be this line, not the default server.

comment:10 Changed 8 years ago by zacw

Agreed, "1" should be the apiPath, and "api.twitter.com" should be the default server.

comment:11 Changed 8 years ago by zacw

Oh, blah:

[self setPreference:self.defaultServer forKey:KEY_CONNECT_HOST group:GROUP_ACCOUNT_STATUS];

Need an upgrade path. If the KEY_CONNECT_HOST is "twitter.com", migrate it to "api.twitter.com", as well.

comment:12 Changed 8 years ago by David Munch

Ticket #15263 has been marked as a duplicate of this ticket.

comment:13 Changed 8 years ago by kbroderick

I'm also seeing the behavior as described—unable to connect to Twitter since 1.4.1, disabling "Show people I follow in the contact list" allows Twitter connection to work again.

comment:14 Changed 8 years ago by evands

  • Owner changed from zacw to evands

comment:15 Changed 8 years ago by evands

  • Milestone set to Adium 1.4.3

comment:16 Changed 8 years ago by Evan Schoenberg

  • Resolution set to fixed
  • Status changed from new to closed

(In 6ca41449fc05) Properly use the defaults system for the connect host of Twitter. Clear out a previously set preference for twitter.com. Set the apiPath to /1. Fixes retrieving the Twitter user list. Fixes #15239

Note: See TracTickets for help on using tickets.