Adium

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15229 closed defect (fixed)

Linkification is broken if http:// isn't part of the pasted text (reopen #9944)

Reported by: pschastain Owned by:
Milestone: Adium 1.4.2 Component: Adium UI
Version: 1.4.1 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

No protocol type in pasted URL results in link to 'file://...'

Steps to reproduce

NOTE: Google Chrome hides the protocol, so it's easiest to use some other browser.
1.) Copy URL without protocol type to clipboard ( i.e. 'trac.adium.im/ticket/9944' )
2.) Switch to Adium
3.) Edit->Add Link... (or 'Cmd-K')
4.) Add 'Link Text:', leaving the URL that Adium has auto-copied from clipboard
5.) Send link

Expected results

I expect the recipient to be able to click on the link and have it open in his/her browser.

Actual results

Nothing, since the link now points to a local file ( i.e. 'file://Applications/Adium.app/Contents/Resources/Message%20Styles/ Stockholm.AdiumMessageStyle/Contents/Resources/trac.adium.im/ticket/9944' )

Regression

Only seems to occur when Adium auto-pastes a link without protocol from the clipboard, and only after actually sending the link. If you 'Edit Link...' before sending, it appears exactly as pasted from clipboard.

Notes

If the user types or pastes the URL manually into the 'URL:' field it works as expected, with or without the protocol declaration. It's only when Adium auto-copies from the clipboard that this seems to happen.

Change History (3)

comment:1 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

(In d9c85bd86159) Fix the automatic pasting of URLs from the pasteboard when using Edit -> Add Link...

Refs #15229

comment:2 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 20b944ef28e9) Revalidate (and thus determine if "http://" should be prepended) when calling -[SHAutoValidatingTextView setContinuousURLValidationEnabled:TRUE] so it will also revalidate when auto-pasting.

Fixes #15229

comment:3 Changed 8 years ago by sphynx

  • Component changed from Adium Core to Adium UI
  • Milestone set to Adium 1.4.2
Note: See TracTickets for help on using tickets.