Adium

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15226 closed defect (fixed)

Incoming retweets get truncated

Reported by: aristidesfl Owned by: zacw
Milestone: Adium 1.5 Component: Service/Twitter
Version: 1.4.2b2 Severity: minor
Keywords: Cc:
Patch Status:

Description

Summary

Incoming retweets get truncated with ... in the end

Steps to reproduce

Enable a twitter acount
Receive a retweet with more than 140 characters (tweet + RT tag).

Expected results

The tweet should be shown completely.

Actual results

Incoming retweets get truncated with ... in the end

Regression

Tested with v1.4.2b2

Change History (14)

comment:1 in reply to: ↑ description ; follow-up: Changed 8 years ago by Robby

  • Keywords retweet truncated ... removed
  • Milestone set to Adium bugs
  • Severity changed from normal to minor

Replying to aristidesfl:

Tested with v1.4.2b2

I think I have seen this with every version that supports Twitter.

Last edited 8 years ago by Robby (previous) (diff)

comment:2 in reply to: ↑ 1 Changed 8 years ago by Burgestrand

Replying to Robby:

Replying to aristidesfl:

Tested with v1.4.2b2

I think I have seen this with every version that supports Twitter.

Aye, same here. Really pains me when URLs get truncated, or like… the kicker in jokes, or whatever. Meep >:(

comment:3 Changed 8 years ago by andrej

I don't think this is a Adium specific problem though. RT + a tweet that is 140 characters long will be truncated due to twitter's requirements, not due to a bug in Adium.

Am I wrong?

comment:4 Changed 8 years ago by aristidesfl

Most likely, yes..

The extra RT prefix is added by adium.
The tweet comes complete from twitter.
It only makes sense to truncate on outgoing RT, not incoming.

comment:5 Changed 8 years ago by andrej

Ah, I see. So, the "RT" string is added to the 140 character limit which it shouldn't, specially for incoming incoming messages. So either the RT should explicitly not be counted or there needs to be a better way of indicating that it is a retweet.

comment:6 Changed 8 years ago by aristidesfl

Simply do not truncate incoming messages, it isn't useful.

comment:7 Changed 8 years ago by zacw

Adium does not do any truncation. It simply does not support the extended 'retweet' information, it just reads the same field for the text every time. Twitter itself truncates and prepends "RT".

comment:8 follow-up: Changed 8 years ago by andrej

If that is the case this bug should be filed with twitter and be closed here.

comment:9 in reply to: ↑ 8 Changed 8 years ago by aristidesfl

Replying to andrej:

If that is the case this bug should be filed with twitter and be closed here.

The bug should be filled with twitter?
"Hey twitter, how are you? Would you please come here and fix our application for us?"

How do every other application handle it?

It looks a matter of doing a little extra work and fetch the extended retweet information. (If it's not being fetched already)

comment:10 Changed 8 years ago by ambiguator

It's true that the twitter API returns a truncated value for the user's tweet, which may be over 140 char.
HOWEVER, the original status is still available from the API.
In the case of a retweet, the original status should be used, and adium should somehow manipulate the display or prepend "RT @username" to denote the retweet-edness.

See specifically, the example at the end of this issue report:

http://code.google.com/p/twitter-api/issues/detail?id=2261

Adium should use retweeted_status.text for retweets, instead of the text attribute used for regular tweets.

comment:11 Changed 8 years ago by sphynx

Ticket #15520 has been marked as a duplicate of this ticket.

comment:12 Changed 8 years ago by neu

Still not fixed in 1.5b3...

comment:13 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 99aaf53dc82b) When a tweet is a retweet and contains its original, use the original text instead, prepended with "RT @user: ".

Fixes #15226

comment:14 Changed 8 years ago by sphynx

  • Milestone changed from Adium bugs to Adium 1.5
Note: See TracTickets for help on using tickets.