Adium

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#15153 closed defect (fixed)

Gadu-Gadu connection problem. Connection impossible.

Reported by: pandarek Owned by: sphynx
Milestone: Adium 1.4.4 Component: Service/Gadu-Gadu
Version: 1.4.2b2 Severity: normal
Keywords: connection problem impossible Cc:
Patch Status: Accepted

Description (last modified by Robby)

Gadu-Gadu connection problem. Connection impossible.

  • System Version: Mac OS X 10.5.8 (9L30)
  • Model Name: Power Mac G5
  • Last working version 1.3.10

However, on Intel Macbook and Snow Leopard works without a problem.

Attachments (2)

adium.txt (12.1 KB) - added by pandarek 9 years ago.
Adium Debug
adium-libgadu-gg-ppc.patch (549 bytes) - added by tomkiewicz 8 years ago.
This one should help, unfortunately untested.

Download all attachments as: .zip

Change History (28)

Changed 9 years ago by pandarek

Adium Debug

comment:1 Changed 8 years ago by sphynx

  • Owner set to sphynx
  • Status changed from new to assigned

comment:2 Changed 8 years ago by sphynx

Did it work correctly in 1.4.1?

comment:3 Changed 8 years ago by sphynx

  • Resolution set to fixed
  • Status changed from assigned to closed

There was a problem connecting to a number of protocols in 1.4.2b1 on PPC. It should be fixed in 1.4.2b2, if it still persist, please let us know.

comment:4 Changed 8 years ago by sphynx

  • Milestone set to Adium 1.4.2

comment:5 Changed 8 years ago by Robby

  • Milestone Adium 1.4.2 deleted
  • Severity changed from normal to regression

comment:6 Changed 8 years ago by pandarek

O my PPC ( Mac OS X 10.5.8 (9L30) Model Name: Power Mac G5) Gadu-Gadu Service still does not work.

comment:7 Changed 8 years ago by sphynx

  • Resolution fixed deleted
  • Status changed from closed to new

comment:8 Changed 8 years ago by sphynx

Ticket #15216 has been marked as a duplicate of this ticket.

comment:9 Changed 8 years ago by David Munch

  • Version changed from 1.4.2b1 to 1.4.2b2

comment:10 in reply to: ↑ description Changed 8 years ago by Robby

  • Description modified (diff)
  • Severity changed from regression to normal

Replying to pandarek:

Last working version 1.3.10

Last edited 8 years ago by Robby (previous) (diff)

comment:11 Changed 8 years ago by pandarek

correction - Last working version 1.3.10

comment:12 Changed 8 years ago by Robby

  • Description modified (diff)

comment:13 Changed 8 years ago by pandarek

The final version (1.4.2) still does not work Service/Gadu-Gadu. Connection to gadu-gadu on PowerPC impossible.

comment:14 Changed 8 years ago by pandarek

The new beta version (1.4.3b1) still does not work Service/Gadu-Gadu. Connection to gadu-gadu on PowerPC impossible.

comment:15 Changed 8 years ago by David Munch

As you can see in the ticket, no changes has been made for Gadu gadu, and none is planned. Since none of the developers use Gadu Gadu, I wouldn't expect a fix anytime soon, although, apparently some work on Gadu Gadu has been made in LibPurple.

Last edited 8 years ago by David Munch (previous) (diff)

comment:16 follow-up: Changed 8 years ago by tomkiewicz

That seems to be a problem with Adium, not libpurple.

Look at:

adium-1.3.10/Frameworks/libpurple.framework/Versions/0.5.9/Headers/libgadu.h

There is a test, which includes proper version of libgadu.h. And there is no such thing in current Adium (with updated libpurple). Probably someone, who updated libpurple wasn't careful with that piece of code.

I have prepared a patch, that should help, but I don't have any Macs to test.

Changed 8 years ago by tomkiewicz

This one should help, unfortunately untested.

comment:17 Changed 8 years ago by tomkiewicz

There is libpurple binary in

Frameworks/libpurple.framework/Versions/Current/libpurple

So, there is possibility, that it have to be recompiled. I don't know Adium build process, so just use it as a hint, if patch won't help.

comment:18 Changed 8 years ago by David Munch

  • Milestone set to Adium 1.5
  • Patch Status set to Needs Dev Review

comment:19 Changed 8 years ago by pandarek

Milestone: Adium 1.5 ? Adium 1.5 not support PPC Architecture. Now on Intel Mac Adium and Gadu Gadu work perfect. You must repair bug on PPC Mac. I can test but i can't repair library. Add repaired files to attachment.

comment:20 Changed 8 years ago by Robby

  • Milestone changed from Adium 1.5 to Adium 1.4.4

comment:21 in reply to: ↑ 16 Changed 8 years ago by sphynx

Replying to tomkiewicz:

That seems to be a problem with Adium, not libpurple.

Look at:

adium-1.3.10/Frameworks/libpurple.framework/Versions/0.5.9/Headers/libgadu.h

There is a test, which includes proper version of libgadu.h. And there is no such thing in current Adium (with updated libpurple). Probably someone, who updated libpurple wasn't careful with that piece of code.

I have prepared a patch, that should help, but I don't have any Macs to test.

im.pidgin.adium.1-4 and im.pidgin.pidgin both have the following in libgadu.h:

/* Defined if libgadu was compiled for bigendian machine. */
#undef GG_CONFIG_BIGENDIAN

(http://developer.pidgin.im/viewmtn/revision/file/f9026fae7abc46af7f5f2ab7976b01b01e4c2bc8/libpurple/protocols/gg/lib/libgadu.h, http://developer.pidgin.im/viewmtn/revision/file/41ecbfc19cc8b1a53505ed08eca6ed9944d699de/libpurple/protocols/gg/lib/libgadu.h)

What's confusing me, is that libgadu-config.h seems to define a similar macro correctly (__GG_LIBGADU_BIGENDIAN), but that is never used. sha1.c (which is probably the file that causes the login to fail) only includes libgadu.h, and not libgadu-config.h. Are you sure this is how it should be?

Your patch does look correct, by the way; I'm just wondering why Pidgin doesn't need it too.

comment:22 Changed 8 years ago by tomkiewicz

I'm pretty sure, that sha1.c is not the file, that makes problems.

Look at debug log adium.txt, line 163: "gg_recv_packet() invalid packet length (67108864)". It's printed at libgadu.c:567 of libpurple 2.10.0. And the root cause is gg_fix32() issued few lines before. And there is used that macro (libgadu.c:211), included from libgadu-config.h at libgadu.c:48.

comment:23 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In a0a72159c4b3) im.pidgin.adium.1-4 @ e6091a5e70af187752dd370da0f20481ba18783e which fixes loading avatars on Yahoo and logging in to GG on PPC.

Fixes #15153

comment:24 Changed 8 years ago by Robby

  • Patch Status changed from Needs Dev Review to Accepted

Good work, folks!

comment:25 Changed 8 years ago by pandarek

1.4.4b1 works beautifully!

comment:26 Changed 8 years ago by Robby

Thanks for letting us know. Cool! :)

Note: See TracTickets for help on using tickets.