Adium

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#14965 closed defect (fixed)

"Unable to add the buddy abc@xyz.com because the username is invalid. Usernames must be valid email addresses." (libpurple)

Reported by: ernani Owned by:
Milestone: Adium 1.4.2 Component: Service/MSN
Version: 1.4.1 Severity: major
Keywords: Cc:
Patch Status:

Description

Summary

Can't add new msn users, maybe or not it is related to the @hotmail.com domain

Steps to reproduce

Add a new contact with @hotmail.com id

Expected results

Add the user into the contact list.

Actual results

I get the following message "Unable to add the buddy xxxx@… because the username is invalid. Usernames must be valid email addresses."

Regression

All the time

Notes

I am using the latest beta available

It is or not related to pidgin libpurple.

This happens whether or not I fill in the alias information when adding or accepting invites from new MSN buddies.

Useful url with some issues on pidgin
http://developer.pidgin.im/ticket/10126

Could not find anything on Adium bug track.

Change History (20)

comment:1 Changed 9 years ago by jweyrich

Reproducible in 1.5hgr3633, with any valid passport account.

comment:2 Changed 9 years ago by sphynx

  • Resolution set to notadiumcode
  • Status changed from new to closed

#p13298 has the same issue, and as this is not exclusive to Adium, I'm closing this one.

comment:3 Changed 9 years ago by ernani

I understand this is not related to Adium, but will we eventually have a solution for it? I am frustrated I can't add new friends, this is somewhat a big issue for Adium users, isn't it?

comment:4 Changed 9 years ago by sphynx

There will be a solution when libpurple has a solution. But in the mean time, it should work to add the person with the official client, and switch back to Adium.

comment:5 follow-up: Changed 9 years ago by ernani

Thanks, I am doing this over windows, as over mac I don't want to clutter my hard drive, specially with microsoft crap (hehe), so, will this ticket be updated once the problem is fixed? I have never ever filed a bug over trac before, so I am not familiar how to be up-to-date on this specific fix. Cheers, EJ

comment:6 Changed 9 years ago by wixardy

Ticket #14969 has been marked as a duplicate of this ticket.

comment:7 Changed 9 years ago by theginboy

Any update? This is doing my head in!

I can't use the official client as it crashes every 10 minutes to the dot, and I can't use this one because I can't add anyone! I've tried Trillian but frankly it's horrible.

comment:8 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.2
  • Severity changed from normal to major
  • Summary changed from Unable to add the buddy xxx@hotmail.com because the username is invalid. Usernames must be valid email addresses. to MSN: "Unable to add the buddy abc@xyz.com because the username is invalid. Usernames must be valid email addresses."

comment:9 Changed 9 years ago by Robby

Let's keep this open until the issue is fixed in libpurple.

comment:10 Changed 9 years ago by Robby

  • Resolution notadiumcode deleted
  • Status changed from closed to new

comment:11 Changed 9 years ago by Robby

  • Component changed from Libpurple to Service/MSN
  • Summary changed from MSN: "Unable to add the buddy abc@xyz.com because the username is invalid. Usernames must be valid email addresses." to "Unable to add the buddy abc@xyz.com because the username is invalid. Usernames must be valid email addresses." (libpurple)

comment:12 Changed 9 years ago by Robby

Ticket #15005 has been marked as a duplicate of this ticket.

comment:13 Changed 9 years ago by David Munch

Ticket #15007 has been marked as a duplicate of this ticket.

comment:14 in reply to: ↑ 5 Changed 9 years ago by David Munch

Replying to ernani:

Thanks, I am doing this over windows, as over mac I don't want to clutter my hard drive, specially with microsoft crap (hehe), so, will this ticket be updated once the problem is fixed? I have never ever filed a bug over trac before, so I am not familiar how to be up-to-date on this specific fix. Cheers, EJ

When the LibPurple ticket mentioned in comment #2 is fixed, I assume somebody (Or yourself?) will make a note in this ticket. But we just need to pull the latest LibPurple build, when it is fixed, which happens on a regular basis anyway.

comment:15 Changed 9 years ago by SimonF

Hope you can fix this problem, I'm tired of adding people with the official client.

comment:16 Changed 9 years ago by paulwilde

Ticket #15016 has been marked as a duplicate of this ticket.

comment:18 Changed 9 years ago by sphynx

Ticket #15025 has been marked as a duplicate of this ticket.

comment:19 Changed 9 years ago by Evan Schoenberg

  • Resolution set to fixed
  • Status changed from new to closed

(In c6a5d600fdba) ?libpurple 2.7.11 [im.pidgin.adium.1-4 @ 6a027e41a13240f7b76e4f040795ac3c209133b1]

Fixes #14965 (Adding MMSN buddies #p13298). Fixes #14650 (UPnP crash). Fixes #14901 (ICQ contact list loading problem). Fixes #14527 (XMPP '_ entered the room' message flood on joining conferences).

Public thanks to Robbie Vehse for compiling that list (posted to an adium-devl thread)... and of course to our friends on the libpurple team upstream.

comment:12 Changed 9 years ago by Robby

Ticket #15124 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.