Adium

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#14650 closed crash (fixed)

MSN crash related to UPNP (libpurple)

Reported by: Robby Owned by:
Milestone: Adium 1.4.2 Component: Service/MSN
Version: 1.4.1 Severity: regression
Keywords: Cc:
Patch Status:

Description (last modified by Robby)

Summary

#14584 is a mess. I'm attaching the relevant logs from that ticket to this one. Tracked in Pidgin's Trac at #p12387.

Attachments (5)

Adium_2010-11-16-104341_Kraken.crash (36.7 KB) - added by Robby 9 years ago.
Crash report
Adium_2010-11-22-184405_Kraken.log (500.4 KB) - added by Robby 9 years ago.
Debug log #3
adium_upnp.wireshark (198.2 KB) - added by mattf 9 years ago.
uPnP wireshark capture
Adium_2010-12-28-231053_Arael.crash (37.4 KB) - added by mattf 9 years ago.
Simultaneous crash dump, Adium log and wireshark capture - crash dump
Adium_2010-12-28-231053_Arael.wireshark (3.4 MB) - added by mattf 9 years ago.
Simultaneous crash dump, Adium log and wireshark capture - wireshark capture

Change History (31)

Changed 9 years ago by Robby

Crash report

Changed 9 years ago by Robby

Debug log #3

comment:1 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.2
  • Severity changed from normal to regression

comment:2 Changed 9 years ago by Robby

  • Description modified (diff)

comment:3 Changed 9 years ago by sphynx

Ticket #14845 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by Robby

Ticket #14856 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by Robby

Ticket #14865 has been marked as a duplicate of this ticket.

comment:6 follow-up: Changed 9 years ago by Robby

We could use a wireshark sample of the nat/upnp device reply. If you could obtain one, please add the output to this ticket.

Last edited 9 years ago by Robby (previous) (diff)

Changed 9 years ago by mattf

uPnP wireshark capture

comment:7 in reply to: ↑ 6 Changed 9 years ago by mattf

Attached a uPnP trace above from what appears to be the same crash. If there's something else that should be filtered in, please let me know and I'll try to oblige - although this bug doesn't much like to occur on demand.

With regard to the environment in which this was captured:

  • The uPnP device is a wireless router of random Chinese brand (TP-Link TL-WR740N). It cost pennies and has about the level of performance and features you'd expect given that.
  • The said router is furthermore actually located in China, behind a (or more than one?) network-scale NAT.
  • A port mapping doesn't actually seem to occur - the trace appears to show that uPnP is enumerated, then a NAT-PMP mapping is attempted, but the above router doesn't know anything about NAT-PMP. Its admin screen doesn't show anything mapped for Adium.

comment:8 Changed 9 years ago by Robby

Brilliant, thanks. :)

comment:9 follow-up: Changed 9 years ago by darkrain42

mattf (gah, I apologize in advance if I typo that as "MattJ"): Very much appreciate the packet capture.

I'm not trying to be nitpicky, but is there any chance you could provide a concurrent packet capture *and* debug/crash log from Adium?

comment:10 in reply to: ↑ 9 Changed 9 years ago by mattf

I'll do my best, and leave a capture going. It should crash again before too long.

Is the content of the capture sufficient? I deliberately didn't include the actual MSN exchange in the first one, as I have no idea how safe that is to publish. I can include more packets if it would be helpful, though.

comment:11 follow-up: Changed 9 years ago by darkrain42

Thanks!

I think the amount of info in the capture is probably enough (my knowledge of MSN is spotty at best, though), since what I was particularly interested in are the UPnP interactions.

Changed 9 years ago by mattf

Simultaneous crash dump, Adium log and wireshark capture - crash dump

Changed 9 years ago by mattf

Simultaneous crash dump, Adium log and wireshark capture - wireshark capture

comment:12 in reply to: ↑ 11 Changed 9 years ago by mattf

After a lot of waiting, I finally caught the bug in action again.

In line with the procedure in http://trac.adium.im/wiki/CurrentAdiumDebug for the submission of private data, I have sent the Adium log by email. The associated crash dump and wireshark capture are attached to this ticket (I have the unabridged capture if you do after all need any more packets).

I'll continue to watch this ticket if there's anything more I can do to assist.

Let me add in passing that there is a special place in my heart for tools that know what they are supposed to do, and do it simply, well, and without fuss. In short, Adium is awesome and the effort of its developers greatly appreciated!

comment:13 Changed 9 years ago by Robby

Ticket #14919 has been marked as a duplicate of this ticket.

comment:14 Changed 9 years ago by Robby

A possible fix was committed to libpurple by darkrain42: http://developer.pidgin.im/viewmtn/revision/info/8febed9408d870efdef757d67f9a3631e1d6d494. We need to update libpurple in Adium source to see if it prevents the crash.

comment:15 Changed 9 years ago by sphynx

Ticket #14941 has been marked as a duplicate of this ticket.

comment:16 Changed 9 years ago by wixardy

Ticket #14964 has been marked as a duplicate of this ticket.

comment:17 Changed 9 years ago by Ekevoo

I'm having this problem too. My router is TP-Link TL-WR340G/TL-WR340GD. I disabled uPnP and it now works.

Last edited 9 years ago by Ekevoo (previous) (diff)

comment:18 Changed 9 years ago by sphynx

Ticket #14975 has been marked as a duplicate of this ticket.

comment:19 Changed 9 years ago by Robby

  • Summary changed from MSN crash in libpurple related to UPNP to MSN crash related to UPNP (libpurple)

comment:20 Changed 9 years ago by xqzy

I have the same problem.
My router is also a TP-Link one, model TL-WR740N.

comment:21 Changed 9 years ago by Robby

Thanks for the efforts but we do not any more information on this issue. It will most likely be fixed in the next beta / final release.

Last edited 9 years ago by Robby (previous) (diff)

comment:22 Changed 9 years ago by xqzy

Glad to hear, many thanks.

comment:23 Changed 9 years ago by Evan Schoenberg

  • Resolution set to fixed
  • Status changed from new to closed

(In c6a5d600fdba) ?libpurple 2.7.11 [im.pidgin.adium.1-4 @ 6a027e41a13240f7b76e4f040795ac3c209133b1]

Fixes #14965 (Adding MMSN buddies #p13298). Fixes #14650 (UPnP crash). Fixes #14901 (ICQ contact list loading problem). Fixes #14527 (XMPP '_ entered the room' message flood on joining conferences).

Public thanks to Robbie Vehse for compiling that list (posted to an adium-devl thread)... and of course to our friends on the libpurple team upstream.

comment:12 Changed 9 years ago by Robby

Ticket #15066 has been marked as a duplicate of this ticket.

comment:13 Changed 9 years ago by wixardy

Ticket #15123 has been marked as a duplicate of this ticket.

comment:14 Changed 8 years ago by David Munch

Ticket #15228 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.