Adium

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#14629 closed defect (fixed)

Arrows missing in Events tables

Reported by: Robby Owned by:
Milestone: Adium 1.4.2 Component: Adium UI
Version: 1.4.1 Severity: regression
Keywords: Cc:
Patch Status:

Description

Summary

The arrows are missing in the Events tables, both Preferences - Events and in the Get Info pane. See attached screenshots.

Regression

This problem is new in 1.4.1, was non-existent in 1.4. I went through the changes in-between at http://hg.adium.im/adium-1.4/ but no change stood out to me as a possible culprit for this regression.

Attachments (2)

1.4.png (115.9 KB) - added by Robby 9 years ago.
1.4.1.png (115.6 KB) - added by Robby 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.2
  • Severity changed from normal to regression

Changed 9 years ago by Robby

Changed 9 years ago by Robby

comment:2 Changed 9 years ago by Evan Schoenberg

  • Resolution set to fixed
  • Status changed from new to closed

(In 22fb5f71ee72) Noted in AIVariableHeightOutlineView's header that _ai_drawRow:clipRect: is a correct drawRow:clipRect: override point, and then followed my own directions in AIVariableHeightFlexibleColumnsOutlineView. Fixes drawing in the Events tables. Fixes #14629

comment:3 Changed 9 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

I cannot confirm this is fixed in 1.4hg (r3286, 774f4e606ea0).

comment:4 Changed 9 years ago by paulwilde

Fixed in 1.5hg at least. (r3567)

comment:5 Changed 9 years ago by Robby

  • Summary changed from Arrows missing in Evens tables to Arrows missing in Events tables

comment:6 Changed 9 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed

Shame on me, I missed the latest commit.

comment:7 Changed 9 years ago by Robby

Ticket #15026 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.