Adium

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#14534 closed defect (duplicate)

Contact list 'status' background colors don't propagate to metacontacts consistently

Reported by: evands Owned by:
Milestone: Component: Adium Core
Version: 1.4 Severity: regression
Keywords: Cc:
Patch Status:

Description

As per description and photo.

Attachments (3)

CLbreakage.png (56.2 KB) - added by evands 9 years ago.
the dark blue is my unread content color
Screen shot 2010-11-16 at 8.10.18 PM.png (356.5 KB) - added by themadrussian 9 years ago.
Metacontact
Screen shot 2010-11-16 at 8.16.05 PM.png (23.1 KB) - added by themadrussian 9 years ago.
Yep - when expanded it works. I am expecting the entire contact to change the background color to blue, just like it used to.

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by evands

the dark blue is my unread content color

comment:1 Changed 9 years ago by Evan Schoenberg

  • Resolution set to fixed
  • Status changed from new to closed

(In 3429fa3628c5) Fixed contact status background colors updating in the contact list, including both static and flashing statuses. Fixes #14534. Fixes #14493.

comment:2 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.1

comment:3 Changed 9 years ago by themadrussian

This still isn't working properly, despite having updated Adium to 1.4.1.

comment:4 Changed 9 years ago by evands

  • Milestone changed from Adium 1.4.1 to Adium 1.4.x
  • Resolution fixed deleted
  • Status changed from closed to new

Please provide a screenshot demonstrating the problem.

Changed 9 years ago by themadrussian

Metacontact

comment:5 Changed 9 years ago by themadrussian

See attachment above.

"Ryan" is a metacontact, with a Yahoo and a GTalk account. We're talking on the GTalk account, and I'm running Adium 1.4.1. When he sends me a message, the contact list does not indicate that there is an unread message, despite the preference being set just as it always was, pre-Adium-1.4. As you can see, the dock and the menu bar icon are both indicating that he has sent a message.

comment:6 Changed 9 years ago by evands

Please select Ryan in the contact list and press the right arrow to expand his metacontact. Does the appropriate contained contact show the unread message indication?

Are you expecting a background color change or an icon?

Changed 9 years ago by themadrussian

Yep - when expanded it works. I am expecting the entire contact to change the background color to blue, just like it used to.

comment:7 Changed 9 years ago by cepheid

Just FYI, bug #14493 is also not fixed in v1.4.1... same issues.

comment:8 Changed 9 years ago by Robby

  • Milestone changed from Adium 1.4.x to Adium 1.4.3
  • Severity changed from normal to regression

comment:9 Changed 8 years ago by evands

  • Resolution set to duplicate
  • Status changed from new to closed

comment:10 Changed 8 years ago by evands

Closed as duplicate of #14493.

comment:11 Changed 8 years ago by Robby

  • Milestone Adium 1.4.3 deleted
Note: See TracTickets for help on using tickets.