Adium

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#14522 closed defect (fixed)

Disable transcription for Twitter timelines

Reported by: boredzo Owned by: zacw
Milestone: Adium 1.4.2 Component: Service/Twitter
Version: 1.4 Severity: normal
Keywords: twitter statusnet transcription logging Cc:
Patch Status:

Description

Summary

We should either not transcribe timelines, or provide an option in the account's settings.

Steps to reproduce

  1. Connect a Twitter account.

Expected results

The timeline comes up as a group chat, but it is not transcribed.

Actual results

The timeline comes up as a group chat, but it is transcribed.

Regression

No.

Notes

No other Twitter clients do this that I'm aware of, and since (1) tweets are persistent, unlike IMs, and (2) tweets tend to come in in high volume, transcribing them does little more than waste space in the user's long-term storage.

Change History (4)

comment:1 Changed 9 years ago by wixardy

  • Milestone set to Adium 1.4.2
  • Resolution set to fixed
  • Status changed from new to closed

(In 030035dabb86) Add "Log only certain accounts", which lets you log only certain accounts, and add "Log secure chats" which (enabled by default) logs secure chats.

This was prompted by (for the first time evar!) using a Mac at work all day, and wanting my work chats logged but not my personal ones. I know, it breaks account/service/whatever agnosticism, but hey, whatevs. Encrypted chats not being logged has been a popular request for a while, and I was in here anyway.

Defaults to not "log only certain accounts", and accounts default to enabled for logging.

Take the opportunity to backport [da70be37dabb] as well, which renamed "Save open chats when quitting" to "Reopen chats from last time on startup".

--

Use #8 for more fine tuned control e.g. still log DMs.

comment:2 Changed 8 years ago by mark

Last edited 8 years ago by edr1084 (previous) (diff)

comment:3 Changed 8 years ago by mark

Last edited 8 years ago by edr1084 (previous) (diff)

comment:4 Changed 8 years ago by mark

Last edited 8 years ago by edr1084 (previous) (diff)
Note: See TracTickets for help on using tickets.