Adium

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#14484 closed defect (fixed)

Group chat bookmark icons do not show in chat window

Reported by: claytron Owned by:
Milestone: Adium 1.5.3 Component: Adium UI
Version: 1.4 Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description

Summary

When creating a jabber group chat bookmark, you can assign it an icon. This icon only shows in the contact list, not the chat window.

Steps to reproduce

  1. Click "File -> Join Chat Room..."
  2. Enter the chat room name
  3. Click "Join"
  4. Right click on the group chat in the chat window
  5. Select "Add Bookmark" and "Add"
  6. From the contact list right click and "Get Info"
  7. Drag an image on to the card to set an icon for this bookmark

Expected results

The icon should show in the contact list and in the group chat list. This way it is easy to recognize the chat room in the list of active chats.

Actual results

The icon only shows in the contact list. All group chats still show a "lightbulb" icon.

Attachments (2)

chat_list.png (23.4 KB) - added by claytron 6 years ago.
contact_list.png (15.0 KB) - added by claytron 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by paradoxmo

Why do we have that icon thing there anyway? I assume you're talking about the first button on the left side in the toolbar? It seems utterly useless to have a button that drops down to show the larger version of the same picture...

Changed 6 years ago by claytron

Changed 6 years ago by claytron

comment:2 Changed 6 years ago by claytron

I'm talking about the contact list:


VS. the chat list:


comment:3 Changed 6 years ago by jas8522

  • Resolution set to wontfix
  • Status changed from new to closed

I don't believe the icon should take over for every user on that IRC channel - it just doesn't make sense since that image has no reference to any of the specific users.

comment:4 Changed 6 years ago by jas8522

  • Milestone set to Adium bugs
  • Resolution wontfix deleted
  • Status changed from closed to new

My apologies - it's the tab in the chat window that corresponds with the bookmark that you are referring to, not a userlist.

comment:6 Changed 5 years ago by Robby

  • Patch Status set to Needs Dev Review

comment:7 Changed 5 years ago by Andreas Marienborg <omega@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In eac298cb768a) Attempt to fix #14484: Wrong group chat icon on tabs

The lookup of contact information when getting images was not consistent with
how it was done elsewhere in the same file. Changed it to special case
isGroupChat here as well, and the images showed up.

Fixes #14484, r=xnyhps

comment:8 Changed 5 years ago by Thijs Alkemade <thijsalkemade@…>

(In 9f195727e81d) The fake toolbar item that is actually just an image now also shows the bookmark's image, if it has one.

Refs #14484

comment:9 Changed 5 years ago by Robby

  • Milestone changed from Adium bugs to Adium 1.5.3
  • Patch Status changed from Needs Dev Review to Accepted

Thanks! :)

Note: See TracTickets for help on using tickets.