Adium

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14483 closed defect (notadiumcode)

no longer compatible with Xtra : MSN plus ?

Reported by: perfecto Owned by:
Milestone: Component: Xtras
Version: 1.4 Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by Robby)

Summary

the "custom smileys" submenu doesn't show up anymore in the menus / chat windows, since the new 1.4 update.

Steps to reproduce

Detail the exact steps taken to produce the bug. Use the following format, each line with " 1." before it: version 1.3

  1. update to 1.4
  2. launch app
  3. find out that the upgrade has maybe fucked all the smileys you took time to customize with msn plus >>> the menu doesn't show up anywhere anymore and custom msn smileys are not working anymore

Expected results

I always expect a new version to work BETTER, not remove some already limited features

Actual results

I regretted I didn't stay on an older version as usual

Regression

occurs all the time, even after reboot

Notes

always make new versions EXTREMELY more IMPRESSIVE than the previous ones
hire me to direct this team
one more time and I change messenger

good luck
for the love of GOD

Change History (7)

comment:1 Changed 6 years ago by sphynx

  • Resolution set to notadiumcode
  • Status changed from new to closed

You should contact the author of the plugin and request they update it for 1.4.

comment:2 Changed 6 years ago by Robby

  • Description modified (diff)
  • Patch Status Accepted deleted

comment:3 Changed 6 years ago by perfecto

it is extremely important that the way Adium is programmed from scratch should always allow all developed plugins to constantly work whatever modification you make on the code.
if it is not the case, this means you are using a very unsteady and messy structure
this is an extremely important thing you will now have to think about
thank you to me

comment:4 Changed 6 years ago by David Munch

Since you clearly show incredible skills at coding, I would like to appoint you as lead developer. But first, please attach your patch where you remedy this current issue by restructuring the internals of Adium.

comment:5 Changed 6 years ago by perfecto

I only provide this kind of services for extremely wide amounts of cash flows | I have contacted the programmer of MSN plus in the meantime... have a good evening
for the love of god I spent an entire day with no smileys
it better be fixed when I wake up tomorrow
this is extremely big discomfort in my outstanding life of glory
peace
god

comment:6 Changed 6 years ago by zacw

I don't know what the issue is, but it's possible the plugin was not written correctly, as well. Don't immediately jump to Adium being at fault. However, there were significant architectural changes in 1.4, and there's _no guarantee_ a 1.3 plugin will work in 1.4, doubly so since I'm betting it's doing libpurple-level hacks and other things.

comment:7 Changed 6 years ago by zacw

Haha, even more awesome.

A 1.4 compatible MSN plus plugin has been available for months.

Check out http://adiumxtras.com/index.php?a=xtras&xtra_id=7005 to grab it now.

Hopefully we can add Xtras updating to a future version, but for the moment it's your responsibility to make sure you're up to date, or hound the author about adding Sparkle updating to their bundle.

Note: See TracTickets for help on using tickets.