Adium

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#14480 closed defect (fixed)

Message style "mockie" broken on some systems

Reported by: masc Owned by: mathuaerknedam
Milestone: Adium 1.4.1 Component: Message View
Version: 1.4 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

On my MacPro OSX 10.6.4 the message style "Mockie" is broken since updating to Adium 1.4.

Steps to reproduce

  1. Update to Adium 1.4
  2. Select Mockie message style

Expected results

Correct style

Actual results

Messages appear on white background without any style/formatting (see screenshot).

Regression

Downgrading to 1.3.10 resolves the issue. The problem is not related to user profile, I created a new user account for testing Adium, the issue persists. On a different machine (MacBook Pro running 10.6.4) style works fine and I cannot replicate the problem.

Notes

I'm aware that this might be difficult to fix, since it cannot be reproduced on any system. Please let me know which additional info you need to trace it down.

Attachments (2)

Screen shot 2010-11-02 at 03.11.32.png (133.4 KB) - added by masc 9 years ago.
broken mockie in prefs
Screen shot 2010-11-02 at 03.12.03.png (69.8 KB) - added by masc 9 years ago.
broken mockie message view

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by masc

broken mockie in prefs

Changed 9 years ago by masc

broken mockie message view

comment:1 Changed 9 years ago by mathuaerknedam

For some reason Adium isn't loading the message style CSS. Please try changing to another message style (like Smooth Operator) and then back to Mockie. That should force Adium to reload everything all of Mockie.

comment:2 Changed 9 years ago by Robby

  • Status changed from new to pending

masc, please see if that works for you or whether the problem remains.

comment:3 Changed 9 years ago by masc

  • Status changed from pending to new

yes, I already switched between different themes, doesn't help.
Also odd that something apparently fails, but there's no log entries.

One remarkable difference between the two systems is the one showing defective behaviour uses case-sensitive HFS+, while the other one does not. If a file can't be loaded, maybe something is misspelled.

comment:4 Changed 9 years ago by mathuaerknedam

  • Owner set to mathuaerknedam

Ah, that's probably it. Case sensitivity isn't well tested, and often breaks things. If that's the cause I should be able to find and fix the problem.

comment:5 Changed 9 years ago by mathuaerknedam

  • Resolution set to fixed
  • Status changed from new to closed

(In a9237108d80c) Mockie: Re-add Mockie to (crudely) resolve issue on case sensitive filesystems. Fixes #14480.

comment:6 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.1

comment:7 follow-up: Changed 9 years ago by SimR69

Still having a white background with the message style "Mockie" in Adium 1.4.1, when checking the option "Show received message colors".

comment:8 in reply to: ↑ 7 Changed 9 years ago by mathuaerknedam

Replying to SimR69:

Still having a white background with the message style "Mockie" in Adium 1.4.1, when checking the option "Show received message colors".

This a is a separate and unrelated issue. Please open a new ticket for it.

Note: See TracTickets for help on using tickets.