Adium

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#14454 closed defect (fixed)

Remove Link appears twice in context menu

Reported by: DarthShrine Owned by:
Milestone: Adium 1.4.2 Component: Adium UI
Version: 1.4 Severity: minor
Keywords: Cc:
Patch Status: Accepted

Description

Summary

When HTML text that contains a link is pasted into the input box, it is formatted as a link in Adium. Upon right-clicking this link, the context menu contains the item "Remove Link" twice.

Steps to reproduce

  1. Select text from a webpage containing a link
  2. Paste into an Adium chat
  3. Right click on the link

Expected results

Only one "Remove Link" item should appear in the context menu

Actual results

Two "Remove Link" items are in the context menu

Regression

Using Adium 1.4 on Mac OS X version 10.6.4

Attachments (3)

Screen shot 2010-11-01 at 9.59.31 AM.png (17.4 KB) - added by DarthShrine 9 years ago.
Screenshot of the context menu
Context menu link in Adium.png (98.0 KB) - added by ShawnRisk 9 years ago.
Context menu link in Adium
removelink.diff (627 bytes) - added by ShawnRisk 9 years ago.
Get rid of extra Remove Link Item

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by DarthShrine

Screenshot of the context menu

comment:1 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.1
  • Severity changed from normal to minor

Thanks!

comment:2 Changed 9 years ago by paradoxmo

Seems to happen in Snow Leo and not Leo-- I don't see it on 10.5.8.

Changed 9 years ago by ShawnRisk

Context menu link in Adium

comment:3 Changed 9 years ago by ShawnRisk

I got Robby to test out this in 10.5 & 1.4 Final and he is getting a different problem. He is getting two "Link bearbeiten..." meaning "Edit link..." and not sure why.

I heard from evands in IRC that we can do [NSApp isOnSnowLeopardOrBetter] to clear this error, but if this is happening in 10.5 I am not sure we can do this.

comment:4 Changed 9 years ago by Robby

  • Milestone changed from Adium 1.4.1 to Adium bugs

I don't think this is an issue introduced by 1.4 so I'm moving this away from 1.4.1.

If you manage to fix this, Shawn, we can still move it back.

comment:5 Changed 9 years ago by wixardy

  • Patch Status set to Needs Changes by Author

That looks like a patch to a patch, i.e. not complete. Also, try

if (![NSApp isOnSnowLeopardOrBetter])

Changed 9 years ago by ShawnRisk

Get rid of extra Remove Link Item

comment:6 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 42f17d17845e) Patch from ShawnRisk to remove an extra "Remove Link" on 10.6. Fixes #14454

comment:7 Changed 9 years ago by wixardy

  • Milestone changed from Adium bugs to Adium 1.4.2
  • Patch Status changed from Needs Changes by Author to Accepted
Note: See TracTickets for help on using tickets.