Adium

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#14452 closed defect (fixed)

Adium strangely flashes the name notification in dock

Reported by: jackeill Owned by:
Milestone: Adium 1.5 Component: Events
Version: Severity: normal
Keywords: dock, notification, icon, flashing Cc:
Patch Status:

Description

Summary

Adium strangely flashes the name notification in dock. As shown in: http://dl.dropbox.com/u/1196561/2010-10-31%2023-27.mov

Steps to reproduce

Happens everytime I get new message. Strangely, after downgrading to 1.3.10 this still occures until I delete the user profile - on a new one works fine.

Expected results

Name notification doesn't flash.

Actual results

Name notifications flashes and makes user epileptic.

Regression

Versiomn 1.4

Attachments (1)

adium_icon_flashing.mov (78.6 KB) - added by jackeill 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by jackeill

Attachment: adium_icon_flashing.mov added

comment:1 Changed 10 years ago by kabirakhtar

yes, i am having the same problem as well, only since installing 1.4.

the adium icon flashes very strangely, no longer in an even, rhythmic way. it is as though when the icon cycles through an animation, whenever the animation starts over, the text flashes for that one frame of the animation, instead of for half of the animated frames.

note: the ADIUMY icons appear to work properly. perhaps this is because they only have two frames in their animation: flapping, and not.

further explanation: say the dock animation lasts for, say, 6 images (duck flapping, etc). the name of the person who has IMd me used to flash white for 3 of those images, and then colored for the other 3. now, in 1.4, it flashes white for 1 of those images, and is colored for the other 5, resulting in a very distracting effect.

i can replicate this problem with the following installed Xtras:

also, a slightly different problem occurs with the "AdiumIcon" dock Xtra. (http://www.adiumxtras.com/index.php?a=xtras&xtra_id=7365) it only has two frames in its animation, but appears to blink VERY quickly, much more so than one would expect.

looks like something was changed in "dock icon bounce behavior/speed" in 1.4 and broke this.

comment:2 Changed 10 years ago by Frank

Ticket #14488 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by Robert

comment:4 Changed 10 years ago by Frank Dowsett <wixardy@…>

Resolution: fixed
Status: newclosed

(In add0c83648a5) Massive changes to dock icon drawing:

  • Use NSDockTile for badging fixes #13439
  • Remove flashing of the contact name* fixes #14452
  • Use a constant size instead of the current screen's size fixes #13088

Fixes #616

*It's superfluous and may have been broken in 1.3 based on the reports from after 1.4 was released.

comment:5 Changed 10 years ago by Robert

Milestone: Adium 1.5

comment:6 Changed 9 years ago by CC

I guess there's no chance of getting this back. I've got 1.5b2, and I'm missing notifications now because they're not getting my attention. A option to continue flashing the contact's name would be nice…

Also, I can't read the contacts name because my dock icon is tiny, but that's not something I'm super picky about, as long as it gets my attention.

Note: See TracTickets for help on using tickets.