Adium

Opened 10 years ago

Closed 9 years ago

#14432 closed defect (fixed)

Updating Adium switches profile

Reported by: CompC Owned by:
Milestone: Adium 1.4.2 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

After updating to Adium 1.4rc2, all of my settings were reset to the way they were on April 24, 2009. My chat transcripts were also erased so I have nothing past that date. I'm on Mac OS 10.6.3.

Change History (18)

comment:1 Changed 10 years ago by Robert

You updated from which version?

comment:2 Changed 10 years ago by CompC

I'm not sure… I usually just update when it says to update and I don't pay attention to the version numbers.

comment:3 Changed 10 years ago by Robert

Looks like even your tweet was more elaborate than this "report". :P

Were all preferences lost or just the ones that are in the "Messages" pane of Adium's preferences?

comment:5 Changed 10 years ago by Evan Schoenberg

Please check ~/Library/Application Support/Adium 2.0/Users. Do you have multiple folders listed there?

comment:6 Changed 10 years ago by Evan Schoenberg

Also: Were your settings reset to some custom settings from April 24, 2009? Or were they reset to the default?

comment:7 Changed 10 years ago by CompC

Yes, there are two folders, CompC and Default. My settings were reset to exactly how they were on April 24, 2009. So the contact list style and colors, menu bar icon, dock icon, message view, sounds, etc. are now just how they were then. The same thing happened a few years ago.

comment:8 Changed 10 years ago by CompC

I replaced the Logs folder from Default with the Logs folder from CompC and all my chat transcripts are back. My settings still aren't though.

comment:9 Changed 10 years ago by CompC

I just replaced the whole Default folder with the CompC folder and everything is back to how it was.

comment:10 Changed 10 years ago by Evan Schoenberg

Resolution: worksforme
Status: newclosed

Good. That's what I was going to suggest and why I asked about the two folders. For some reason, Adium lost track of the fact that you had renamed the overall user account to CompC, and it recreated a Default user account. Glad to hear everything is up and running again.

comment:11 Changed 10 years ago by Raphaelo Casanova

but happen to me ¾ times since all the new updates lately some update use in ~/Library/Application Support/Adium 2.0/Users/ "DirtySkeMe" as a folder for store all my setting and other update use “Default” just have to change the name of the folder depend on the update it might be something between beta and build updates maybe don’t really know

comment:12 Changed 10 years ago by Evan Schoenberg

Resolution: worksformefixed

(In f1997d7125f5) Add a RELEASE_BUILD preprocessor directive, and don't use a separate user name for beta builds. Fixes #14432

comment:13 Changed 10 years ago by Robert

Milestone: Adium 1.4.2
Summary: Updating to Adium 1.4rc2 reset settings and chat transcripts to how they were on April 24, 2009Updating Adium switches profile

comment:14 Changed 10 years ago by Robert

Fix added for Trunk: 77be2b0e69e0.

comment:15 Changed 9 years ago by Robert

Milestone: Adium 1.4.2Adium 1.4.3
Resolution: fixed
Status: closednew

DirtySkeMe reported on IRC that this is still happening. http://forums.cocoaforge.com/viewtopic.php?p=129568#p129568 confirms this.

comment:16 Changed 9 years ago by Robert

Milestone: Adium 1.4.3Adium 1.4.2

Oops

comment:17 Changed 9 years ago by Thijs Alkemade <thijsalkemade@…>

(In 355bff287503) When running a Release-Debug build, store the profile used correctly as the normal profile instead of the debug profile.

Refs #14432

comment:18 Changed 9 years ago by Thijs Alkemade <thijsalkemade@…>

Resolution: fixed
Status: newclosed

(In 9b3686f7a1c9) Actually set RELEASE_BUILD for Release and Debug-Release.

Fixes #14432

Note: See TracTickets for help on using tickets.