Adium

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#14357 closed enhancement (fixed)

Double Confimation/Alert when Removing Jabber Account from the Server

Reported by: xmppjingle Owned by:
Milestone: Adium 1.4.2 Component: Service/XMPP (Jabber)
Version: 1.3.10 Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description (last modified by Robby)

Summary

Adium is not confirming and alerting the end user properly about deleting account at the server.

Steps to reproduce

  1. Add a Jabber Account.
  2. Login
  3. Go to Account manager panel
  4. Click on "-" to remove the account
  5. Click on "Delete and Unregister"

Expected results

An Alert explaining that the account will be removed also from the server, "Do you want to continue?".

Actual results

Account is removed from Adium and also Jabber Server.

Regression

Always

Notes

This is critical for new Adium Jabber users, I already heard several reports of people loosing accounts, and stopping using Adium due this.

Attachments (2)

adium_jabber_confirm.patch (981 bytes) - added by xmppjingle 9 years ago.
Patch to Include an extra COnfirmation Dialog Explaining the Behavior and Risks.
adium_jabber_confirm_new.patch (1.9 KB) - added by xmppjingle 9 years ago.
New Pacth With Extra Check when Account not logged in

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by xmppjingle

Patch to Include an extra COnfirmation Dialog Explaining the Behavior and Risks.

comment:1 Changed 9 years ago by Robby

  • Description modified (diff)
  • Milestone set to Adium 1.5
  • Patch Status changed from Initially Included to Needs Dev Review

Cool! :)

comment:2 Changed 9 years ago by sphynx

  • Patch Status changed from Needs Dev Review to Needs Changes by Author
  • Status changed from new to pending

Hey, nice to see you've finished your patch. :)

But this will only show the warning when the account is online at the moment of deletion, are you sure that's what you want to do?

Changed 9 years ago by xmppjingle

New Pacth With Extra Check when Account not logged in

comment:3 Changed 9 years ago by xmppjingle

  • Status changed from pending to new

Attachment (adium_jabber_confirm_new.patch) added by ticket reporter.

comment:5 Changed 9 years ago by xmppjingle

Added new Version of the patch with enhanced behavior to also cover Alert, when user is not logged id.

comment:6 Changed 9 years ago by paradoxmo

Ticket #14355 has been marked as a duplicate of this ticket.

comment:7 Changed 9 years ago by xmppjingle

Needed changes already submitted. Waiting for feedback.

comment:8 Changed 9 years ago by paradoxmo

  • Patch Status changed from Needs Changes by Author to Needs Dev Review

comment:8 Changed 9 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 603694d9bafb) Double confirmation is now required to delete and unregister an IRC account. Based on a patch from xmppjingle.

Fixes #14357

comment:9 Changed 9 years ago by Robby

  • Patch Status changed from Needs Dev Review to Accepted

Needless to say, that is supposed to read "XMPP", not "IRC".

Thanks, xmppjingle!

comment:10 Changed 9 years ago by Thijs Alkemade <thijsalkemade@…>

(In ffae91fa6b57) Double confirmation is now required to delete and unregister an XMPP account. Based on a patch from xmppjingle.

Fixes #14357

comment:11 Changed 9 years ago by Robby

  • Milestone changed from Adium 1.5 to Adium 1.4.2

This was also applied to 1.4.2. :)

Last edited 9 years ago by Robby (previous) (diff)
Note: See TracTickets for help on using tickets.